Freezing and crashing in Roku players

Well, it’s interesting you guys/gals are having issues with the 3x scrubbing.

I wish that were what I see, I don’t even have to touch the remote!

Commercial skip zips ahead and hangs, so I have to believe Tablo can fix that! I appreciate that it might be a challenge to reproduce, since it only happens once every 20 show. Still, it needs to be taken seriously and investigated.

Roku 4800X - 11.0.0 build 4193-C2

At first thought this problem was only a commercial skip issue too. But then it’s happened to me several times when I was fast forwarding. It doesn’t seem to matter whether the thumbnails are intact or blank.
FWIW - I have not tried to recreate the problem to see if it’s repeatable for me.

TL;DR; My take on what may be causing the freezing Roku players…

Somewhere in the command & response protocols between the Tablo & Roku, there is a situation occurring, or a race condition, that is causing either the Tablo or Roku to be left waiting for an acknowledgement or some data.
I’ve seen this happen when software updates make the code “more efficient” or “faster”.

The classical situation in a “real-time” client/server environment is that the client makes requests, and the server obeys. The client says “fast forward please” and the server response “here’s your next point to resume playback”.

If the server (Tablo) can keep up with demands from the client (Roku), the client is making requests such as:

Fast forward

Fast forward

Fast forward

And the server fulfills each demand shortly thereafter.

The critical word here is “shortly”.

Should requests be made at a speed which the server cannot abide, due to latency arising from hard disk delays or other Tablo resource issues, the client gets ahead in a way which ultimately breaks the essential synchronization between the two computer systems, Roku and Tablo.

If the hardware supports it, which the Roku does not, interrupts can be used to pend / delay The second and subsequent client request until the first one has been fully satisfied.

In systems where interrupts do not exist, a software approximation can be achieved using semaphores, locks, or flags to signal completion by one computer before the other computer starts another request cycle.,

Without these essential controls, the “race” problem arises where the receiving server needs to complete its service before the client makes the subsequent demand, and, if insufficient time waiting to send the next command is permitted, then premature sending takes place, and the synchronization breaks the lock step.

Although buffers can be constructed to attempt to overcome the race, the potential for loss of synchronization is not entirely mitigated.

Absent the availability of software semaphores or hardware interrupts,classical technique to solve such a problem is to slow down the requesting
so that enough time will ALWAYS be available for the worst case delayed server response. This solution unfortunately brings with it a penalty in scrubbing speed, making the whole process appear sluggish.

A similar situation arises when file deletion is requested by the client and the server needs to first stop recording, wait briefly, and then delete the file. This problem arises specifically when deleting files which are cURRENTLY being recorded.

Once again, a potential race situation is created.

If the server has not fulfilled the first step to stop the recording, and attempt to process the delete request prematurely, errors in improper file deletion then arise.

Not surprisingly, both for the case of incomplete file deletions leaving ghost icons on the Tablo desktop, as well as freezing and crashing problems when scrubbing have both occurred for months until the Tablo software added long and noticeable delays to these two processes. In the case of file deletions, there was never any dismissive finger-pointing by Tablo. In the case of freezing and crashing of the Roku however, Roku became the long awaited solution for many months with most attention, distraction being pointed to Roku. I am just trying to get back to a properly working solution here, and see similar issues and attitudes reoccurring over nearly 8 years of ownership of Tablo, much to my frustration.

gGood software people with the proper tools to analyze packet traffic, look at Netwerk activity, and use debuggers to step through these processes can quickly see and correct these problems, but only if they can be reproduced. Although many of us are experiencing these problems frequently, it is not consistent as a failure mode to the extent that beta testers or software quality assurance people can easily provoke.

A simple and very informative alternative is to temporarily insert time delays, typically using instructions in the code which are affectively wait/“no-ops” to slow things down, minimize the opportunity for a race, and see if this fixes the issue for all the users who are complaining. It takes very little time and very little coding effort, and need not be pushed out to all users. This is a much better and more proactive approach than waiting for Roku to bring out another release.


One other point:

A new and clearly erroneous branch in the Tablo app program is now visible which never occurred up until the latest app release:

When exiting playback using the “back button”, the normal way to quit playback, notice that a brief screen appears showing the dialog button choices available to start the playback process. It flashes on the screen briefly and then disappears.

It makes no sense logically that the program would branch back to this starting position display, and it only remains on the screen for a short period of time.

Clearly a mistake was made in programming. This is not a Roku problem whatsoever. It indicates a sloppy approach to programming as well as beta testing and quality assurance.

Just saying…

Obvious;y too much lysergic acid diethylamide in the 60’s.

With Roku OS 11 you might notice this - which I don’t remember on the previous Roku OS’s.

If you are recording a show and want to watch the recording - not current recording position. You go to the recordings menu and play the recording. If you pause the recording playback a “Rewind live TV” pops up on the left side of the scrubber. It’s not really Live TV. I was watching the PGA Open and was 3-4 hours behind the current live TV recording.

Great comment, Zippy!
This new Tablo bug will be called “the Flashback feature”!

Here’s the workaround I am using (until Tablo fixes this issue). Restart your Roku before you start watching the recording (Settings > System > Power > Restart). The issue goes away at least for that viewing session (until it reappears again but not in the same session).

In the past few weeks we have been experiencing the same issue with our recordings. It appears to give us the black screen at least several times during the recording. Like others, I hit the ‘back button’ on the remote and it takes me back to the original screen for the record and I just hit “Resume” and things are fine. After I hit “resume” it will take me back to where the black screen appears.

Live recordings never had issues until this past week when it was occurring repeatedly during a live show. If you waited long enough it would go away and the show would resume at the point when the black screen appeared.

Sure hope Tablo software people are able to isolate and create a patch. This kinda reminds me of the old “Blue Screen of Death” with Microsoft!

My system info is:
OS 11.0 build 4193-46 on my Roku Ultra 4660X. Currently connected through WiFi.
TABLO - Firmware - 2.2.40 Unit is currently connected to a T-Mobile 5G Wireless gateway. The issues with the black screen/circles started on my live broadcasts when I went to Wi-Fi last Thursday (May 19th). Plan on calling Tablo tomorrow (May 24) to have them help me change back to hardwire onto the wireless gateway box.
Roku App - 2.19.1

Have a Roku Ultra on the latest software and a few times I’ve run into the issue where you forward a Tablo recording (to jump over commercials) and you get a black screen with a rotating circle when trying to resume playback (stop/replay gets past this). I thought it was exclusively a Tablo issue but just had it happen with YouTube (exact same scenario and rotating circle screen).

Tonight, Tablo worked beautifully with no problems despite frequent scrubbing. Switched to YouTube, hoping to see it fail, but it too worked well.

Strange how this bug seems so frequent on some occasions, and virtually disappears on others.

Beginning to wonder if some memory management, garbage collection, or messed up pointers or linked lists are involved here. The evidence seems to be no problems when first starting, sometimes eventual corruption with continuous problems, and eventual crash. Then the reset starts the cycle over again. Memory leaks or other resource starvation rather than race situations are usually the cause.

I will go back and try YouTube again. So many commercial interruptions, for which no scrubbing is permitted, makes a comparison to Tablo a bit challenging.


I spent hours on Tuesday and again this morning trying to get YouTube to misbehave on my Roku players.

I could never get it to show any of the freezing and crashing I experience on Tablo.

I will keep trying, but it certainly does not appear even once so far.

I actually hope that the problem we are seeing on Tablo does occur on YouTube. My reasoning is that YouTube and Roku are both extremely popular, get used by millions daily, and would generate frequent complaints if this problem existed. This would force Roku to fix the problem, if in fact it really is based on Roku programming mistakes.

Time will tell…


Some more info for the Tablo folks on this subject. The black screen with the spinning circle is also present when I go into the guide for “TV Shows”. Certain Genres that likely have large numbers of shows never open. I just get the spinning circle. So far I can produce this with Genres “Entertainment and Sitcom”. That was yesterday. Today Sitcom is working ok, but Entertainment is still just the spinning circle. This is with a Roku Ultra.

Yesterday most would open but some took forever. Today most seem to be working as usual.

Everyday I access a live channel on Tablo to see how long it will take for the “black screen/rotating circle” will appear and how often it happens. It seems that the time and space vary each time I access a live channel and it really upsets my wire in trying to watch the news or any other show. This morning I tried to watch a recorded show from last night. It was loaded with “black screens/rotating circles” throughout the recording. I am hoping that either Roku or Tablo will realize there is a problem and provide a fix. Also, my wife watches You Tube a lot after I go to bed. So far she hasn’t complained about getting the “black screen/rotating circle”. Also, another strange situation with the “black scree/rotating circle” is about the same time this started we haven’t had any issues with the recordings passing the commercial skip feature. Prior to this time we were only seeing about 10% of the records passing the skip feature. Anything in common? Who knows!

Although my Tablo on Roku does act up, it’s very rare/intermittent - same with YouTube. So not surprised you can’t reproduce the condition, I don’t think I could either. :slightly_smiling_face:

I’m also seeing the recorded video jumping/glitching like stop/go very fast that was not happening before all these updates. 4630X Premiere 11.0.0 Build 4193-29 / 4670X Ultra 11.0.0 Build 4193-46

@TabloSupport @TabloTV
I’m still randomly experiencing this problem.
Is it still being researched? Is there a way the Tablo community can assist you?

Freezing and crashing of the Roku Tablo app continue on a daily basis here also.

In an attempt to find another app on Roku which has the same problem, I have become a heavy user of YouTube, since somebody here stated that YouTube was also freezing and crashing.

I have been using YouTube now for weeks on a daily basis, and have never seen it freeze or crash. Nor have I seen any other app on Roku behave like the Tablo app.

Since 2014 when I first joined this forum and first bought my original Tablo, I have seen this very same issue arise more than once.

I have posted literally hundreds of posts related to the specific type of problem over the years. I eventually purchased Apple TV and Amazon fire players and switched to them for only one reason, to avoid this Tablo bug.

I am personally convinced that the bug resides in software developed by Tablo, and further convinced that it relates to some resource starvation which provokes race between the Tablo and Roku processors. I have offered this theory recently as well as years ago when the same problem occurred for many months.

For the benefit of all of us who deal with this on a daily basis, I look forward to a statement from Ottawa letting us know what is being done to fix this problem.


I have encountered the “freezing” issue almost every time. I have gotten into a habit of “restarting” Roku before starting to watch every time to avoid this annoying problem.

My Roku box is rebooted every time I turn my TV/projector on.

Rebooting/restarting the Roku only provides very temporary relief. The same freezing problem begins very soon after restarts.