Freezing and crashing in Roku players

My Roku reboots at least once a day since this new bug arrived.

Frequent scrubbing definitely provokes the crashes.


Ditto for us last night. Started getting the spinning circle on our Roku Streambar 9102 running 11 9143-95.

Given that some folks are not seeing any problems, it would be good for those encountering issues to include the Roku OS 11 build number (the string of numbers in bold above) so we can see if there are particular build numbers that are affected.

my 4200 is running 11 4193-04. But yesteday they dropped/installed something called an update to the roku engine and the build numbers didn’t change.

Hmmm. We’ve seen a few references to that on other forums.

Let us know if that makes any difference to the performance.

That engine thing is to fix the RUM thing, doing update fixed for me. Solved: Roku Rum - Roku Microsite - Roku Community

It’s happening to me also. Roku express 4k, os 11 build 4193-CR.

I didn’t get any channel icon that said rum. But I did do another check for updates and had an update that was called “maximizing fun factor”.

How much more fun do I need?

4630X Premiere 11.0.0 Build 4193-29 / 4670X Ultra 11.0.0 Build 4193-46

Both my Roku Ultras updated a few days ago (my wife watches on Roku Streaming Stick Plus), and I haven’t observed any issues as of yet (and I am sure I would have heard about it if the wife did).

I have been experiencing similar issues with Tablo on Roku Ultra. It freezes the frame after skipping/forwarding the recording every time (although sound resumes). I have to get out and resume. Is Tablo aware of this issue and working on a fix? I have tried updating the app, uninstalling and reinstalling, restarting Roku, closing the app, etc. It appears to fix the issue for some time and comes back again. I have the latest Tablo firmware. Thank you.


Other than my brief issues Sunday night I have not had any since. That’s three days of four Judge Judy episodes per day plus three other shows, two an hour long the other two hours long. Manually skipping through commercials produced no problems.

Version 11.0 build 4193-46 on my Roku Ultra 4660X. Connected through WiFi.

Looking thru posts seems Ultras mostly freezing. Haven’t seen any with 3930X Express, Build- 4193-AE

I personally think that it is not especially productive trying to associate this issue with specific Roku players. My reasoning is as follows:

This problem appears across multiple players, some eight years old like mine, some new models recently released, and numerous ones in between these two extremes.

The problem may have more to do with the individual user scrubbing behavior, how often, how vigorously, and how much elapsed time since the last use of fast forward, fast reverse, etc.

My sense in viewing this is that yet another Roku incompatibility , which has plagued Tablo software developers since the inception of the Tablo product, has occurred here. I personally think it is a huge mistake to point to Roku, since I use numerous apps with perfectly fine scrubbing on a daily basis, and the problem only occurs with the Tablo app .

Waiting for Roku to solve this problem strikes me personally as being a dismissive attitude, and associating it with specific Roku players distracts attention from where the problem and the solution need to be fixed in Ottawa…

The most memorable Roku incompatibility which occurred several years ago took many, many months, at least six or eight, to fix. The crashing, freezing, and similar synchronization issue was there until the Tablo update was released.

I might add, parenthetically, that reports from those who are not having the problem really are not helpful. For any bug, there are those who are not going to encounter it, for a wide range of reasons. The entire point of debugging software and quality assurance is not to say that some or most of the users won’t be unhappy. The point is to release a product which works properly for all users.

Having very vigorously tested the latest Tablo firmware with numerous players from Amazon, Apple, iOS, Roku, and Nexus , most of which I purchased over the last eight years due to previous Roku incompatibilities totally ruining playback and spoiling what is otherwise a very good product, I am here to say that the problem needs to be solved by Tablo, in the Roku app, and that (for all seven players I have here from Roku), the bug can be demonstrated in about 15 seconds. It is not in anyway subtle, occasional, or easy to ignore.

The work around of using the back button only partially overcomes the problem, and I am once again thinking of buying additional players from a different, non-Roku brand, for my home locations where I only have Roku players and cannot use Tablo. My treadmill, my wife’s laundry area, our kitchen, and my office all use Roku players exclusively, as does our guest bedroom, and these five locations are basically now unusable AGAIN! I hate to spend $70 times five to get them equipped with Amazon cubes, or half that amount to put in less capable Amazon stick players, but all of my previous purchases of Apple, Amazon, and Nexus players along with returned Roku players of different types were all purchased for only one reason… to allow me to play Tablo without crashing and freezing over the last eight years.

If anyone is witnessing Roku problems with crashing and freezing on other apps, please let me know. I would love to try them on my Rokus here to confirm that the problem is showing up on other apps. I have no desire to falsely accuse/incriminate Tablo in this problem, but my past and current experiences have yet to give me any evidence that Roku is responsible here.


1 Like

@RetiredEngineer - Can you provide the specific steps to recreate the problem?

Using the fast forward and fast reverse at 3X, switching back-and-forth very frequently, usually will do it.

I say “usually” because it does not always happen, but very often does. I also think that there may be some correlation with recording quality, such that files which have poor/weak signals below the threshold used to determine if thumbnails will be generated seem more susceptible.

There also seems to be some possible correlation with other network traffic, but not really very repeatable. I have many devices on my network, now over 70 total, and cranking up my ethernet traffic seems to adversely impact Tablo freezing somewhat.

I have not gathered and recorded failure statistics, but what my intuition suggests fewer failures early in the day and more failures late in the day. My treadmill Tablo gets used early in the day, as does my wife’s laundry Tablo, and both seem comparatively stable when compared to the nighttime Tablos we use in our home theater and bedroom for evening viewing. The evening Rokus seem to be more susceptible and fail more consistently.


I have a Roku TV, running Roku OS 11 build 4193; Tablo firmware 2.2.40, Roku app version 2.19.1. The freezing doesn’t always happen, but here are the conditions when it is most likely to happen:

I am watching a recorded show that has the thumbnails generated (usually wait about 5 minutes until after the recording ends). I start watching the recording. I decide I want to skip ahead using the right-arrow button (which brings up the thumbnails). If I see a few thumbnails in a row that are blank and not fully rendered, possibly with a circle in the middle of the thumbnail, and I attempt to start playing at one of those thumbnails, it may freeze like others here have documented…that is, I hit OK on one of those incomplete thumbnails, and then the TV shows a blank screen with a spinning circle in the middle. I haven’t waited more than 30 seconds to see if it comes back. So I hit the BACK button to get back to the Tablo menu, and then I go to watch the show again and hit RESUME, and it usually works fine.

Since Roku OS 11 I’m seeing some 3X fast forward thumbnail freezing behavior of tablo recordings using roku. But I’m also see some of this during playback of DVR recordings from slingtv,

Maybe Ottawa can also fix the slingtv app.

I do not use slingTV, so I cannot compare performance, but all of the many channels /apps I use on Roku scrub without any freezing or crashing.

It is entirely possible that both Tablo and slinTV apps have bugs provoking the same freezing and crashing, and it is also possible that Roku has defective scrubbing which only shows up for very few apps.

I personally want to avoid yet another prolonged, unproductive, frustrating period of ownership of Tablo, with finger-pointing and waiting to see what Roku offers as “the solution”.

in larger and more mature software development, the programming team hands off the code to the software verification and validation people to perform software quality assurance, to avoid the problems associated with people being asked to critically examine and test the code they have written. So-called “ego-less programming” prevents the blind spots, defensiveness, and misunderstandings of the original programmer from finding and fixing bugs.

In smaller software developments in companies which are using less mature and more chaotic programming techniques, it can become more’challenging for those who are programming and checking their own code for bugs to remain objective.

Having been to this same rodeo more than once, I am hoping that this will be quickly remedied.

Update: This morning I was watching a recorded show, I did my usual right-arrow click to skip forward about 30 seconds, and after I hit OK (play), I got the blank screen with spinning circle…the difference this time is that the thumbnails were all visible and fully rendered. I decided to wait 60 seconds, but it didn’t come back. The usual remedy of hitting the BACK button and resume watching the recording worked.