Firmware release problem (2.2.6)? Roku access SLOW

Just updated Tablo to the new release update… I use Roku… and when I go “Recordings”, it just stays there saying “Retrieving Info From you Tablo”… for a LONG time… FINALLY it will go through. It wasn’t near this slow before the update. What’s going on?

1 Like

The first time you use the Tablo after the update might take a while since it is looking for lost recordings. It should be normal after that.

It’s been about an hour now. How much longer should it take?

Also, just noticed when using Chrome Browser through PC, it accesses everything at normal speed… (previous recordings, Live TV, etc). But when going through the Roku, it literally takes FOREVER to access ‘recordings’… and the only difference is the firmware release.

xxxx cccc xx cc

You’re right, even the preview channel is horridly slow regarding actually accessing the data. The “Official” Roku Channel takes approx 2 mins, 9 seconds to finally load my ‘recordings’. (I stood there with a timer). This is just about EVERYTIME. I certainly hope they fix this… as this is a deal breaker for sure.

That sounds miserable, I hope you get this fixed. Keep in mind, you don’t have to get rid of Tablo, there are other platforms like FireTV and Android TV which aren’t experiencing this bug.

It’s really too bad since Roku is supposedly the most ‘popular’ way people access the Tablo.

@Jay12 It definitely is the most popular, but I don’t think it’s the best. Android TV seems like the most full-featured, stable way to access Tablo at this point. This is coming from someone who used Chromecast and Roku 3 for around 8 months before settling on Android TV.

I think the order goes:

Android TV>Fire TV>Roku>Chromecast

I don’t have experience with Apple TV but in its current state I wouldn’t say it is in the running for the best. Perhaps once the native app is released for Apple TV.

@getcashmoney I wouldn’t doubt for a minute the ‘Tablo App’ is better on the those platforms you mentioned, however, Roku is the best ‘streaming player’ regarding content options. There is literally a large amount of channels on Roku that I actually use regularly that I can’t find anywhere else. Not to mention the private channels. With that said, it would be more of an inconvenience to buy something else JUST for Tablo… and have to switch back and forth between Roku and Android/Fire/etc. Roku pretty much has everything readily available… and then some. I suppose that’s why it’s the most popular. Regardless, thanks for the recommendations regarding which platform works best with Tablo. I will keep that in mind.

What I had done while the Tablo was updating to 2.2.6 was go to each device and remove the apps (Roku, phones, FireTV stick, and cleared the Chrome browser history/cache/cookies) and then once the Tablo was back up I reinstalled the apps to each device. I should note that I did not reinstall the original Roku channel, just the Tablo Preview channel and forced the new Tablo Roku update on them just yesterday or today. So far everything is working very well after doing that. Initially, it took about 30 seconds to load Recordings section on each Roku 3 but after that it was almost instant. There’s a chance it might improve things for you. Hope it helps.

I updated to 2.2.6 yesterday and when I went to the old Tablo app (not preview) it was taking 2-3 mins to load the recording using Roku 3. This was true for 3 or 4 tries on both Rokus, not just the first time. Everything in our house (three tvs, two Roku 3s, one Apple TV) are all wireless from two Apple Airport Extremes in each end of the house (extended network) using Centrylink DSL at 5.1Mbps. Should mention that the iPad running thru the Apple TV worked fine with 2.2.6! We have been able to use any combination of Tablo, Netflix and Amazon on any two tvs with little or no problems over the last year.

So yesterday after this problem I did a reset on the Rokus - pulled the plug for a min. This did nothing to solve the 3 min load for recordings. Then I did a complete reset of the network AND Tablo and then the recordings loaded in 10 secs - about 750 Gb of recordings. I should have done each one at a time, but was in a hurry and didn’t so I don’t know which one was the problem, but since iPad was working fine I think is was the Tablo that was the problem and not the network.

Now everything is working fine including the new Preview app. Maybe this is useful to someone. Cheers

1 Like

One thing I’ve noticed is since the update, the Hard Drive attached to the Tablo seems to be in constant motion… and there’s no access or recording taking place. Usually it would be ‘asleep’. So I don’t know if it’s doing some sort of constant indexing or what. Again, it used to not do this prior to the firmware upgrade.

Yeah resetting my network worked. Thanks

Hey folks -

If the reboot of network > Tablo > Roku doesn’t work to speed up your access, please let us know what version of the Roku channel you’re using, what edition of Roku you’re using (Roku3?) and what Tablo firmware you’re running.


“If the reboot of network > Tablo > Roku doesn’t work”.

I assume “network” means router. If so, do I need check with the router maker to see if new firmware available. If new firmware isn’t available should I contact them about a performance issue?

If it is a third party router (like a Netgear), then there should be a page in the router setup app that shows which firmware version you are on and if any new versions are available. I do try to keep my Netgear router up to date.

If it is your ISP’s router, there may not be anything you can do to update it yourself. Usually the ISP takes care of keeping it updated.

I don’t see any good reason to contact the router maker though. They won’t know anything about the Tablo.

Tried the reboots and it still takes 60-70 seconds for recordings to start playing. Live TV starts in 2 seconds.

  • Roku 3
  • Roku Preview 2.0.15
  • Tablo firmware 2.2.6
1 Like

I know all about router firmware update. @snowcat misses the whole point of the post. In multiple thread the actual company tablo is telling it’s users that something is wrong with the functionality of the users router and it needs to be rebooted. And that this is standard problem solving procedure.

If a user hasn’t been mucking around with the router settings then tablo is implying there must be something wrong with the router firmware/product. Why else would a router reset be needed?

Rebooting the rounter, the Tablo and the Roku in that order is the first thing people should do who are having the slow access problems. Tablo’s suggestion to do this has nothing to do with router firmware or faulty router equipment. Rebooting in that order is intended to make sure the 3 pieces of equipment are properly communicating with each other.