Fire TV issues with Tablo


#1

Anyone else have issues with video being jittery with Tablo on Fire TV? It works fine on Roku, but it’s jittery on our new Fire TV (pendant). Everything else works fine on the Fire TV.


#2

Known issue. This thread covers it pretty well.


#3

Thanks. I can’t believe this has been going on since November and Tablo hasn’t fixed it. Every other app works fine.


#4

I think this is a “combination” thing… it’s Tablo working with Amazon on a fix. And even then, it takes Amazon a VERY long time to allow stuff to get pushed out.

Not everything is Tablo’s fault, believe it or not.


#5

Yes, this sucks. I trust Amazon has invested interests in keeping the live TV out if possible, due to a relationship with TV manufacturers. It conveniently keeps them happy.


#6

We provided them with full documentation of the issue on January 5th, and bugged them about it again on February 12th citing bad reviews on their own product from frustrated Tablo users.

Two days later they said they were working on it and it’d be in the next update… Since then it’s been:

I’ve got a 4K Fire TV at my desk and boot it up every morning to check for an update.

As soon as we see it and confirm the fix, we’ll let everyone know.


#7

I understand this to a degree, but why would only one app be affected? Obviously there is something in the code that is making the two not play nice. Why would the impetus be on Amazon to change their firmware for one app maker? Wouldn’t that normally be the app makers responsibility? That’s a serious question, not being a smart aleck.


#8

Our app works just fine on all previous models of Amazon Fire TV hardware, so there’s definitely something different about the firmware running on this new model.

When we did send over the documentation (after trying in vain to find a workaround) we also asked for them to provide guidance on how we could provide even a temporary fix. Unfortunately they weren’t willing to reveal any of their secret sauce.


#9

Gotcha. I suspect it’s because the Fire TV (pendant) is the only one running Fire OS 6, which is based on Android Nougat, and all the others are on Fire OS 5, based on Android Jelly Bean. It’s possible that even Amazon doesn’t know what’s causing the issue since the code is so different between the pendant and every single other Fire device. That said, it’s still odd that DirecTV Now, Netflix, Hulu, etc. are all running just fine and it’s only TabloTV that’s running badly. Either way, I hope it gets resolved soon. I’ve had a love/hate relationship with my TabloTV since I got it, and this isn’t helping it’s case in my house.


#10

Has anyone tried installing Kodi on it? If so, is the add-on helping with any of those issues? That could help narrow down the issues with either the platform (the Android integration) or the app. Just a thought.