Failed to load. Item not found on each Channel

With Apple TV theres is no way to listen live tv,
With my iPhone its working,
I reboot , nothing is different ??
What can I do except a factory reset?
And my Apple TV updated is done, this problem start when the RECENT option on the guide appears!!

I am having the same issue. If you find a resolution, please reply. I’ll do the same.

found this in another thread…

Got the new update with the Appletv app. The Tablo connects, the guide comes up but when I click to start viewing a program, I get a “Failed to load. Item not found” message.

We have confirmed there is an issue with selecting the SHOW ID vs. the CHANNEL ID to begin playback of a live channel.

We’ll get working on a fix right away, but in the meantime if you select the CHANNEL ID from the live TV grid, you’ll be able to get playback going.

1 Like

I have this problem too.

Selection of Channel ID does work. Thanks for the workaround.

How do we notify Tablo. Is this forum being monitored?

Tablo monitors this forum and their other “contact us” methods during weekdays, office hours.

ok folks, i did the factory reset ,and it didnt change anything except that ,if you click on the channel number instead of whats playing in that channel its working!!, probably they will do a Tablo app updated later on to fix this!!
try it before the factory reset!!
sorry for my english!!lol

1 Like

Clicking on the Channel ID worked for me. Thanks so much! Hopefully the Show ID glitch will be fixed soon.

Same issue here.

Martin_Proulx… THANKS for the solution!!

I think it is too bad that Tablo doesn’t seem to have an oncall person working the weekends or after hours.

1 Like

We have the same issue. Funny as I just go ta new update on my iPhone. Wonder when it will all sync??

I’m having the same issue. Tried every troubleshooting technique I could think of. I have 3 Apple TV 4’s. I’ve tried restarting Apple TV, updating Apple TV, restarting router, and restarting Tablo. Each to no avail. The issue started right after Tablo was updated on Apple TV. I can only watch a show if I click on the channel. Only very few shows can I click on to record or view. On most shows, I get the “Failed to load. Item not found.” error. Hopefully someone comes up with a fix. Once again, I have the older Apple TV 4’s. Not the new ones that allow viewing of 4K. I hope this helps Tablo with their troubleshooting.

For now just click on the Channel ID on the left instead of the program!

They got free tech here on weekend :slight_smile:

LOL, true but can you fix the software issue? :joy:

1 Like

Same here. Failed to Load on Apple TV. Hopefully a software Fix is in the works!

Same problem here cannot select program in guide to record future programs or watch live tv with Apple tv4

A fix will be submitted to the App Store today.

In the meantime, you can begin playback of live TV by selecting the channel ID vs. show ID and schedule recordings via any other Tablo app including the web app at

1 Like

I’m a software engineer for aircraft avionics, it makes you look really bad when you don’t test your software first. Getting impossible to recommend your product with so many engineering failures