Even with FW update Roku still freezing and rebooting?

Video will stutter and then go to a black screen then Roku reboots. Happens randomly and seemingly without a good reason. Was hoping FW update would fix… Only started with new “public” interface. Preview app worked OK but still rebooted Roku when using FF but different symptoms? Remote will become unresponsive also. I have 4 Roku 3’s and they all do this. Lots of buffering while watching recordings.

1 Like

Exactly the problem I have. You detailed it perfectly.

I have this problem with my Roku 3500X MHL streaming stick… I can trace it back to the Roku software update to V7.0

The Tablo folks tell me that they are aware of the problem, but have verified it’s a Roku issue and they’re working with the Roku folks to resolve it.

The problem existed prior to the Roku FW 7.0. In fact, we were led to think the v7 upgrade would f fix it. I can watch any other channel on my Roku with no buffering and/or crashes.

1 Like

It was too painful to try to watch recorded shows on the Roku, because of the freezing/rebooting problem, so I bought a Nexus Player for my living room TV. It’s once again a pleasure to watch both live and recorded shows now, and the Tablo app on the Nexus Player is much more complete and much slicker than on the Roku. $50 at Best Buy.

Haven’t played with this enough on my other ROku streaming sticks, which are a different version, but from what little I have, they didn’t seem to have the problem. I think I erred in the description above… the 3400X definitely has a problem, and I can’t say for sure whether the 3400X does or not.


So,if it is a Roku problem why does it only affect the Tablo app? Doesn’t seem to happen with other apps…

Just a guess as to why the Tablo app doesn’t play nicely with Roku, is that when you’re using Tablo, you’re hitting buttons on the remote more often than you do with the other apps… when I watch Netflix or Hulu, for example, I select what I want to watch and then down’t touch the remote until I’m done watching the show. Maybe once in a while I’ll hit pause and then play, but that’s infrequent. When watching a recorded show on Tablo, every time there’s a commercial I fast forward through it, then hit play. That happens many times during the course of the show. Thinking maybe it was a memory issue, I deleted a bunch of Roku channels I rarely if ever watch, but that had no effect. It may well turn out to be a memory management issue after all… it would be interesting to watch a show in Netflix or Hulu, and frequently hit pause and then play to see if the problem can be reproduced there.

1 Like

We watch Acorn on Roku and my wife likes to go backwards and forwards on the mystery shows. Sometimes the British accent is hard to follow so she rewinds, pauses and resumes frequently. As a result we do get LPWs and crashes on Roku when viewing Acorn (Roku 3). On previous Rokus (from Roku XDS onward) Acorn would freeze quite often on FFs and we had to reboot the Roku. So my wife had to learn patience (and minimize use of the remote which was becoming dangerous) for Roku\Acorn.

As far as the LPWs on Acorn, I used to think that perhaps Acorn had poor servers that could not keep up with internet streaming. In the early days of Roku, the shopping channels such as HSN exhibited LPWs quite frequently.

That’s why I have not been surprised with Tablo’s difficulties with Roku after two years of struggles with Roku\Acorn. But those British mysteries (like Morse) are too good to pass up. Roku reboots on Acorn became “Let’s take a break and come back…”

1 Like

Then I guess the other thing to try is not fast forwarding through recordings on the Tablo… my guess is that the shows will play with no issues. It’s starting to sound like Roku software is not handling inputs from the remote correctly… either the input buffer isn’t big enough or they’re not managing the buffer correctly and overwriting something they shouldn’t. You’d think that would be something that’s easy to find and fix, but at any rate, if that’s what’s happening, then clearly Roku has to find and fix the problem. There’s nothing that the Tablo folks can do about it.

I mentioned in another thread (Roku vs Nexus Player) that I suspect that a real-time streaming device based on a scripting language may not be ideal for a platform. I spent years in factory automation in which real-time programming was essentially a time-based exercise. No one used a scripting language in that environment because an interpreted language has to continuously contend with time. Brightscript was designed by Anthony Wood to be as simple a development construct as possible for a streaming device using scripting techniques for “anyone” to use. That should raise some warnings to someone…

The more I see of Roku, the more I think of it as the “Windows” of streaming…and both are a success :wink:

1 Like

I suggest when one sits down to begin a lengthy viewing session using a Roku that they take a few moments first to execute a restart of the Roku. Perhaps some background threads are running that can affect the next program viewing and are cleared after a manual restart.

This seems to work well for me. Kinda like rebooting a PC that has been up for a while and starting to get sluggish.

I agree with @Wolfpack, a few years ago my Roku 2XS would restart often because of problems with the firmware. This was eventually resolved by Roku, but now with the V7 firmware the restarts are back. Especially bad with YouTube - watch 2 or 3 videos and the playback begins to freeze intermittently leading to the inevitable restart. Interestingly I have not had any restarts when using the Tablo Legacy app.

I agree with the restarts on Roku, and generally do that. Btw, the legacy Tablo app now suffers from the same problem with Roku V7.0

1 Like

@lkahhan, that used to be true. If I didn’t FF or RW I had no crashes/freezes. Now, with 2.2.8 I get freezes while I’m simply watching. Remote isn’t even in my hand. :fearful:

1 Like

Ohhhh,that I haven’t tried. I’m always anxious to FF through the commercials. In my case, it didn’t start until Roku V7.0, but I did verify this morning that the both versions of Roku I have, the 3400X & 3500X streaming sticks have the same problem. On the other hand, I now have a lot of time in on the Nexus Player, and Tablo is a pleasure to watch now on the living room TV. I hated to have to spend the $50 on my setup for yet another streaming player, but it works really well with Tablo. I still have Rokus on the bedroom TVs, but don’t watch them nearly as much, so I’m willing to live with them and hope that the Roku problem will be fixed in the near future.


Same here; I have Rokus in four rooms and I hate the idea of replacing them with a stable, efficient Android based device (now that sounds funny). For my neighbor’s setup, as I mentioned elsewhere, I recommended the Nexus Player in setting him up with a Tablo and he hasn’t had a problem in three weeks. This forum would be a mystery to him :astonished:

I feel that my wife and I have grown up with a problem child (the Roku) and won’t toss it out despite the emotional “reboots” (ours!) living with its disfunctional ups and downs. We’d miss the little miscreant…

Some families have well behaved kids, others don’t LOL…

One of the reasons I don’t ditch an old Roku I have in my office is that it has the old fashioned component-out connection. This allows me to hook it up to the Hauppauge PVR device to record whatever the Roku is playing at HD resolution (though not as good as HDMI but good enough). Been able to record a lot of 48 hour “rental” movies from Netflix and Amazon…

I’m hanging on to an old Roku 2 XD for similar reasons, tho it’s currently in the spare equipment box… composite video and audio outputs, in addition to HDMI gives me a little more flexibility should I need it. In a pinch, I could patch it into my old DVD recorder. A little clunky, but it works.

Of course, just as General Hospital isn’t your video, I make sure to delete those 48 hour rentals I record after watching them :wink:

So why is my Roku 2 XD not exhibiting the same issues so many of you are experiencing? It never freezes and reboots on it’s own during Tablo use. I can’t remember the last time I got a LPW if ever. FF and RW work fine for the most part, however sometimes it’s a little slow to get started again, maybe 10 seconds or so. I installed my Tablo in April of this year and for the most part it has been a pleasure using it. And it gets used a lot. It’s currently at 2.2.6 because I have yet to be offered 2.2.8. I am recording at 720p because it’s good enough for me and conserves space on the hard drive.