DVR that doesn't require server in foreign country?

Tonight’s frustration may end up being a final straw. Our quad has been reliable for years - many years, except of course when the internet is down and we can’t use it AT ALL.
Tonight appears to be a different issue - it’s saying something about an authenticated connection can’t be made. No software, no device, can’t access it to actually USE it - at all.
It pings, it’s there, it’s connected, I can pull up that simple Tablo web page in a browser by putting the device’s IP address in the browser, but…
My wife wanted to watch something she’s been chomping at the bit to watch for a while - I went to the Tablo app in our LG TV (flakey as heck, poor app, but generally works ok) It gave a connection error. Sorry, honey, guess you can’t watch it tonight. Then she asks me to make sure to record a couple of show tomorrow while she’s gone. Sorry, honey, can’t do that, either.
I tried my tablet, I tried my laptop computer with the Tablo app, I tried everything to connect, but can’t. My guess - Tablo servers are down? Our internet is fine. I can get to here, obviously!
I hate, and I mean hate the fact that they force us to hit out to a server thousands of miles and who knows how many hops away to watch a recording, or to simply click on a show and record it.
My take? It’s totally stupid to have to rely on someone else to access a device that’s 3 feet from your TV, 10 feet from your computer, on the exact same network. Why? Who was the ding dong that said hey, let’s force customers to hit our server before they can use a device that they have paid for in their own home.
That’s like saying hey, wanna drive that Jeep? Sorry, you can’t, the FCA servers are down!
I’m looking around, this is just plain stupid. Can’t watch recordings, can’t set up shows to record because of a connectivity issue with a server in a foreign country.
If they don’t program in a way for us to use these things without them making a connection for us - from our own TV to our own DVR, someone out there will have a device that allows it to work even if they go belly-up.
Can someone please explain why they insist we contact the mother ship to use a device in our home?
Thank goodness our A/C doesn’t do that!

There is another thread that notes there was a server outage affecting some devices. It appears to be fixed as of Friday morning.

But I go back to - why must people who buy a device like this rely on an internet connection to a server “out there” just to connect an app to the device in order to set something to record or play things already recorded?
We missed out on an evening we had planned for watching things we wanted to watch, and I was not able to set up a program to record because THEY had a server issue.
The devices and all software are in our house, in the same room, on the same network.
I’d love to ask some engineer what makes it so very necessary that in order to use a local device and local software we must rely on having a perfect internet connection to their servers.
There must be devices out there that do not require that we have full internet connectivity to the manufacturer in order to use the device.
This is the only thing we own that requires such a thing.

I’ve said it before - huge chunks of the USA do not have reliable broadband. Those who do have it seem to live in their little world and assume everyone else has it. If we all had access to broadband, Musk’s satellites would be out of business.
Too bad we were not warned from day one that hey, you can only use this if you have good internet back to servers “out there”.

We rank 27th in the world in broadband access.
A new study shows the U.S. is one of the lowest-ranking countries when it comes to broadband access. Oct 30, 2020

There Are Far More Americans Without Broadband Access than Previously Thought. The Federal Communications Commission says 21 million Americans lack high-speed internet access, but a new report says the actual figure is double that.

And yet everyone assumes… just because they and their friends have access, all of the USA does.

There’s got to be some way the makers of Tablo can turn off the requirement to have access to THEIR servers to watch something that exists in our own homes.

Can’t get DSL and the local monopoly on cable refuses to build their equipment out to our area despite there being extremely expensive massive new homes being built out here.

So, why can’t Tablo allow a device in our house to access the DVR directly even if the internet was completely down? (let alone their own servers being problematic - and not the firs time, either)

Please explain why software sitting here can’t traverse our own internal network and link up directly with the DVR?

There needs to be a server that “introduces” the two devices. Device IP addresses can change both inside the local network and on the public internet. Most people have a dynamic IP address. The Tablo server act’s like a phonebook. Your Tablo tells the server when it’s IP address changes. Your app asks the server for the IP and connects you.

You can stop using the Tablo server BUT that means setting up dynamic DNS and your own server. When you think about it Tablo saved you a bunch of time you would have spent running your own server.

EDIT: I thought you were talking about a remote connection. I’m with you on this. There are reasons the Tablo needs an internet connection but playing something from the local network isn’t one of those.

Up until around 2-3 years ago the tablo Roku app didn’t need to access the internet to find the local tablo units. It used IPV4 broadcast. Then the app was changed to phone home.

If the internet is down the app will still limped along. But if the internet is up but the remote server fails to respond your screwed. There doesn’t seem to be any timeout values for waiting for a response.

That’s what I can’t figure out. Say things have gotten out of whack locally, maybe you replaced equipment, whatever, you can use the app to do a search for local Tablo devices (thus the same subnet requirement - it broadcasts on that subnet for a response from any Tablo that exists there)
You can tell it to rescan for devices. I couldn’t see why it saw the device but was giving a crazy authenticated connection error. Hey, it’s the same network - the same subnet. (I stayed up really late trying to make things work). More confusing was that internet was up - I was able to do searches, look through all of the FAQs here and out there in the world, no trouble accessing the internet. In fact it was actually fairly fast last night. But still no Tablo.
Makes no sense that the app can scan your network for Tablos, but can’t connect over that same network subnet.
Remote access for streaming, fine - but we never do that. It’s nonsense to have to have their server - not just internet, but their server, to watch or access locally on the same subnet.

Our Internet data is slow and limited, so streaming isn’t even an option. *(commercial delete isn’t an option due to this)
Watching locally is the only reason we have one of these.

1 Like

I’ve considered running a raspberry PI server to trick my Tablo into working without internet. That’s really the only fix I can think of. I have no Idea why the app can’t just save the last known address of the Tablo and attempt to connect to it. Worst case scenario on your home network is that it might fail. That’s better then not working at all. It’s perfectly understandable they need internet to download guide data and sync the time but OTA2GO just let’s you enter the IP address manually to connect to the Tablo if it can’t find the server. Realisticly the Tablo needs to connect once a day not including commercial skip. Someone did a test using the Tablo without internet and with manual recording. The time does get way out of sync fast. That could have been solved with a $1 real time clock but that’s a whole different battle.

My “guess” is that they do this because they expect the apps to be used on a portable device and use to stream remotely from Tablo. So if the app requires connection to their servers, it will work remotely. But what they need to do is program the app so that if it sees it’s on the same subnet as the Tablo device, it will work directly with the Tablo. So I think I have figured out part of the why - but why in the world they make it work that way ALL the time, even when connected to the same network, that’s dumb.
Let it do a detect of the network - heck, I can do it in VBScript, so they can do it in whatever language they are using. If they can see the Tablo device on the same network the app is on, skip the internet and server detecting and just connect. If they don’t detect a Tablo device on the same subnet that are on at the time they are launched, then hit the Tablo server to get the outside address and get to the device.
In other words, they could fix this. They apparently choose not to, leaving people frustrated. (and looking for a device that will work when their servers are down). This is such a simple fix. (and it’s a choice they made, they don’t have to do it this way)

I completely agree with all your rants and have made similar myself - yet I knew this is how it operates prior to purchasing my tablo… so I knew what I was getting into.

There are many, many topic over this - there is no local network discovery with tablo devices. There are detailed posts and vague FAQ tablotv blogs.

Even though Nuvyyo is based out of Canada, they use cloud CDN services - searching you’ll find which according to geoip is located in the US… not foreign, unless you are Canadian.

Loads and loads of post - one time TabloSupport provided this response

They read these forums and know how we use the apps. Many have complained over the years and they have had time to update the apps. We also do those surveys twice a year. I don’t know (for sure)why they do it they way they do but it has nothing to do with their initial expectations at this point.

I’m pretty sure those servers are AWS and in every region they serve. You get the closest server no where you are. I blocked some AWS servers because they were serving malware once and I accidentally blocked Tablo too. Oops! I was having a heck of a time figuring out why my Tablo didn’t work.

1 Like