Dead Tablo/Horrible customer service

Bought a 4th gen in October. Immediately had trouble getting it to connect. Then it worked great for a couple months.
After that, I started getting Retry? messages when I tried to tune channels. Connecting antenna directly to TV tuner proved no issues with antenna.
Tried rescanning channels, and it said no channels found, but left the guide as is.
Tried contacting support, and it appears the only monitored method is email, which is horribly slow. Never got chat to work.
Tried to exchange at Best Buy, but was told they don’t handle factory warranty for Tablo.
Called support and waited 45 minutes to be connected. Was told to factory reset. After that, I couldn’t get it to finish setting up. Freezes on channel scan. Was told to put in remote access mode and they would look at it.
Been in this mode a week and a half. No email replies from them. I called and when they called back, they told me it’s escalated to engineering. Then no updates for several days. Called yesterday and got a callback and they hung up. I got back in the queue again, but they never called. Called again today, and no return call.
So, right now I’ve got a brick with a blinking blue light.
I don’t know why they won’t just replace it and figure out what’s wrong with it on their own time instead of ticking me off.

4 Likes

@TabloTV @TabloSupport

2 Likes

Still no contact from Tablo and my unit is still still there taunting me with it’s blue light.

So disappointing. The reviews were so good, that I bought this piece of crap. Now I can’t even use it
Does anybody have a suggestion on an antenna DVR that actually works? If I can find an address for Tablo, I might just mail it back to them. Then they won’t have any excuse to not refund my money.

1 Like

I hate burst your bubble, but unless Tablo authorizes a return and issues you an RMA number your not going to get anything from them. If they do authorize a return, then it most likely would only be to replace a defective device with a new or rebuilt device.

1 Like

Well, I’m not getting anything from them right now either. I can’t even get them to call me back.
I think they’re trying to delay until the warranty expires. Fortunately that’s 8 more months.

Still no updates from Tablo on my issue. Called again and requested a callback. Said wait time is 10 minutes. Got a call 40 minutes later. Picked up and nobody there. Called them back again. Now wait time is 9 minutes. Well, it’s been 30 minutes and no callback yet. I wonder what kind of math they use for their averages.
Went through this sequence a couple of days ago. Never received a callback after I called the second time. I’ll post back today’s results, but my expectations are pretty low.

1 Like

Completely feel your pain.

a user named 269587 should be stopping by any minute now to say how great the product is and how it’s all YOUR fault

1 Like

Similar experience?
Still no callback. So I bombed their call queue about 15 times, and their chat Jeeves thingy about that much. Kevin responded to 2 of my chat tickets with a generic form letter.
I’m looking for Nuvyyo CEO contact information so I can inform him of how horrible his company’s customer service is. I’m also contemplating filing a BBB complaint about them. I informed my buddy Kevin of where things are headed at that it would be great if he would give me a ring so we could get things cleared up.
Kevin is being quite shy tonight.
Who is this 269587 you speak of?

Nah, Bruh… Go back and read your post (“horrible experience” post) and do some self reflecting. There is always 2 sides of the story… the story the comes out your mouth and the story to comes out the opposite hole… your post is coming out the opposite hole bro!

That user would agree with this situation. As do I. The support isn’t the greatest… I emailed support and got a short reply back 1 month later.

This post does worry about… If my Tablo blows up, I’m just gonna have to buy a new one or go with another vendor.

1 Like

What support? They currently don’t seem to have any support.

1 Like

@djreiswig The team has reached out to you several times via email but hasn’t heard back. They’ll try again today.

1 Like

Just received the email about putting it into remote access mode. Here’s my reply in case it doesn’t make it.
My Tablo has been blinking the heartbeat for almost 2 weeks. When I was able to reach someone, I was told my issue was escalated to engineering.
For some reason the email connection doesn’t seem to be reliable, as I don’t get your emails and you don’t get mine. That’s why I would like to talk to a human, but obviously this isn’t possible.

Did you happen to reply to the email you sent before hearing back from support? In the past the way Tablo email support has worked if you reply too early it actually sends you to the back of the email queue.

Received an email reply from Tablo this morning. It seems that they can’t see my Tablo even though it’s been blinking the heartbeat for almost 2 weeks now. They say it hasn’t been online for 6 days. As the asked me to, I rebooted my router and Tablo and tried the set up in the app. Got stuck with an unknown error. I proceeded to press the reset button 3 times quickly and the heartbeat is back. Replied to the email about 6 hours ago. Haven’t heard back.

So if the setup failed did you verify that the tablo unit is even connected to the router. Or is the LED blinking because it’s not connected to the router.

How would I determine that? The led is blinking because I put it in remote access mode just like they asked me to. The instructions said nothing about setup. Just push the reset button 3 times and wait 2 minutes to make sure the heartbeat is still blinking.
I’ve not been able to get it to complete the setup and do the channel search. The Roku app says it’s not setup. But so far I’ve got no help from Tablo on finding a solution to get this piece of crap working.

Most people log into their router and check to see if the router even knows about the tablo device.

I’ve seen setup fail collecting the SSID list and/or switching credentials to the router SSID. For me it’s always android 13 on a samsung tablet.

1 Like

No idea. Tablo support has made no mention of any of that. They did tell me one time that engineering was working on my issue. So I’m guessing they had an idea on what the problem was.
I had this thing working great when I first got it. Then it started not being able to tune channels. Now nothing is working. Seems to me like it died a slow death, but for some reason they won’t just replace it. If it won’t connect to my network, then how are they going to be able to do anything? BTW: I did try plugging it directly into my router with an Ethernet cable instead of WiFi, and it acted the same way.

Just checked devices on my router and there is no Tablo showing up. So I guess it’s not even capable of connecting to the Internet. And the setup process ends with an unknown error, whatever that means. So I have no way of getting it to connect.

I uninstalled the app a couple of times and think I finally got it connected to my wifi. At least that’s what it said. The blue light was on solid and bright.
Then I got to the channel scan screen. After scanning, I’m left with a grayed out save & continue button and a rescan button. Rescanning ends up with the same results.
So I’m back to my original issue of not being able to tune channels, but a TV tuner connected to the exact same cable tunes all channels in fine.

Just a couple of quick questions:

  • Have you tried different zip codes?
  • Does your antenna have an amplifier?
  • Do you have an external drive attached?
  • Which device are you using to set up your Tablo?

I give you credit for your continued effort. You’ve got more patience than I do, for sure! it sounds like you’re trying everything you can think of and taking in suggestions by fellow Tablo users. Your latest post looks like you’re further along than you have been, so maybe something’s working?

1 Like