Dead Tablo/Horrible customer service

No, no, no, Android phone & Samsung tablet.
I’m persistent, because I have $100 invested in this thing, so I want to have it work. I just wish the Tablo folks were a bit more helpful.
Hopefully when they get through the queue sometime in the next week, they’ll be able to remote in and see why I can’t get any channels.

I get where you’re coming from. I’ve been through various setup issues on all three of mine – and twice on one when I gifted it!

It sucks that it’s the weekend.

Are other devices able to see your Tablo?

1 Like

It doesn’t show up in my wifi networks on my phone, so who knows. It did say it was connected and went to search for channels.
This process has been going on for months, so the weekend doesn’t really matter. I’m guessing it’s going to be a while before anything gets solved. I’ve never run into a place that’s so reluctant to exchange a device under warranty. Worst case they get a working unit back. Best case, they get a happy customer.

1 Like

Very true.

Well, I hope something works. Again, it’s amazing how much energy you’re putting into making contact with them and reaching out to others.

I’m NOT telling you to do this, but I’d have pulled all of my hair out and factory reset the friggin’ puck 30x by now. I know Tablo is against that because then they don’t have the logs for what the problem is, but sometimes, my own sanity has to come before others (as in learning from my problem to help others in the future).

Support once asked me to put two of mine in access mode. One stopped blinking 5 or so minutes later, the other went on for 12+ hours. Tablo support said if it bothered me to shut the LED off. I waited a couple more hours, then rebooted the thing. I probably should have waited, but I was ticked off that they told me to do it, I responded that I had, so in my eyes they’d had adequate time. I’ll never know what the problem was and they never made another mention of it.

Sorry you’ve been so long without your device. Keep doing your part and maybe between their acknowledgement above and your emails/phone calls, they’ll be able to do something. Good luck and keep us posted.

1 Like

I have factory reset it several times to no avail. This was a solution suggested by Tablo support. Of course it didn’t work.

Message from Austin at 5 tonight. Asked me to uninstall the app on the TV. Unplug the Tablo for 20 seconds. Reinstall the app.
TV still says the Tablo needs to be registered.
Replied to the email with a picture of my TV screen. No response yet.
Since I didn’t hear back, I uninstalled the Tablo app on my phone. Reinstalled the app. It said it was searching for firmware updates. Then it went to the channel search screen and found no channels. Tried rescanning multiple times. Can’t get past this screen because it appears that it must find channels to complete the setup and activate the Save & Continue button.
I assume the tuner is messed up.
Guess I’m back to waiting again.

Kinda sounds like it has a shaky Wi-Fi connection.

1 Like

Why would you say that? I also tried an Ethernet cable straight to the router and picked wired connection and it does the same thing.

Unless your Roku or whatever device you’re using to access the Tablo is also connected via ethernet, then a shaky WiFi connection could still be the problem.

I run Netflix and several other apps through the Roku without any issues. Why am I having problems with the channel search? Shouldn’t that deal with the antenna tuner rather than the wifi?
I don’t have any WiFi issues with any other devices in my house. Is a Tablo really that special?

Netflix is streaming straight from the net, out of your wan port. Tablo is streaming from one device to another. It is an internal transfer.

You will have 2 devices streaming 10-15mbps each at the same time on the same wireless router.

If you have a crappy wireless router with no horsepower… Low end chip set for wireless, routing, and switching can have this issue.


If you have channel search issues, then you may have low RF signal.

1 Like

They were able to remote access my Tablo and think it’s a hardware issue, so I guess they’re going to replace it. Sent info this afternoon, so we’ll see how long that takes.

Received new unit today. Had a little trouble getting it set up, but all seems to be working correctly now. Channel search completed and I am able to tune live channels and schedule recordings again.
It’s unfortunate that this process was so difficult. Hopefully Tablo gets things figured out for those having issues in the future.


Thanks for the update.

1 Like