Consensus on Firmware 2.2.12?

Fairly new here and refugee from SimpleTV.

Have followed the discussion about issues with 2.2.12 and now seeing an update notice for our Tablo.

Would be interested to hear what other customers are thinking about updating now or waiting.


It’s working fine for me.

1 Like

Updated three hours ago this morning. Went smoothly, everything working fine - live TV, recording, scheduling, etc.

Was nervous too. But I did this am. All is good.

Updated OK last night. No problems viewing or recording thus far after 8 hours of operation.

Holding out util I finish my work on SurLaTablo 2… but that’s my reason…

Had it about a week. Using Roku 3s on Wifi and Chrome on Windows 10 hardwired to router. Works fine here.

Also one week in… no problems. 4 tuner tablo streaming wi fi to NP and Roku

A week into having firmware 2.2.12 and it is operating nicely.
(Using FireTV’s, not stick, as my frontend)

Thanks to everyone that responded.

Went ahead with the update and the only anomaly was the device couldn’t be found on the network. Router reboot wasn’t sufficient. Had to restart the network. Likely related to using a VPN.

I’ve noticed only one flaw through the last few betas and this build, when you get a “weak signal” off a channel, it seems to cause a reboot of the unit on the ATV4.

Other than that it’s been very reliable for me.

No problems at all here, had it for a while now.

In fact, not sure which of the two is more responsible but between this firmware and the 7.5 Roku firmware, the Tablo experience today is the best and fastest it has ever been.

About a week in for me and working nicely. Like @jayeffgee, I did notice that I had a station in the linup that had stopped transmitting, one of the subchannels of a group a subchannels, which caused a reboot of Tablo when I tuned to it, so I deleted it from my lineup.

Other than that, it’s been working nicely for me.

It’s amazing how first impressions can impact a release. For about a week there was a raft of posts about Tablos being “bricked” with the new release. Caused me enough concern to delay the update until today. Now there has been a slew of messages that the new update works well (including mine).

My hesitation was I have had a bricked tablo. turned out It was a problem with the power supply. And a year ago when Roku and Tablo updated it was an epic disaster. Seriously my mood swings by how well my Tablo experience is. Working great now!!

1 Like

There was a rare set of circumstances that caused an issue with very few units - mine being one of them. Support was very responsive and they shipped a new Tablo, even though mine was about two years old. Tablo takes care of their customers.


Mine works fine, but the ability to connect with has gone south.

When I try, it just gives me the error message saying it can’t establish a connection.
Was fine before the update but, but today is the first time since the update that I tried to connect on my PC with Chrome, and it just won’t connect.
Tried resting all my equipment, but no luck …

Fortunately, it’s still working normally with the E-wired roku 3, and to the two WiFi Roku 3s I have.

Submitted a ticket …

Yikes … is there no faith in the beta testing process?

Working well here, fortunately!

Since Firmware 2.2.12 update, PLEX Tablo Channel no long works on any device. I have requested that Tablo support back me off 2.2.12. Waiting for a reply.

My remote connection keeps dropping out with both my iPad & iPhone. I took a video to upload but it does not allow that here.