Commercial Skiping Does Not Work!

Good Day -

I have the Tablo Quad, and have been using it for the past week. Antenna is strong on all channels, five green dots. Using multiple devices, Apple TV 4K, Lenovo Laptop, Samsung Smart TV, and Roku. None of my devices, when recording shows is the automatic skip of commercials feature working. I have the box checked under settings but its not working. And I notice that this option must be selected for each individual TV (Operating System) being used. I can however fast forward them, but they are not skipping. HELP!

Also, I notice that the guide in the Apple device allows you to select other channels while viewing the current channel in the background albeit is just a tiny channel selector at the top, really not that great. The Roku is the best option for streaming the service, it has a much better guide setup. Does anyone know if there is a way to setup the guide the same as Roku or is the guide different for each operating system?

My Samsung Smart TV is the biggest disappointment, you must reverse out all together to view the guide, and it does not even show the same options such as commercial skip on this device as it does on the others.

I really like the unit but am finding a lot of flaws that with TIVO I did not have. I want to keep the device but some of the aforementioned are deal breakers for me, especially the lack of the options to be used with the Samsung Smart TV which is the TV we use the most aside from our bedroom TV which uses the Apple TV 4k. I am hoping this is user error on my part because I want the best user experience with the device.

I’ve used HDHomerun, Mohu, and TIVO, and now Tablo, so I have some experience with this process over the past five years. So far Tablo has not been up to my expectations of its advertisement, I am hoping someone in the community can answer my questions and prove me wrong.

Commercial skip is a global setting, so if you set it once, the Tablo will send out all your shows to its commercial skip server for processing. You do have the option per device to use that commercial skip data or not, but the default is on.

If the recording is showing bright yellow rectangles on the timeline, then it is working. If it is showing gray rectangles, then you have it turned off for that device. What are you seeing on your devices?

This is a key tidbit.

More info here:

And here, including details on which platforms/apps support Automatic Commercial Skip (the Samsung app does not):

Thank you for your response, in my situation I noticed during setup on multiple devices the “global setting” you indicated this was not the case. I had to go in to the Apple TV 4K and check it, as well as with the Roku and Samsung Smart TV.

They indicate orange with the clock so I know they are ready to record and I have watch several recordings, but as I indicated in my post it is not skipping commercials.

Also I will note I am still under a 30 day trial premium subscription so the commercial skip should be working but it is not. At this point I am definitely leaning toward either returning it or not signing up for premium service if I can’t get a basic function like commercial skip to work, it’s one of the main reasons I bought this device.

Just to clarify, what @snowcat was saying is the global commercial skip functionality must be turned on in Settings. This is what tells the Tablo (assuming you are paying for the commercial skip service, which it sounds like you are using under the 30-day trial) to actually send the appropriate data up to the Tablo commercial skip server(s) to actually process the shows.

That Settings toggle is entirely separate from the playback toggle on each playback device that tells that device to use the commercial skip data/playlist that Tablo has sent back after processing the shows. You want to verify the commercial skip toggle in the playback screen on each device is toggled on, as indicated in the article @TabloTV linked above.

Thank you for your response - perhaps I was not specific enough.

  1. I am using the initial 30 day trial - I did go on the site to activate my account and entered my serial number.
  2. I did go into settings and checked the box for commercial skip.
  3. When I scheduled recordings the orange clock indicated in the guide the show selected as going to record.
  4. The shows I elected did record, but they are not skipping commercials.

I am not sure what you mean about toggle all I know is that for each device, the operating system is different as is the method of use. For example on the Lenovo Laptop the commercial skip options does not appear at all in the settings. Or when using the guide each operating system has a different process to change channels, for example on an Apple TV 4K device the channels while watching live TV can only be seen at the top of the device and are very small, whereas the Roku Device it is to the left of the picture and offers a much nice guide for changing channels during viewing, and the Samsung Smart TV or Lenovo Laptop you cannot use a live guide at all you must reverse completely out to see the guide and change channels. I guess I am asking for too much here but I think these basic functions should be more intuitive and consistent.

Bottom line I have followed the instructions to the letter and yet commercial skipping is not work and I am at a loss why it isn’t because everything else is working albeit not as I would prefer.

The Tablo Win10 app does not support commercial skip, but you can use it in Chrome and Edge.

The Samsung app does not support commercial skip either.

But you should see it working on your AppleTv and Roku devices.

Thank you - any suggestions on what to do to troubleshoot why its not working with my Apple TV 4K or my TCL 55" Roku TV?

I have rebooted Tablo, I am wired hard-line in with 400Mps speeds and my antenna is getting 5 green dots of reception on all channels programmed.

It is recording shows but not skipping channels, needless to say I am frustrated.

Once you have enabled Commercial Skip Detection within SETTINGS, eligible completed recordings will be processed and a new Automatic Commercial Skip playlist will be downloaded to your Tablo.

This may take several hours depending on the length of the recording, the time of day, and the speed/stability of your internet connection.

Recordings that were successfully processed will show a yellow checkmark in the airing details screen.

Do you see that on your completed recordings?

No it just shows a blue triangle in the right hand corner with the number 1 which I assume means one episode. I took photos to show you but it won’t let me post them?

Sounds like you are at the show level, that screen shot is at the episode level.

And while you keep indicating commercial skip is toggled on in Settings, you haven’t indicated if you have turned it on in the playback window of the playback device (i.e. Apple TV 4K or Roku)…


It has to be toggled on there in order it to actually auto skip the commercials during playback.

Another great question - however I do not have that option to do so at the episode level, it only has Record options which is delete all, delete watched or cancel - episodes, watch next, delete and more… with more its the description of the episode.

You need to play the episode and while it is playing hit the down button to get options to turn on or off com skip.

@sqedebinder Perhaps you should give the support team a call so they can talk through this with you:

Will give that a try - thanks!

That is the next step if I can’t get it to work with the last post recommendation.

UPDATE, I was able to get skip to work, but not with all recordings, it says in some instances that its “not eligible” for this function? How does one know which one’s are eligible or not. Also recorded the Bucs game last night and am not seeing the skip function worked with it. Does it take a time period for this function to work or should it be automatic within a time period. I’ve read that Tablo manages the data and it takes time to have it loaded is that true?

Filtered Shows (as of January 11,2021)

Apparently the commercial skip for the Bucs game worked, it just took a long time to update it so I assume it’s Tablo working it through their network to complete the task.

Many thanks to those who contributed to answering my questions.