Can't play any recorded shows. Was able to watch 1 show live while it was being recorded but can't play the recording

We purchased a Tablo - 4th Gen 128GB Over-The-Air DVR & Streaming Player – White from Best Buy on Sept 24 and installed it the next day. I find it is not very forgiving. I now need to reinstall the app only every few days, at first it was at least daily.

By uninstalling and reinstalling the app and/or rebooting (by unplugging AND pressing reset on my 4th gen) I have been able to get around or resolve problems UNTIL TODAY.

We have recorded shows but we cannot watch the recording.

We recorded a major network show last night between 8-10 PM. We recorded some non-network shows between 4 and 8 AM today. We have also recorded some PBS shows between 8 and 9 AM today.

None of these recordings can be watched. I was able to watch a PBS show while it was recording but I was not able to watch the recording. When I move the cursor over the recording highlights. When I click it goes to the next screen BUT moving the cursor does nothing. No shows highlight.

I have uninstalled and reinstalled the app and rebooted the 4th Gen DVR three times and still no change.

Doe to cloudy weather today our antenna signal is weaker than normal BUT I was able to watch the PBS show at the same time it was recording. Could the reason we have had so many problems be a bad DVR?

We received a firmware update and I installed that yesterday.



You shouldn’t have to reinstall the app ever, much less daily or every few days. What client are you using and how old is it?

It is possible that if it is an old FireTv or AndroidTv device (3 or more years old), that it won’t work well with the Tablo. Have you tried using your phone and seeing if you are having the same issues?

Try a different storage device. The one you are using may be too slow.

Are you using a Roku by any chance? My 4th Gen would not play any recordings until I made changes to the sound settings in the Roku Ultra. My older TV apparently cannot display videos via HDMI with surround included. So I turned it all off in the Roku and now it plays recordings/Live TV just fine.

Mine is doing the same thing since the update.

It definitely sucks but I have found a workaround.

From “Home” go down to the “Recent Recording” line.

Click a show you want to watch and pick the top option.

If it plays the episode you want you’re good.

If not pause the show.

Then go down to “Up Next”

You should then be able to pick the episode you want.

It’s nuts but it works lol. Good luck!

1 Like

Thank you so much Snowcat! Yes my Fire Stick is over 3 years old. Time for a new stick! Thanks again!!!

Fhssh_Ttned, hank you for the work around which works very well. Hopefully TabloTV will update the updated client quickly and also acknowledge the problem.

1 Like

You are welcome. I hope that helps.

Paul, this is apparently a problem caused by the latest update to the fireTV version of the client/ you might want to try the workaround suggested by Fhssh_Ttned above before replacing your firestick. hopefully there’ll be a correction and an acknowledgement from tabloTV soon.

Thank you Fhssh-Ttned this worked!
Since my Fire Stick is over 3 years old I have also ordered a new Stick as suggested b SnoCat.

I’m using Fire Stick but great advice to fool with settings! TY

TY for your response! The work around suggested by Fhssh_Ttned worked. Since my stick is over 3 years old and I have had other issues I am also getting a new stick.


Thank you!

I just talked to phone support (after a 25 minute hold). This is a known problem and according the the support person “they are working on it now”. When I asked when a fix could be expected, she said it should be ready by the end of this weekend.

TY. Wish they would broadcast a msg:)

I reported this bug to Tablo yesterday and they were able to reproduce it. They’re working on a fix. They told me about a workaround. Some recordings can be played directly from the Home page, just scroll down.

Thank you!

It’s Monday and nothing has been fixed. Still can’t play recordings on my new 4k Firestick which was working until end of last week

Monday 6 PM EST. I replaced my 3+year old Fire Stick today and I am now able to watch recorded shows. I don’t know if this is a coincidence, TABLO fix was applied at same time? If NOT a coincidence then it would look like TABLO firmware upgrade does not work on some legacy products. While reinstalling, I saw that Amazon states that 4K buffering ONLY works on HDM1; another thing to check on your setups. Hope this helps!

I have the Tablo app on 2 TVs, one has an older Fire Stick and the other a brand new one. I’m able to play my recordings as usual on the new Fire Stick but I had to use the work around suggested by Fhssh_Ttned on the old one. I’m hoping Tablo can fit the problem this weekend, as was mentioned, so I don’t have to replace the old stick right now.