Apple TV Broke Tablo

Warning TVOS17.2 Breaks Tablo.

Further my Tablo never worked right on Apple TV anyway. IS there an update for the older units in the works? Very frustrating the lack of communication.

Tablo confirmed to me that they were aware that tvOS and iOS 17.2 versions break Tablo so it is non-functional.

I reported it over a month ago when the new tvOS came out. The only thing you can do is pick out no more than 20 channels and delete the rest and the Apple TV should work. It has never taken this long to fix a problem before. I’ve been using a tablo for over 8 years and yea it very frustrating that Apple TV app has not be working for over a month. It stared with the new tvOS 17 17.1 and 17.2 none of them works with the tablo app.

Interesting workaround. I have about 40 active channels. Not sure if the app will be stable enough for me to drop the number, but I’ll try it.

Try it it should work. If you want to leave all your channels tablo will continue to record all channels that you have just go to the recored section. But you will lose the ability to watch live tv when the guide freezes up. Another work around is not to use the guide at all and use the other guide you use to see what next while watching tv.

WONDERFUL. Great Workaround! I had 35 channels. Dropped to 17 and all seems OK for now. Guide updates, live channels seem right, etc.

Tablo - this should be a good clue to a fix. It seems to be a memory overflow issue in iOS / tvOS 17.

Do they actually “break” the Tablo? Or do we mean that Tablo is just unable to properly function via the Apple app platforms?

1 Like

I spoke to apple on this one a month ago. the thousands of apps on apple are notified of the updates and its put on beta many weeks before release. so its tablo failing to follow thru. the iOS upgrades are needed for security but are in beta long before public release. again tablo knew of this before release.

Ok, so the Tablo isn’t broken, just the apps used to access it. Thanks for calling out my sloppy language.

I have confirmed that if you simply reduce the number of channels that you have in the interface to something less than 20 then the interface works OK and you can play recordings, etc. things work again!

thanks for that info.

Wasn’t meaning to call you out. Just trying to grasp what’s really happening. (For what it’s worth, the OP said “broke” in the subject before you did.)

Yes of course, they know about this ahead of time. Public beta come much after the developer betas, so they have plenty of time to fix this.
I know everyone will say it’s a beta, but the last two releases of TVOS have really messed up the legacy Tablos and they have yet to make a statement or fix it properly. Either they’re having issues at the company. Are they just not focused on the legacy app anymore?

1 Like

All the betas on the dev side, worked fine until iOS 17 was pushed Thanks for the tips on channels.

Actually I’m still having problems watching recorded shows. However the interface no longer hangs.

Isn’t the Apple TV on TVOS 17.1? Are you running the beta? I have an Apple TV HD and Apple TV 4K with a Tablo Dual 64 and everything works perfectly and not changed with any of the updates.

I have over 10 Apple TVs. Various OS.
The last time it worked was well TvOs 15 maybe. 16 has minor issues (16.6). 17 has major issues. Basically unusable. It’s a complete nightmare and 17.2 just won’t Even work.

1 Like

I’ve had issues before but don’t get why it works for some and not others. What model of Tablo do you have.

The only issue I’ve had is sometimes if you hit the back button to get out of the guide its unresponsive and have to several times. Also I have had it at times randomly buffer several times then work fine.

With tvOS 17.2, it is totally broken…VERY DISAPPOINTING!!

With limited testing so far, I have found that the Apple iOS update 17.2 Public Beta 2 seems to have resolved the issues I had been having.