Ability to Listen to Surround Sound Recordings on Roku Remote


#1

I record things on my Tablo in surround sound as I like to be able to watch my shows in surround sound. However, sometimes I like to watch tv late at night and don’t want to wake up the kids. I use my Roku remote and plug-in my headphones to it.
As it stands, I can’t watch the Tablo recordings if my headphones are plugged in since Tablo reports that I cannot view the recordings since my device does not support surround sound.
It would be nice if Tablo can make it so you can record both surround sound and non surround sound audio track so that you can enjoy surround sound on your roku if you are not in a headphone setup and vice versa.


#2

Yeah, they know about the limitation, but here’s a workaround for you, in the meantime.
You can disable surround sound just before you start watching TV.
Just remember to enable it before you go to bed, so recordings, and Live TV audio will come out in surround sound the next day.

The surround sound setting change takes effect immediately on tuners not currently in use, but will wait for tuners currently in use to finish what they were doing before applying the change to them.

I’m not sure what will happen if you try to play a recording that included surround sound, but the current Tablo surround sound setting is disabled?


#3

The problem is this only works for live television. If your recording was recorded in surround sound then you can’t watch it with your roku headphones on. That’s why I would like to see if both audio tracks can be stored.


#4

For those who search and find this thread, I re-posted my response below to you on the weekend in another thread. To follow up the below explanation, I don’t think the tuner itself can spit out 2 audio streams - one untouched and one transcoded. Maybe @TabloSupport can shed some light on that?

If that’s the case, the ability to have 2 audio streams will likely never happen.

———
The Roku does not have a Dolby chip in it so it cannot decode the 5.1 AC3 / DD stream to play the audio back on your remote. That’s why you have no audio. The Roku can only decode AAC audio.

With your Tablo set to SS On, it is actually your HDTV that is decoding the 5.1 AC3 audio. The Roku just passes on / hands over the audio to the HDTV.

The other apps such as Netflix have 2 audio tracks for their streams, one 5.1 AC3 for the HDTV, and one 2.0 AAC for your Remote.

So the only way to get audio from the remote on the Roku is to disable the SS option on the Tablo. The Tablo will then record the audio as 2.0 AAC.

Or you can ask Roku to put a Dolby chip in their boxes. Many people have asked them for this on their forums. The response from Roku is that it is too expensive to get the licensing from Dolby.


#5

Sounds like a limitation also on the Roku remote with headphone. And Tablo.


#6

Depends on how you look at it. Yes, if the Roku itself or the Roku remote could decode 5.1 DD audio, you would get sound from the Roku remote via headphones.