No private listening on Roku and Tablo HDMI

I recently tried using private listening on my Roku Ultra remote. It works fine on my Tablo 2 tuner, but won’t work with my Tablo HDMI. Both are connected by Ethernet, and I am accessing the HDMI unit over the network, not directly. Any clue why I’m not getting sound on the HDMI unit?

Is Surround Sound enabled on your Tablo 2 tuner? I’m going to guess no, so the audio is recorded in 2.0 AAC. The Roku Ultra can decode the 2.0 AAC audio and this is why you can hear audio from the Roke remote.

By default, the Tablo DUAL HDMI records the audio in 5.1 AC3 (surround sound). The Roku Ultra cannot decode the AC3 audio to send via the Roku remote.

See the link below. When “Surround Sound Passthrough” is set to OFF, the Tablo will convert the 5.1 Surround Sound audio to PCM (Pulse Code Modulation) audio to be output and sent to your television. This is for the TV directly connected to the Tablo DUAL HDMI via the HDMI cable. I don’t think there is a way to get the Tablo DUAL HDMI to transcode the 5.1 AC3 audio to 2.0 AAC or 2.0 PCM to be sent to the Roku Ultra.

If my above explanation is not clear enough, this thread below should be helpful.

Good suggestion, but there was no change with passthru set to ON. When it is OFF, the second I plug in the earphones unto the remote, the sound goes off on the TV but then doesn’t come out thru the headphones.

Is the passthrough setting available under the Tablo Settings on your Roku?

Or only available under the Settings when using the Tablo DUAL HDMI directly?

I’ll ask our QA team to check this out. Hopefully we can identify some differences between the Tablo HDMI & Network connected Tablo’s to determine the difference.

1 Like

After chatting with our team, I can confirm this is the expected result. As mentioned above, the Tablo HDMI is providing AC3 audio, which can’t be decoded by the Roku remote.

Thanks for the update.

So the Tablo DUAL HDMI will only decode the AC3 audio to PCM audio for local playback via the HDMI cable?

Is there no way to have it record an AAC audio stream? Or transcode to AAC audio for local streaming? Kind of like how the network based Tablo does for remote streaming.

The HDMI doesn’t transcode at all, so there wouldn’t be a workaround.