World Cup ghost soccer ball

I’m using a ge indoor antenna $80. I think good quality. A Roku 4K ultra. My download speed is 300mbps or more. My tv is lg oled 4K. I rec with my Tablo at the highest setting 60fps. When I watch recorded World Cup soccer the ball disappears and look ghostly… it is driving me crazy. Any way to fix this issue? I’m worry this will happen with nfl football?

Most Fox channels broadcast at 720P.

Could it be:

could it be

Thank you Zippy. If the problem is the Roku ultra, has anyone have better luck with the Apple TV 4k? I am trying now to record at lower resolution to see if that helps. I didn’t have this problem when I was using a old hd tv. Maybe the new tv is just too good than what the Tablo can handle?

It should be much easier with tablo version 2.2.20. You should be able to watch Live TV and change the tablo Live TV Quality setting to evaluate the results of changing to various quality settings . Playings with the Roku video settings along the way.

I have an older Roku 3 which is set to 720p connected to a new 4K Sony. While I thought the highest recording quality seemed a little better, it wasn’t that much better then the 720 5Mps.

But if you like remote connect you may be forced into the highest quality setting.

I think I’m running version 2.2.20. I also have a firestick and tried that on the tv. It does the same thing, ghost soccer ball. Does anyone else have this problem with LG OLED 4k TVs? With tablo have 4K support?

Yes and no. Yes, meaning that the Tablo works just fine on 4K tvs, like all other apps. No, meaning that since broadcasters don’t broadcast in 4K, the Tablo can’t display a native 4K signal.

Do you have the highest quality setting set and is your channel a 720p channel? If so, then it should look about the same as from an antenna. But if it is a 1080i channel, it will look more like an internet broadcast.

Thank you Snowcat. Yes, I do have it at 720p at 60fps when recording. I guess that’s the best I can expect on the Tablo. I have a PS Vue account and the quality is better than I record from the Tablo which was not what I expected because when I watch live tv on the tablo the quality is just as good as the PS Vue.

Another disappointing thing is now that my trial guide subscription is over, I can not record programs from my Roku!!! I have to use my smart phone instead. That is inconvenient… Wish that was not the case and from what I’ve read on here, there is no plans to change that?

I’m think about getting a channelmaster stream plus instead, anyone here have experience with that?

Thank you

The Tablo folks are on Facebook and were discussing Rokus this week. One of the questions was about manual recordings on the Roku, and the Tablo folks did say “coming soon”. Now that could mean a month or a year, but it does appear that it is at least planned. :wink:

As for the World Cup, is your channel a 720p or 1080i channel? Usually the 720p channels look great with sports, while the 1080i channels are more like what you were describing.

Or never* (like 5.1 surround sound). Just saying :wink:

*I guess 4 years and counting.

Yes, the world cup on Fox is 720p and I get a good signal. When I watch it on my old plasma hdtv it looks better because it is not 4k. I know my tv have dolby vision and HDR. Maybe the tv is too good for the tablo? I am wondering if there is a setting I can turn off or turn down on my tv to downgrade it to the Tablo resolution? I just got both the TV, tablo, and the Roku ultra so I’m kinda a novice at streaming but learning.

Depends on whether your TV is performing auto upscaling to 4K versus playing 1080/720 as native and if so can the upscaling be controlled.

Thanks everyone. I figured out what was wrong and I just wanted to share it. I turn off the TruMotion creature on my LG tv and it fixed the problem. No more ghost soccer ball.

1 Like

I am glad that fixed it. I should have thought of that right away, since I turn mine off on every TV.

I was watching some of the World Cup games on my Vizio 4K tv via the Tablo, and it looked great.