Wireless Streaming Quirkyness

Hey Guys-

I know there are tons of wireless streaming issues posted but I’m just going to put this out there and see what you all think?

I have 4 Roku TVs, 1 Roku Express 4K+, and 5 iPhones. They all do streaming from the tablo at any point of the day.

When I bought this system right after xmas, everything was good. Until about a week later. Buffering every minute.

Having a semi-enterprise network in my home, I started troubleshooting this deal. The Tablo is wired into my core switch. I have 2 AX 4x4 APs in my home.

I emailed Tablo support asking what type of stream was coming out of the Tablo, with no reply yet. For giggles, I enable Storm Control on 3 cast on that switch port. Port Isolation turned on that port too. Streaming got a tad better.

I also disabled 802.11K/V on both my APs and it seemed to pick up a bit more. I know not all wireless clients play happy with that protocol.

Maybe the luck of the draw, once I attached a USB SSD, seems like streaming improved alittle. Dont know if that relieves some CPU/MEM usage?

Enabled AirTime Fairness… and boom, seems like all my clients started working like normal. No hiccups.

Then I found out my Roku Express 4K+ was still having the issue. 4 Roku TVs and 5 iPhones work flawlessly. But that 1 roku device.

Now on to this device… Seems like it streams better on the 2.4 band then the 5. Both bands have low interference, and great SNR, RX, and TX.

I also noticed something… when buffering happens, there is no data flowing out of the tablo device (per the switch port) and my Roku device isnt gathering any data. Like it just dead stopped. UNTIL I press the fast-forward button (recorded and live tv) and it seems to jolt it enough to fire up again. Data starts flowing and then stops. Dead in the water again. No Data.

I can see about 8-12MBPS flowing from each device when testing against the Tablo. Express 4k+ does the same amount and just stops.

I wonder if there is a fail-safe trigger there? OR is there needs to be a restart threshold?

Here’s the quirky part… I have Roku Media Player on it, streaming movies from my Synology at UHD. No buffering. Going across the same AP and switch. I can watch 50-100mbps flow between these 2 devices flawlessly. I know my AP’s can handle the load.

The Free Streaming channels have no issues at all. My wife was watching Bones all day on it. Once she switches to Live / Recorded. Buffering on the Express 4k+

If someone can give me some insight on what I can do, that would be great? Or just say Hi, since I’m a noob here, that will be ok too. lol.

1 Like

Dont mean to double post… but during the testing, i was the only person accessing the Tablo APP and I have no recordings set or scheduled. I have a few recorded movies for testing. Just Plain Jane for now. Until I get this under control.

See the Express 4K+ is our living room TV. My luck, right? Where everyone sits down and watches TV.

“Hi!” :-).

Sorry that all I can offer you is that the Roku app is a mixed bag ATM. Still seems to be undetermined why certain Rokus work while others don’t.

I’m assuming you’ve seen the numerous posts about the Roku 0.8.401 update and its issues. Has any of the pause/jumpback tricks worked for live TV?

The MPEG-2 file compression that the Tablo 4th gen uses requires much more bandwidth than anything you tend to stream or watch off of a server drive.

So many things happened in the days before the holiday and the new year that anything could be the problem. The Roku app was updated and rolled back due to major issues (hard to believe it was worse, I know) and the 0.8.401 update came out on the 2nd. I have not seen it, but some users report a Roku update that has really messed up their boxes in many ways and the Tablo app being one of them.

Tablo seems to be pretty hush hush on what’s going on or when a fix is available, but we really hope it’s soon.

You have done way above what any user should have to do to make their system work, and with all that extra data, maybe sharing it with Tablo in a support ticket could help.

I also have had better luck on a 2.4ghz channel, my theory was that the 5ghz band was throwing too much at it for it to keep hold and just overwhelmed it. You definitely have a better testing setup than I, but you seem just as baffled.

I don’t have any real insight on what to do. Even my Express 4k+ does what it wants randomly with the Tablo. IDK if you have other sticks you can continue testing this on that aren’t Roku, I just hope you don’t drive yourself nuts trying to figure this out. I was only using the Roku 4kE+ on one device and I’ve swapped it out with an older 1st gen Firestick 4k Max. I was getting grey enough without the app’s torture!

Good luck, keep testing, and between all of us (and maybe a new Tablo version) … maybe we’ll get this figured out.

(I’m serious about sharing this info w/ Tablo … so maybe @ TabloTV, TabloSupport and TabloEngineering so that they’re likelier to see it. Great job, BTW. What you’ve tried is amazing! — but keep in mind that I’m nobody. ;-)…)

1 Like

Thanks for the reply… I really appreciate it! Gave me some insight that I’m not alone and giving a solid history lesson. I didn’t know all those deets. It has given me a deeper view of what is going on.

I did email support asking some questions but have not heard back from them. Once they reply, I will send them this link here. Tagging them now … @TabloTV @TabloSupport @TabloEngineering

I’m willing to help test and QA whatever they need. I’m game!

I tested The 4k+ against my 5ghz network from HT20-160 with the same results.

I found my 2018 Ultra, fully updated, and better streaming results. But still buffering. Not as bad. BUT the app could randomly close. Not often, but like twice in an hour during testing.

The quirky part is, my crappy Roku TVs work flawlessly. My wife sleeps with the TV on. It streamed all night last night. FYI, Walmart HAD these 31" Magnavox Roku TVs for sale at $25 each (3 years ago). I bought 4 of them.

I was like hey $25 a TV, if they last a year, then I got my moneys worth. They are solid, only 720P. My kids and Wife don’t mind in their bedrooms. The living room got the big sammy UHD TV… thats where everyone congregates to watch TV.

As of now, the 2018 Ultra is hard-wired into the entertainment center switch. It works flawlessly (hardwired, I figured it would).

More info, the 4k+ was sitting at -50DB on the 2.4 and 5ghz during testing. The signal was great. The SNR, TX, RX were good!

1 Like

You are certainly not alone!

So many details can get lost in topics after they become a couple posts long.

I forgot to mention that they had that server outage, which many of us think was a rollback since many issues that were “fixed” returned as soon as they were up and running again. (An example is on the FireOS/Android side where sometimes a simple button press can send the app into a reload – even doing so twice in a row on one of my devices!)

I don’t blame ya for the $25 TV. I picked up my 50" Philips 4k 3 years ago for $120! It still works great and Philips recently released an Android11 update to keep it up to date, but with only 4.6g internal, I’ve been using STBs on it. I know others are really bothered by the layout (not enough apps in favorites; the new “default to ad” when hitting the home button) but my 2nd gen 4k Max was the best purchase I’ve made to bring it back to life, and I’ve got 4 other “sticks” just lying around, waiting for those “just in case” moments.

I hate to suggest buying another device, but if you have any lying around, it’s definitely worth a shot. If you’re running around with perfect behavior on your iPhones, then maybe it’s a more tempting offer to pick up a cheap test stick (and yes, I keep recommending the 4k Walmart one for $20 because if you’re only going to use it for a backup and need ONE app, why spend an outrageous amount of money?) I know it’s another thing to hang off your TV (BTW, it’s got a Bluetooth remote, so you don’t even have to have it sitting where you can see it) but until they get this Roku app fixed for the more dedicated Roku-ites (Roku-ists? Roku-ans? lol)… just a thought.

I hope Tablo has seen how dedicated we are to making these things work. I love your dedication to a new product, and I’ve only been banging my head against the wall for 3 months with these things! ^_~

For some strange reason, the TVs with built-in-Roku don’t seem to have many issues with the app – something I also hope @TabloSupport takes note of.

Keep testing, playing, posting, but be sure to give yourself some chill time. Until we have any word of what’s going on, this is about all we can do.

(I would have replied the first day you posted, but you threw so much into that first one that I needed to be in front of my laptop to sit and process it!)

1 Like

Oh, For Sure, dude… My wife will keep me in check with spending too much time in my man cave, tinkering. LOL.

I figured, I wouldn’t get a lot or very few responses to my 1st post. It was a lot of info thrown in. I figured someone could use it for some helpful hints. Anything is better than nothing.

I’m not a Roku fanboy, but my fam likes it and knows how to use it. I do like their channels too. My wife is really the only one who uses the Tablo. For her local news, judge judy, and her reality TV shows. (not kidding, she loves judge judy, and we’re not that OLD, We were teenagers in the late 90s).

Found something else out… I have two different models of APs in my home. I have a beefier AP on the opposite of my home. Furthermore, I took my 4K+ there, and it’s been working… which is the same side all my Roku TVs are playing on. BUT my iPhone will stream fine in the same spot/original spot as the 4K+.

Now I have to find out what is going on there. Maybe a red herring, but I will dive in and see…

1 Like


You just can’t quit can ya?

Sounds like you’ve got a few more things to work with and that you might have found some of the issue. IDK if you’re still using that SSD you mentioned in your first post, but I would think it should be decent enough to handle whatever the DVR throws at it!

I “acquired” a Roku when I upgraded my Mom’s system, and then later it was the perfect device for an LG webOS TV that didn’t have frndly tv. Picked up a Roku Cam (big mistake) and since you can only access it through a mobile app or a Roku box… I upgraded. Then Tablo wasn’t on webOS, so it stayed put. The cam app is broken now (fragmented viewing or completely distorted picture) so I put it aside, except for testing.

If it helps, the Roku Channels app is available for Android/Fire. It’s nice to have around for a few things (Dave Gorman was my recent fix).

Still wishing you luck, man. And you above all know that just because it works ONCE… test test test.

I’m not pulling out my Rokus (the other is an Express+) until I hear something’s changed or that there’s a new issue that I would like to try and duplicate. Although… I do try to check every day or so for that 12.5.5 update I’ve heard about…

Good luck, sir! (I am also a 90s teenager – which kinda makes us old?)

Not to defend your wife’s choice of viewing, but for years I couldn’t stand Judge Judy. Then one day, I found her being an outrageous B to be hilarious! Haven’t watched in a couple years and I’m not gonna record it… but it has its moments! (no reality TV here, though, for me… so she’s on her own there)

1 Like


Just for giggles… I swapped out my inWall AP in my living room with a ceiling mount AP. Close in specs to the Ceiling Mount AP (Different vendor) on the other side of my home (look at previous post above).

Streaming worked. Flawlessly.

I disabled all the extra options from the 1st post, and all streaming devices bombed. buffering, again, on all devices. Even with the newly added/tested AP.

Enabled those option again. Devices came back alive and streaming fine.

Ok, we got that kinda figured out… Now I have to find out, what is up with my In-Wall AP.

BUT during the test. My wife and I watched a recorded episode of Inside Edition and Nightly News. The APP randomly closed. Using the Ultra.

Click back into it… Watched a live episode of Judge Mathis. The APP stayed up and solid. Plus no buffering.

This all happened with in 1-hour lunchtime break.

To our kids, we are 10 minutes older than dirt. LOL.

I updated all my Roku devices to 12.5.5 with the newest Roku Tablo APP.

As of now, streaming is working. Ultra has the random APP closing issue. 4K+ seems to be solid on the APP not closing.

Ultra and 4k+ work on both bands and tested. from the test above.

Well… now that you’re 3 steps away from solving all the world’s problems…


You are quite the go-getter here, man.

You make me (sniff sniff) so proud! (sheds a tear)

And tbh, I haven’t even had time to go through most of what you’ve written in the past couple hours!

I’ve been debating how much monkeying around I want to do before my already-1-week-late 4th gen gets here (maybe sometime) today. I haven’t checked for the 12.5.5 update today, but I’m glad it hasn’t affected your positive results.

So much of what you’ve typed up in the last few days is tech overload, so hopefully enough of it makes sense to others with similar issues.

Then again, with your background, yah.

Glad it’s working. Keep testing and proving those results. I look forward to your fixing whatever mess I get into here while I add a third 4th gen and transition one of them out… ^_^.

1 Like

More testing:

Sat down last night in the living room with the 4k+ had no issues. No buffering. No App closing.

When Wife was cooking dinner, I swapped it out with the ULTRA 2018. The App closed once, from dinner time till 10pm.

All devices are up to 12.5.5, and it seems table for now.