Wi-Fi works, Ethernet doesn't

Hi everyone,

My refurbished Quad has trouble connecting over Ethernet. Wi-Fi works fine.

When I plug it into Ethernet (directly into the main eero router), guide data doesn’t load, cover art doesn’t load, and I cannot stream any content to any device, recorded or live. Yes, the light on the Ethernet port works. Yes, it blinks. It’s like it’s only passing some traffic, but none of the important stuff that is actually needed to provide, you know, TV.

I’m getting the runaround from Tablo support on this (we are on day 10 going back and forth); they keep pointing the finger at me and my network being the issue. To be clear, I have zero other issues with any other device on my network (I have over 35). I’ve verified the Ethernet port works fine on the router (one is being used for the actual internet connection from my ISP, and the other I’ve ran extensively with other Ethernet devices).

Anyone have any ideas?

Super happy to have egg on my face if this is indeed my issue. It’s just that no evidence has pointed in that direction as of yet.

It almost sounds like the ethernet port on the Tablo isn’t working. Can you see it get assigned an IP address in your router? If so, can you ping that address and get replies back?

1 Like

Yeah, that’s my guess. Something goofy with the Ethernet NIC on the Tablo.

It does get an IP address assigned. And you can ping it. But for whatever reason, traffic doesn’t pass past the physical layer connectivity. It seems to be a logical connection issue.

It took me hours to try setting the thing up because I tried first using the Ethernet port. It wasn’t recognizing the Tablo (couldn’t find it on the network, even though my router assigned it an IP and said it was online), then eventually I was able to set it up, or at least I thought I did, but it got stuck at the firmware update. I decided to try setting it up via Wi-Fi and that worked flawlessly. The firmware update that I thought had completed, hadn’t, so it had to go through that process on Wi-Fi again. But it worked.

So, I decided… okay… now that it’s set-up, let’s plug it into Ethernet… aaaaaand the trouble started again.

Tablo support has been pretty stubborn in their belief that everything is fine with the hardware, but I suspect that this thing was returned by someone else who had issues with it, and that their refurbishment process and checks didn’t catch any issues with it, so they just shipped it out again.

You’ve probably tried this already, but for sure I would try a different Ethernet cable.

The other thing I would look at is a physical inspection of the connectors in the Ethernet port on the Tablo, just to make sure they’re not bent or out of place.

One other thought, check the ethernet port setup on your router, in case there is a port speed mismatch. (I think the Tablo Ethernet port on some units is only 100 megabit)

Thanks for the suggestions.

Yup, tried 3 cables. That was first. Haven’t physically inspected the port on the Tablo, though. I will do that.

The port auto selects speed, and my router (eero) doesn’t have the ability to configure it, but again, thanks.

My first 4-tuner Tablo had a problematic ethernet port, so wouldn’t be unheard of?

The replacement they sent worked perfectly, as has the Quad I replaced it with.

(The 4-tuner is going back into service … soon… I think…)

That’s reassuring to hear. Thanks. Tablo support thus far hasn’t been very helpful.

1 Like

It takes a few more steps than just plugging in the ethernet cable…

You may want to review the steps here:

Lesson learned from prior experience…

Yep, not my first rodeo. I went there first.

They’ve begrudgingly offered a replacement “despite being unable to confirm any failures with it”.

1 Like

Glad Tablo offered a replacement, please let us know your experience with the new unit.

1 Like

Well, guess what? The replacement unit works perfectly. No issues with Ethernet. I’m afraid to try configuring it on Wi-Fi for fear that doesn’t work and I have to spend another 2 weeks trying to convince Tablo Tech Support I’m not an idiot.

…and I’m sympathetic. I’ve done technical support before. I get that I’m not their typical consumer, and that most consumers don’t know the difference between an Ethernet cable and a power cable. But I’m not going to lie… I’m pretty disappointed by how long it took to beg them to send me a functional unit. That, and them trying to convince me that the issue was on my end by using terms they didn’t understand (I was told it was because my unit was double NAT’d at one point) or by them relying on a useless network scan diagnostic that didn’t find 2/3rds of the other devices on my network (I was told my Tablo was too far away based on a weak signal, even though I wasn’t complaining about wireless connectivity).

Anyway, like I said, I get it. Just disappointed that it took this much frustration and effort to fix something that should have never been sent out in the first place.

I’m worried that the unit I am about to send back will pass their bench diagnostics and qualify for shipment back to another customer as a “refurb” (again). If they do, hopefully that poor soul will find this thread and it will be helpful.,

2 Likes