Why can't the Web app find my Tablo? iPad App has no problem

Note: See new info below!

My Tablo light is solid. The iPad app can watch live Tv or adjust settings, no guide info. But no computer using the web app can access the Tablo.

I log in to my account and it says my Tablo has not connected.

Support said my Tablo cannot update its time clock, something is blocking it. But I put the Tablo into the DMZ on my router. And I don’t have any outbound firewall.

What could be causing this?

My modem is an SR505N on VDSL2 (very fast!). Tablo is a quad.

Thanks in advance!


From Tablo Support:

Your ISP (Acanac.ca) blocks the port ntp requires which is 123. I have implemented a workaround but it will be lost on reboot.
You can now try your other devices and re-scan for channels to get guide data.

I will be working with the dev team Monday to get a permanent solution in place for you. Thank you for your patience.

To which I replied:

Ah, I had to power down to move the Tablo back to its “outside” antenna hookup. Your message explains why it’s been “funny” since then.

Web apps still work. But not the iPad, which is really weird.

I put the Tablo Android app on my Tronsmart Media player and it works fine.

Reading this

Acanac claims Bell is blocking it as a ham-fisted fix for DoS attacks back in January 2015.


  1. Is your Tablo hard wired directly into your modem?
  2. How are your computers connected to the modem? WiFi or hard wired?
  3. Can you check the Wireless settings on the modem. It is on page 31 of the manual linked below, is “Clients Isolation” checked?


If you reconnect the Tablo to be part of your internal network instead of the DMZ, does it work any better?

Thanks for the speedy reply!


  1. Tablo is direct wired on a 10-15’ CAT 5e cable right to my modem. I hope to move it to my Gigabit 20-port switch that feeds all the jacks in my house. But for “sanity reasons” I’ll keep it on the modem for now.
  2. I have 3 network hubs and 3 WiFi access points in my house. Some computers/mobiles are wired and some are wireless. I have tested both wired and wireless devices on the same hub and off, I have (thankfully) seen no difference in what network layout I use. The only obvious difference is whether I am testing the iPad APP, or the iPhone APP, or the web app. In that the iPad APP worked right out of the box when I first connected over WiFi to the access point furthest from the modem - I did connect the iPad to the same WiFi point though.
  3. My Wireless settings are the same as your screen print. Only the first option “Enable Wireless” is checked.


Thanks for the speedy reply!

I did all of my initial testing as part of the regular network. I only moved the Tablo to the DMZ because Tablo support claimed it could not connect to their server due to some a “firewall”. The Tablo needed to get the current date/time so it could authenticate the SSL certificates. And since it could not get an updated time, it could not connect.

I don’t know what to make of this claim. It seems highly suspect to me. I do not have any firewall enabled on outbound traffic. And the DMZ sure as heck should not have any firewall.

I did have uPNP disabled, but that is only supposed to affect remote access (according to Tablo’s user manual).

So I don’t know what could possibly be the cause of this “blockage”… I’m torn between software bug in Tablo and an unfortunate timeout.

In all of my tests, I could PING my Tablo from any computer or device in my house. I could also pull up the Tablo web server (http://IP.address.on.network). I could even telnet to the Tablo. And once I had it i the DMZ I could telnet to it from outside my network (dunno what the login info is though).

The Tablo is/was behaving the same as any other computer or Network appliance.

I posted this last night when I had given up for the day. Overnight two things happened, without me making any changes or resets.

  1. The Tablo is now visible to the Web app on all my devices!
  2. The Tablo APP on my iPad has STOPPED working, up to now this has been the only thing that worked! The Tablo app on my iPhone still works.

Now I’m confused. Maybe some weird timeout had to occur before the Tablo re-tried to connect? Maybe some software updates had to complete… But what killed the iPad app? The iPad can still connect through the web app. Curiouser and Curiouser…

I enabled remote access and got the demand I configure my ports. I was in a lazy mood, so I enabled uPNP and let the Tablo do it itself. I wonder if uPNP being enabled will “fix” any other problems - would not explain why it started to work by itself though.

Thanks again for past and future help!


All of a sudden I’m having a new problem in addition to the reboot freezing/crash issue I still have yet to resolve. This new problem did not show up in my prior five months of Tablo use:

Starting today, my iOS app on the iPhone no longer can see or use the Tablo. My six Roku boxes all see and do use the Tablo properly (except for the yet unresolved crashing issue).

So I now have a new issue quite similar to the one which resulted in this thread being created, some devices see the Tablo, but my iPhone app cannot.

Perhaps the iPhone app needs to find my Tablo via a factory Tablo server on the WAN even though I am sitting in my local WiFi LAN? Certainly all the other Lan devices here can see and use the Tablo properly

Any idea what is going on here?

Sadly this wonderful Tablo of mine has gone from being a useful family appliance to a high school science project gone bad…

Thank you!


A bit of sunshine !!

I rebooted the Tablo twice and the iPhone iOS app now CAN find it on my LAN !!! No idea why it dropped out or why it took a 2nd reboot to fix.

Now if I could just resolve my Roku box crashing with Tablo issue. Around April 8th was when it started for me and others, literally the day the new Tablo firmware was pushed down my Tablo’s throat… Very tired of interrupted viewing when I use fast forward or rewind to skip commercials but then sit and wait while TV blue screens and Roku reboots 10 times per night.



  1. Tablo did not force the update down your throat, you had to actively choose to update your Tablo. You clicked “Update”.
  2. Roku is the one who forced their firmware update on you. You have no choice when it comes to the Roku updates, they just happen.
  3. Tablo released their .30 firmware which was beta tested on the Roku v6.1 firmware, it worked great, then one day later exactly Roku released their v6.2 firmware. 6.2 causes the FF rebooting.
  4. I know you’ve been told over and over it is a Roku firmware bug, but it seems you don’t believe us. Please see here at the Roku forums someone who has the FF reboot with the Hulu channel:

Look at the date of the Roku firmware in the update section of the Roku settings.

  1. Where is the checkbox to prevent automatic Tablo firmware pushes? I looked through the Settings on the iPhone Tablo app and do not see such a choice?

  2. Indeed, Roku does its push of firmware with no user acceptance or offers method of reversal.

  3. My updates were done on the same day with no intervening day. I did not experience this single day of trouble-free Tablo. Rather, the updates occurred and my issue began.

  4. I do see exactly ONE person on the Roku forum with a single complaint on a single channel. I submitted a ticket to Roku and they have offered neither a solution nor an apparent awareness of any backliog of similar complaints. No beta firmware was mentioned either.

I know for sure three things:

  1. Any other Roku channels I have tried (and I have tried many) have NEVER exhibited this issue whereas Tablo does it A LOT.

  2. My only access to TV entertainment for my wife and I went from nearly 5 months of solid Tablo to extremely flakey Tablo essentially overnight with no ownership of this problem by Tablo or Roku for nearly 2 months so far.

  3. Even if more than 1 other Roku users and channels are affected, and I have yet to see evidence of such, the fact that approx 200 channels on Roku with many thousands of users has not provoked a single thread I can find on their forum with over 120 messages on this issue such as the thread on this Tablo forum says that the bug is not neccesarily Roku’s issue. Even if Hulu does have a similar behavior, both Tablo and Hulu may be using the Roku API improperly.

Where is the link reporting a solution with beta Roku firmware? Having a lot of invested time and money in my Tablo and Roku system, I would love to see encouraging evidence that this is being fixed.


While the Tablo will automatically notify a user of a firmware update, the user has to accept it for it to be installed.


TabloTV responded to you directly in the thread linked below and took ownership and said it’s a Roku firmware bug

philsoft also responded to you and told you the beta fixes the issue.

Please re-read the whole thread from top to bottom.



I did re-read the entire thread.

Philsoft in message 84 says: “the crashing problem MIGHT be fixed when the Roku firmware update goes live”. Not terribly encouraging.

Tablo support has taken ownership in only one minor way----they express hope that Roku will fix the problem soon. You must be joking, right ?

Can you show me any other evidenxe that Roku users are complaining about this??? One Hulu complaint is way way less than re-reading the entire thread here on the Tablo forum reveals for Tablo people who are affected.


The thread would be easier to read if people would stop hijacking unrelated posts.

I’m really hoping the Sysop moves everything from your first post on this thread to its own thread - where it belongs.

My apologies for creating this problem. Sorry to have vented this here.


1 Like