When opening Tablo app only get blank screen with spinning circle

Greetings all, Had tablo for about 1/2 year. New problem of when opening tablo app only getting a blank screen with the spinning circle. Have done the normal troubleshoot steps - unplugging DVR, unplugging modem & router, and also clearing cache. Using the google chromcast. Have no problems with any of the other apps and wifi connection is excellent.
Appreciate any guidance.

I have a Tivo Stream 4k, which is also Android TV and very similar to a Google Chromecast. The Tablo app sometimes hangs up as you describe, and I have resolved it by force stopping the Tablo app.

You may have tried that since you’ve cleared the cache, and the force stop command is a few lines above that in the Apps menu.

I’ve found that if I back out of the Tablo app rather than going straight to the Android TV home page it seems to prevent the hang up. I think leaving the Tablo app with a video playing increases the likelihood of it hanging up.

Had the same experience with my “Google TV” Android app. I also found that sometimes repeatedly pressing the back key will recover the app; force quitting however always works.

Okay - went ahead and did the “Force Stop”. Lo and behold have it working again!
Thanks so much for the help!!