Western Digital My net N900 Router port forwarding

I am having trouble setting up port forwarding with my WD My net N900 Router. This is a newer dual band router. It does support UPnP.

When I set Tablo connect I get:

  Your router requires manual configuration.

Use its Setup Assistant to set up port mappings for the Tablo’s TCP ports.
Your Tablo’s Private IP Address is 

public port private port

21042 8887

21040 80

21041 443

I have noticed that no “Tablo private IP Address” is given as is shown in Chapter 6… 

I have manually added the ports… NO HELP

I have manually added the IP using the MAC addr… NO HELP

I have turned on DMZ… NO HELP
I have noticed that occasionally router port 80 is used by my WD personal Cloud (possible conflict??).
Tablo firmware version 2.2.18 (latest)
Any thoughts… Suggestions?

1. Update your firmware on the router just to make sure you have the newest.

2. Go to page 78 in the PDF (that is the page numbered 74). Turn on UPnP, then the Tablo should be able to configure the port forwarding on its own.
3. If 2 does not work, the do the port forwarding manually (instructions are on page 78-79).


Other question for you, what is your WD router plugged into? What’s the make and model of the modem? And is this modem in fact a modem+router so in fact that the Tablo is behind 2 routers from the external Internet.

@EJC Also, who’s your ISP? Is the WD router being bridged to a separate modem on the network?

 I contacted my ISP and requested that they verify their router at my home was set to bridging. It wasn’t… They configured their router properly and now the Tablo is working in the UPnP mode (all Green), and no port forwarding required. When I installed the N900 about a year ago I asked that they disable the WiFi and set their router to function as a terminating modem (bridging mode). Didn’t happen.

I guess there was a missed communication between my ISP support and myself…

Good to hear you figured it out. You were behind 2 routers that’s why it wasn’t working. All modems should be in bridge mode when a router is connected to them.

I have the same issue with Verizon Fios. I have modem and a Verizon Quantom Gateway router. Any thoughts?

I responded to your own thread. Do you have two physical devices? One modem and then a separate router?

Yes I have 2 devices a router and modem connectec via fiber optic not coaxial