Web app 404 -not found, launching video player

I’m on an android version that now has a “launch video player” step, meaning my only way to play video is via a pl link. This worked for a while but now presents a 404 error. What’s up with this @mattb33 ?

Here’s a link…

I can’t see the screenshot. But I had some other issues with that Launch video player. I downloaded the vlc media player for android which is free in the play store. Select that after Launch video player and it works perfectly

If this is an older Android version (I have 4.1) then the pl will actually get fired off via yet another browser call.  You might want to check your app association defaults through Android to make sure URLs are handled with Chome instead of the older (broken) Android browser.

Ya, browser associations are cleared. Been using MX player for local playback and Chrome browser for Chromecast playback.

404 not found is the Chrome browser error.
MX player is less descriptive and says, unable to play file. Both of these worked right after 2.1.16 when the ‘launch video player’ feature was enforced for “older” android like mine, 4.1.2.

Seems to me to be a web app change that broke this… But if no one else is encountering this… My fustration grows, as my phone is yet another playback device Tablo has taken away. I’m down to just a tablet, a high end computer and a Roku… from 8 devices I could play Tablo on back when it was released 6-9 months ago.

@Thumbs 404 will only be sent to the web app if the recording isn’t actually ‘there’. Does this happen for each one you try to play? Or can you play this same recording on a different device?

@TabloSupport yes this happens for all shows, none have worked through the Tablo “launch video player” button… All shows do work on my windows chrome browser, which plays videos inline.

I went so far as to paste the URL the “launch video player” button loads on my android device, into my windows chrome browser… Where it also reports 404 -not found.

Also, on both the android and windows chrome browser, they both display an episode thumbnail when selected. This usually means the video file exist… And they do.

This is pretty clearly a web app issue with the “launch video player” button. Fix it please and please keep it in your QA routine.

@Thumbs Thanks for the details and feedback. We’ll take a look on our end to see what’s up.

@Thumbs I have the same exact problem, when I launch VLC from Chrome, it gives me a 404 - Not Found. This has never happened before.

When I try the Android app, it’s unreliable, especially with live sports. I try closing the app and launching it again, and Tablo takes me back to the original point I started watching, which is not what I want!

I’ve resorted to watching the World Series on random links on the internet. Watching it from a Russian feed is interesting.

The only device in my house where Tablo thrives is my Roku 3.  Having owned the Tablo for about 3 months now, my Android experience has been a huge disappointment. I would not recommend Tablo for anyone using Android at this time.

No kidding @Barbz … I can’t even recall getting through one episode of a show on Android without cursing at Tablo under my breath. 

Since v2.14 playback stutters in the Android app inline player. Using an external player lets the android tablo app session expire, requiring a reconnection.

The web app on android fails outright on android tablets and is poorly implemented on ‘older’ android phones with the ‘launch player’ button… which forces an external player be selected and then times-out requiring a lengthy re-connection. 

Tablo/Chromecast is a joke so unfunny, it should embarrass Tablo for even trying.

This may all sound harsh… but how Tablo treats android users is far worse. I’ve never had device compatibility taken away so fast after buying a product. It’s normal to not get new stuff but not normal to have functional devices pushed to the tech support queue because of lack of any QA or other controls during product updates. I am not Tablo’s QA team but am treated as one.

I agree, android users should avoid Tablo. Tablo is focused on Roku. Tablo has no timeline for an android phone app. Tablo seems to be dismissive and uninterested in enabling a functional Chromecast experience.  Tablo is a Chrome browser web app and a ipad app… anything else is a promise that Tablo seems unable to keep.

I am a bit more optimistic that Tablo will get it right.  I got one to avoid giving another nickel to satellite or cable any longer.

But Tablo on Android just isn’t ready for prime time (excuse the pun). One day it works, the next it doesn’t, then the pairing, the syncing, then we’re forced to use a workaround, etc. I can’t even use this forum on Android, I had to go upstairs and fire up the PC to post this.

And again tonight, watching the World Series, the app froze an hour in, I restarted it, and it took me to what was on an hour ago. Aarrgh! X( X( X(

In Tablo’s defense, they are not 100% to blame though. Google has made it really tough for Tablo by arbitrarily mixing things up on their end, and in turn, breaking the app.

So hope springs eternal for me that they will one day shore up all the Android problems. I am on a ASUS TF700T tablet running 4.2.1. Thank God for my Roku 3.

Just an an fyi.  My Chome on phone, Android 4.1 used to work… but now even after clearing out Chrome data/cache and reconnecting, all I ever get is a 404 when I try to play something back.  Android 4.1 is really old, so it basically has to launch the player through another browser request (a two step)… but this did used to work for me.  I did recently have a security update on my phone, but I can’t say what broke the web app.  But now all I get is 404 not found when trying to play anything.

@cjcox We’ve actually been doing quite a bit of testing with Android 4.1 the last few days, and it’s been tricky. 

But, that doesn’t explain why/how it was working for you before, but isn’t now. We haven’t made any changes to the web app in a little while, though. Can you try erasing Chrome’s cache?

I erased all Chrome data (both data and cache) before attempting and posting here. Waited for sync… and tried, still I get the 404.

@TabloSupport this issue is due to the ‘=’ added to the end of the url sent by the ‘Launch player’ button for android 4.1 and older web users. Fix that please.

I find I can launch the chrome browser via the ‘launch player’ button, copy the url on the 404 page, launch MX player, open a network stream, paste the copied url, delete the ‘=’ from the end of the url, and successfully play the video on my android 4.1 phone. 

@Thumbs, thank you, thank you!

While the extraneous = makes for a bad demo from my phone, at least it can be made to “work”. I have no idea when this broke though. @TabloSupport, are you sure this wasn’t added on your side? If not, then something on the Android side is doing this now and it didn’t used to… at least in prior testing.

@Thumbs @cjcox Interesting! We haven’t made any recent pushes, so it’s possible that something changed on the Android side - but we’ll have to take a closer look to be sure. We’ll clear this up ASAP!