WD Elements 1Tb HD - How I got mine to work

Purchased a refurbished Tablo 2-Tuner DVR late January from Tablo Web site. Paired it with a WD Elements 1 Tb HD (Model WDBUZG0010BBK-EESN) from WallyWorld. Suggested drive from my research in the Tablo forums.

Two TV’s (living room & bedroom)
65-mile range RCA OTA antenna with powered amplifier
Using a Roku Premiere in living room and Amazon FireStick in bedroom
Older, but still serviceable Netgear wired/wireless router.
Tablo is hardwired to the network.

Initial setup went well, had to hard reset the Tablo once to get the purchased guide to show.

Problem was it not recognizing the WD HD. Fought with this for over a week. Did not work connecting the HD to the Tablo straight out of the box. Reformatting the HD in Windows 10 several times, tried several other WD and Seagate HDs (2.5" types) I had access to, nothing worked!

Without the HD being recognized, it seems you are also limited to being able to access only one tuner of the Tablo. After trolling the forums and web, did this:

Connected the HD back to my Win10 PC and reformatted it one more time, this time using the ext formatting @ 512 bytes sector. Plugged the HD into the Tablo, soft rebooted it and went to the my.tablotv.com site and BOOM! Tablo found and asked to format the drive and now all is working!

Hope this helps!

1 Like

I don’t know if I have recently heard of a good WD Elements drive not formatting directly out of the box. There were at least 5 different versions of the Elements drive. They are identified by S/N suffix “-01” through “-05”.

The “-03” was the most available version being sold when tablo first came out. It had a WD drive firmware issue that caused it to go offline. Since WD drives have multiple versions of the same models, it appears that WD doesn’t always indicate that a firmware update was available on the support page. You had to run the firmware update and see if an update was applied…

1 Like

Using the Disk Management tool in Windows and delete all the formatted partitions should work too.

But yes, it is highly recommended you run the WD Firmware Update Utility to force an update of the firmware. It has fixed many issues for others.

“Did not work connecting the HD to the Tablo straight out of the box.” Some disk drives come preformatted and may need to have these partitions deleted. That information should actually be listed on the box or instructions.

I’ve used a number of WD element drives and have never had a problem. They always seem to be raw. But I also always use the PC WEB app for tablo management.

1 Like

That’s spot on, mate. I had the -03 version of the WD Elements 1 tb drive and did that disk update process and it’s been right as rain now, going on for over a year.

Same with my 1 tb wd passport, 18months old. I had to update firmware before formatting

New user old Tech
Tablo 2 tuner running lates firmware 2.2.12 Northern Calif Urban area Mofu 60 external non directional antenna.
I originally setup my tablo 1 week ago without a HD. I received a Seagate Backup plus ultra slim 2TB STEH2000100 several days later and connected to Tablo.
The drive was not recognized. no mater what I did. I contacted Tablo support and received the following directions from tablo:
"- Unplug the hard drive from the Tablo.

  • Reboot the Tablo, and wait for the light on the front to stop blinking.
  • Once the light stops blinking, connect to the Tablo from the web app http://my.tablotv.com or the Tablo app on a smartphone or tablet.
  • Plug the hard drive into the Tablo.
  • After a few seconds, you should see a prompt on your screen asking you to format the hard drive.
  • Once the hard drive is formatted you should be able to see it in the settings page.
    It will show you the hard drive name (make and model), capacity, and how much is used (in blue) and available (in grey)."
    This did not work for me initially. I ordered and received a WD Elements ! TB WDBUZGG0010BBK EESN and experienced the same issue. I was able to connect to tablo from a number of different devices Laptop, Computer Amazon firestick (latest with alexes voice) android notepad. but no hd.
    I received Instructions to put Tablo in remote access mode from Tablo support but they didn’t get back to me probably because I updated the service tag several times and have since learned that shoves it to the back of the queue.
    In the meantime I experimented with remote access through my two router configuration and read that remote access is only supported on the Chrome browser. since I was using Firefox and Edge on the computer I was attempting to setup with, I repeated the setup using Chrome on the WD Element and lo and behold it worked as Support had advised. Everything clear no stuttering and recordings all worked.
    after a day of having a known good working setup. I removed the WD reset the tablo added the Seagate and it also showed up and I was able to format it.
    The Problem therefor appears to be a difference in the popup utilityused to format the drives. Chrome was the key here.
    Hope this helps other users and a note: to the Tablo coders. Test in all browsers!. Saves everyone a headache.

Anyone have any luck trying to update the firmware on a WD Elements 2TB drive using OS X? The updater doesn’t appear to recognize the drive on either Yosemite or Sierra. I suspect the drive is what’s causing all of my issues given Support told me it was going off line repeatedly. The powered USB hub didn’t do the trick it would appear.

thoughts? WD website is an endless loop of unusable utilities for Mac. :frowning: