Unable to connect via Wi-Fi - TMobile Gateway

Hi! I am unable to connect my Tablo 4 -tuner via wifi on my new T-Mobile 5G gateway. The model is the Nokia 5G21.

It’s basically telling me that my wifi password is incorrect. I have every other device on the house connected with no issues so I am 100% sure I am inputting the correct password. Has anyone else had issues with this gateway and connection?

I’m wondering if it has anything to do with the dual band switching. It uses the same SSID for both 2.4ghz and 5ghz bands.

Customer support was unable to provide any help last year and I just sort of gave up on it.

If there are any special characters in your Wi-Fi password, that could be the problem.

Just straight lowercase characters. I’ve actually just tried a workaround using a power line adapter to hard wire it and seems to be working.

You could try naming the 2.4 GHz and 5 GHz bands different SSIDs.

I’ve done that as well. I’ve actually cut the 5ghz band off and tried it. Only thing that worked (other than my recent power line adapter change) was to connect another router in access point mode. That was not a great solution though as I seemed to get better stability and speed by using the gateway’s router.

I’m looking through the manual for the Nokia 5G21, you’re not using a Mesh network right? Like with additional mesh nodes?

Correct. Just using the built in gateway router.

Did you create any DHCP reservations or MAC filtering rules for the Tablo before you tried going through the WiFi setup process?

I have not tried that. Given that it was giving me a password error I assumed that shouldn’t matter but I guess that could be!

No need to try that - was just confirming you didn’t set these up in advance, as we’ve seen this cause some issues in the past.

Which Tablo app are you trying to complete this on? Can you try doing this using the Chrome browser and Tablo web app at http://my.tablotv.com/?

Sorry for the delay.

Using the chrome browser seemed to work! It’s downloading an update now but if it starts to fail for some reason I’ll chime back in. Definitely seems to be some issue between this router and the phone app. Just for clarification, I was able to add via WiFi on the phone app with other routers prior to this service.

I spoke too soon. That doesn’t seem to be working either. It seemed to briefly connect and attempt an update but keeps cycling back to the start screen. It shows a tablo to connect to but won’t connect.

I can’t get past “searching for tablo on your network” now.

Well the good news is that I have exactly the same issue and tried everything you have tried. The bad news is, well, it’s not working. Like you every other device works fine.

Just to add, I have tried various combos of security settings and speeds. Set up a dedicated 2.4G only network with WPA/WPA2 on the t-mobile gateway and same message about Incorrect password from the Tablo. Tried reset, power cycle, factory reset. No luck.

It’s the only device having this problem

I had the same problem today with my new Tmobile Nokia home internet. Its not compatible with Hulu and i just found out TABLO. I tried everything, no dice. But i found a work around. I simply connected via ethernet cable from the new Nokia 5G to my old router and simply logged in to my old router. works great!