Trying to Open on my Chrome Browser Gives an Error

The last few days, I’ve had trouble accessing on my WIN 7 64 bit Samsung Laptop, using the Chrome Browser. Haven’t had this problem in the past.

I get the Error Message:

A Closed Red Padlock image with a white X in it.

"Your connection is not private

Attackers might be trying to steal your information from (for example, passwords, messages, or credit cards). NET::ERR_CERT_COMMON_NAME_INVALIDd"

Clicked on the Advanced (Info)

" normally uses encryption to protect your information. When Chrome tried to connect to this time, the website sent back unusual and incorrect credentials. Either an attacker is trying to pretend to be, or a Wi-Fi sign-in screen has interrupted the connection. Your information is still secure because Chrome stopped the connection before any data was exchanged.

You cannot visit right now because the website uses HSTS. Network errors and attacks are usually temporary, so this page will probably work later."

I tried using Internet Explorer to open, worked without an error, but the Tablo website told me to download Chrome or Firefox…

I Can access the website ok on my Android phone and my WIN 8.1 Desktop using the Chrome Browser.

Any ideas ?


I saw a potential answer on this site:!topic/chrome/SE3sKXg0iFQ

Check out the one labeled “best answer”

Thanks… I’ll check it out

I had that error a week or two ago. Tablo was working fine on Chrome, then all of a sudden I got this message every time. I googled it and found a solution that was much simpler than the solution here and it worked. I will see if I can find it again.

I can’t find the article with the solution, but I think what I ended up doing is resetting the chrome browser settings (you will lose things like cookies and such, which I didn’t care about because I only use chrome for tablo).

See if this fixes the problem for you.

Thanks for the input @Vonda_Z but resetting did not fix the problem.

Going to try @snowcat Snowcat’s Link when I have more time.



Did you try or works fine for me but the https address gives me the same result you got.

Both gave me the Error, but since I reset the settings, tried it again as you suggested and using the http instead of the https did Not give me the error.

Thank you !

Chas gave me a cert error in chrome, but resetting my chrome settings fixed the issue.
Thanks Vonda_Z