Trouble switching from Ethernet to Wi-Fi

Hi! I’ve used my Tablo exclusively with Ethernet for 3+ years. I’m trying to test with a Wi-Fi connection to free up a port on my router. However, I’m having trouble connecting.

I Disconnect the Tablo from inside my Android app, unplug the Ethernet from the Tablo, reboot it, then connect my phone to the Tablo_xxxx wireless network. I then use the App to add via Wi-Fi. It takes me to the step to pick my home network and enter the password. It tries to save the network credentials, but spins and spins and eventually says:

“Wi-fi setup failed due to an unexpected error.”

I’ve tried many times and keep getting the same error.

Any ideas? Does Tablo not like certain characters in the name of the wireless network (I have an apostrophe) and/or password? Just trying to think through everything. I couldn’t find a way to specify WPA/WPA2 within my router settings. I have two Google OnHub routers configured in a mesh setup, so it should be using “modern” authentication already.

Thanks for any feedback.

Get a cheap Ethernet switch, leave your Tablo hard wired.

https://www.amazon.ca/D-LINK-Ethernet-Unmanaged-Desktop-GO-SW-5E/dp/B00D6M2PC0/

2 Likes

I’ve considered an Ethernet switch, but not ready to go that route yet.

When I free up the Ethernet port the Tablo is using, I’m going to plug in a device that I’ll be testing for something else. I need a Wi-Fi solution for Tablo in the meantime. May get a switch if I decide to keep this other device.

I’m going to say inexpensive network switch… even if you open the port on your router. (technical stuff)


Never used wifi for tablo (or anything with an ethernet port) - is the unexpected error from the android device? or coming back from the tablo? Have you tried a different device to set up wifi?

There are several article in the Tablo Knowledge Base about setting up wifi and swapping between wired/wireless - https://support.tablotv.com/hc/en-us

Sounds like reaching out to @TabloSupport may be in order as you are using the correct process to switch from Ethernet to WiFi.

The unexpected error is within the Android app. I uninstalled and reinstalled the app, but got the same results.

Interestingly, I tested using my guest Wifi network (which I know isn’t a good permanent solution), and it seemed to work. My guest network doesn’t have any spaces or special characters. May try to rename my main network to test. If that doesn’t work, will reach out to support on Monday.

Is your main network holding onto DHCP reservation or MAC filter for the Tablo’s Ethernet address? If so, this would prevent the switch to Wi-Fi, and would explain why the guest network works fine.

If that’s not the case, don’t hesitate to touch base with our support team, we’d be happy to take a look.