TabloTV not working over VPN


#1

I want to revisit this topic because it seems that this feature should just work as the tablo device and the playing PC are on the same network. Also, the community has asked for a mean for remote discovery and access to their tablo device many years ago (2014 was the last post I saw) and it is still not supported yet today.

Tablo developers, please help us!

From my work, I started an openvpn session to my home and my work PC is on the same network as home (192.168.1.0). In fact I can ping the tablo device at 192.168.1.10 without issue.

I can also browse to the device at http://192.168.1.10 and it would display the message “Nuvyyo Tablo Server”. However, when I try to discover and and sync it at http://my.tablotv.com, it always said that “No Tablo Was Found On Your Network”. I have read other posts on the topic which suggested to change lower the route metric, etc. None has worked.

If it helps, I ran a port scan nmap on the tablo device and got the following:
$ nmap -Pn 192.168.1.10

Starting Nmap 7.12 ( https://nmap.org ) at 2017-01-17 13:14 Ame
Nmap scan report for 192.168.1.10
Host is up (0.025s latency).
Not shown: 512 filtered ports, 485 closed ports
PORT STATE SERVICE
23/tcp open telnet
80/tcp open http
443/tcp open https
MAC Address: 50:87:B8:00:2B:C4 (Nuvyyo)

Nmap done: 1 IP address (1 host up) scanned in 6.95 seconds

If you have some idea on how to get my tablo device discovered and play, please share it with us.

I still think tablotv is a good core cutter service but I really hope that it could improve on some of the basic features like this one.

Thank you.


#2

I have a VPN server set up at home where my Tablo is located. I can connect to said VPN on any desktop and then discover and link to my Tablo using the my.tablotv.com website in the Chrome browser. So this use case does work.

Is it possible the issue is your VPN server. What VPN server are you using? Are you running it on a computer?

Or is it running on a standalone device such as your router? Which of course the Tablo connects to directly.


#3

Your VPN is probably not passing the multi-cast type packets needed for discovery. If possible, set up the VPN as the default interface for all traffic while you do the discovery process. Once the browser has cached the connection information you should be able to revert to your normal setup.

In other words, traffic to multicast or broadcast addresses isn’t handled by the VPN the same as traffic to specific addresses.


#4

I am running OpenVPN server on my home linux mint server. My linux server is my router. It has an eth0 port that connected to my FIOS modem and an eth1 connected to my home network. The VPN is configured to use TAP interface instead of TUN interface. Here are some information about TAP.

TAP benefits:

behaves like a real network adapter (except it is a virtual network adapter)
can transport any network protocols (IPv4, IPv6, Netalk, IPX, etc, etc)
Works in layer 2, meaning Ethernet frames are passed over the VPN tunnel
Can be used in bridges
TAP drawbacks

causes much more broadcast overhead on the VPN tunnel
adds the overhead of Ethernet headers on all packets transported over the VPN tunnel
scales poorly
can not be used with Android or iOS devices

The fact that my work PC is able to see the home network and discovered all my roku and onkyo receiver indicated to me that perhaps broadcast and multicast is probably working.


#5

I have finally figured out what caused the tablotv not to work over openvpn. In order for tablotv to work, all the traffics from the laptop must be tunneled through the vpn server. You can do this by modifying the client configuration file and add the option ‘redirect-gateway def1’ . Here is my windows laptop client.ovpn configuration file:

client
dev tap
dev-node MyTap
proto tcp-client
remote chantam.net 1194
tls-client
resolv-retry infinite
nobind
persist-key
persist-tun
remote-cert-tls server
comp-lzo
tls-auth ta.key 1
cipher AES-128-CBC
redirect-gateway def1
verb 4

I hope that this can help someone out there.


#6

The ‘redirect-gateway def1’ does not work for me. At best when I go to my.tablotv.com I can see my Tablo device however when it tries to synchronize it will start and after a few seconds it will show ‘connecting’ in the top right corner and it will start again and it keeps looping like that. I am not sure what is going on here.


#7

I am grateful to all you guys who are working on VPN solutions. Its all a bit over my head but if when a stable solution is achieved I would love a tutorial on how its done. in layman’s terms. VPN for dummies.

Thanks


#8

Tablo doesn’t connect with Avast SecureLine VPN. There aren’t many options to configure, so it seems either turn off the VPN or don’t use Tablo.


#9

Has anyone found a successful solution to this? I’m using IPvanish client with Openvpn tap. I work form home, but in order to connect to Tablo, I have to turn off IPvanish. I would like a solution for this, so that I can maintain my system security. I need a fix for both pc connection and nvidia shield tv w/ IPvanish. Thanks for any support and solutions regarding this matter.


#10

VPN for working-from-home to get ona corporate network is understandable of course. But did someone say ‘security’ in the same sentence as VPN? Why would anyone trust a VPN provider more than an ISP? It is debatable that VPNs provide neither enhanced security nor enhanced privacy unless configured with features orthogonal/additional to the VPN itself (encryption).

So according to the debatable premise, it can be considered that the VPN by itself provides less security, less privacy:
The VPN by itself adds no encryption.
The VPN does add additional imperfect people and additional imperfect systems controlling your data, all requiring your trust, each providing uncountable additional vectors (such as backdoors & bugs) to allow bad-hat-hackers to get at your data if they want it.


#11

I think you’re looking for a VPN feature called split-tunneling, which IPVanish doesn’t seem to have.


#12

Thank you. I’ll do my research for the split tunneling services. Tablo support solution wasn’t a good option for me. I like Tablo and it’s guide, but it appears I may have to return to using Plex with my OTA tuner. The Tablo app in Plex has the same issue.


#14

IPvanish has split tunning now and Tablo still does not work using this feature.
I don’t have a lot of options in controlling the network or adapter since I am using the Android app

Anyone have any ideas?


#15

I’m having similar VPN-related issues on a Mac with IVPN.

Their Andriod client has a split tunneling feature which works as expected with Tablo. However, the Mac client takes a different approach (as far as I can tell). In the app there are 2 settings: Preferences > LAN Settings > Allow LAN traffic when IVPN Firewall is enabled and Allow Multicast when LAN traffic is allowed.

With both of these settings enabled it should allow me to connect to any LAN device on my home network and with the exception of Tablo, it does. For example, I have no problem connecting to several LAN printers with IVPN enabled.

It would seem (I don’t know for ceratin) that the issue lies with Tablo and not the IVPN which clearly works with other LAN devices when those 2 settings are enabled. Not to mention that it works perfectly on Android with split tunneling.

I too would really appreciate a solution, whatever that may be.