Tablo working on all but 1 Roku

I have a Roku2 connected via ethernet that can't stream live TV. The app opens and when I select "liveTV" it shows the list of stations and what is on, but when I select one it goes to a screen while it waits and then after a few moments it drops out (back to the Live TV guide as if I pressed the back button.

At the same time, I have Tablo working on the network for the following venues:
1) Desktop on Chrome on Win7 (ethernet)
2) iPad Mini app via wifi
3) Roku3 via Wifi

I verified that the Roku is online and can run Netflix just fine, so I know it is connected.
What else should I check?

Hi @j321cordcut - here’s a few things for you to check:

- Make sure that you’re running the most recent firmware update (2.1.10) this contained a ton of Roku improvements
- Check your signal strength on one of your other paired devices - do a new channel scan to verify everything is where it should be
- Verify your Roku is on its most recent load (Settings in the main Roku menu)
- If after this you’re still not able to watch Live TV, power cycle the Roku, uninstall the Tablo app and resend it to your device.

If you have any further issues feel free to send me a ticket with the details at

Correction… Roku2 is Wifi (only the 3 has an Ethernet port, but my 3 is set up on Wifi as well)

I confirmed the Tablo is 2.1.10
Roku2 is on latest update
Power cycled and no change.
Removed Tablo app & power cycled again.
Went to Roku online and added channel again.
Tried Tablo and it didnt work.
Rebooted Roku & tried tablo again… still didnt work.
Confirmed Tablo still working on Roku3.
Still getting same symptom on Roku2… 
Open Tablo App & go to Live TV
Channel guide and current shows are accurate.
Select channel and screen says something like “please wait… getting program from tablo” for a few seconds then it blinks back to the channel guide.

Just sent an email.

Following… same problem with a Roku 2

Same issue with Roku 1

old school Roku LT wifi only having same issue.

@j321cordcut @tablosupport my Roku 2 did this as well.  

A roku system restore fixed it for me (as in reset to factory).  After I did the reset I logged back in, and it repopulated all my channels and then worked fine.  It seems that for whatever reason the app may not work when being put on an already established 2nd generation Roku without a factory restore.

@tmann05 Can you clarify exactly what is happening on yours.  In the problem above you see the buffering status bar for a second, then it kicks back to the menu.  On my Roku 1st generation XDS, you never get to the status bar before being kicked out.  Curious if yours does.

@jbanks I can get in the tablo app, go to live tv, see all the channels, click a channel, it buffers, but as soon as the black loading screen appears for half second, it kicks back to the tv channel selection menu. Same thing happens when trying to view a recording. My recordings are set to 720p. I thought the recordings and a few channels might work since they aren’t all above 720p but no.

@TabloTv I will trade you my Roku LT for a known working Roku if you want to research and troubleshoot this model. :slight_smile:

Bump, would like support for this issue.

Hi all, 

Some updates:

We've tested and confirmed the latest generation of Rokus, including the Roku 1, 2, 3 and the HDMI stick (though the WiFi antenna on it can be flaky) - for other models, we're still trying to get of a hold of a few, but it can prove difficult with the older generations of the Roku.

We've determined that composite cables are unable to transmit enough data to meet the requirements of an HD video stream. Unfortunately, the Tablo will not be able to output video on a TV that is connected to the streaming device via composite cables.  

With the above in mind, don't forget to factor in that everyone's setup (their network) is different, and produces different results. 

All of that being said, here are  some of the basic troubleshooting techniques you can try to help mitigate this issue: 

-Check the firmware on the Roku; update if there are any available

-Uninstall the Tablo channel and re-send it from the Roku owner portal

-Power cycle the Roku

-Factory reset the Roku

I have to report that I tried the factory reset on the Roku LT and it is now working! Cheers!

That seems to do the trick.  Awesome!

@tmann05 @jbanks25 Glad to hear it!

I’ve got a Roku2 an TabloTV - updated to latest firmware 1.1.B8  and the Roku still will not stream.  Have powerbooted the Roku, done factory reset and still having the same issue.

The Roku support is the reason I bought  

the Tablo TV so its a shame its not working.

Along with lack of IE support.    

This needs some serious work to get these working…  Roku LiveTV support needs to work simply and seamlessly.

@skytribe - Sorry to hear your Roku 2 is still not working with Tablo. 

Have you tried deleting the channel and re-adding it? If you send an email to the team will be happy to do some further troubleshooting with you.