Tablo wont connect to working internet connection

I am new to Tablo so please forgive me. I have a new Tablo dual lite device and a 4TB WD hard drive. I am connecting to Spectrum cable internet. I have a Arris model TM1602A cable/voice modem that feeds a Sagemcom Fast 5260 router with WiFi.

The Tablo fires up and when hooked up with an ethernet cord to the router. I am not able to connect to the Tablo via the mytablo in chrome.

The wireless connection without the ethernet cord allows me to find the Tablo on my network and use that to connect to the home network. But again it never finishes the connection (spinning ball) and says no internet connection. I then tried an old linksys router without the Sagemcom router and had the same results. I also tried differnt patch cables reboots and such.

I connected the tablo to the internet using my cell as a hotspot, found the hotspot and connected. I was able to format the hard drive, get a channel list and such.

What could be blocking the tablo from working on my network/internet connection?

Thank you in Advance

Your Tablo will need to be connected to your home WiFi network, not your cell hotspot in order to function correctly.

It’s possible that connecting it to your router failed because of one of the following things:

  • you’re trying to connect to a GUEST network
  • the network has no password/security
  • you’re running a VPN or a browser plugin that is blocking something
  • your router/modem are connected in an unusual way

If you’re still stuck, don’t hesitate to give us a ring or drop us a note:

I was able to trouble shoot and found that the windows firewall was blocking the tablo. I used the red X to delete the failed set up and was then able to add the tablo. It is now set up and and the apps have been added two samaung tv’s, a tablet and my cell phone. I will try the Roku devices in the guest bedrooms later.
Thank you again for the phone help, email support and the forums which gave me links and ideas of where to check.



You know, I think I’m having the same problem as you are. I can access my Tablo with my Roku TV but not mw Windows 10 systems. Also using Chrome.
How did you correct your firewall issue anyway?