Tablo will not PLAY (recorded or live)

I know it is not the twilight zone. Has to be an explanation.

Problem: Tablo appeared to be working fine. Could migrate from screen to screen. Initiate the play of a live show or a recorded show, but alas the screen with the play button in the lower left corner would appear include the timeline bar across the bottom, but nothing else. The rest of the screen was blank. While receiving the “play” screen, nothing would appear.

Tried power down, and soft reset. Nothing was working.

Solution: Power down TV. Problem solved. … go figure? Anyone know what occurs between the TV and the Tablo which caused this deadly embrace?

If it’s like my TV (LG OLED) it will drop its Internet (wifi network) connection (often enough to be irritating).

But, I use Roku units, they do much better… then I don’t care of the LG is on the network or not.

I’ve seen this problem with Google (android) TV on my Sony. On this platform I can stop the application and everything works OK without rebooting the TV. However, that’s overkill; if I hit the back button while in the black screen, sometimes twice, the “player” exits and returns me to the regular Tablo display.