Tablo stuck in "loading" screen on Roku

I had a router go bad & replaced it. The 4-tuner Tablo, which is normally wired and sits in an equipment room, was temporarily placed on a wireless network and worked OK. I had a prior issue with it cutting out recordings & learned here that it has to sit on its side to avoid overheating, and I lowered the recording/watch quality to 5mbps. The Tablo is just under a year old (July 2017) and was bought new.

Now when I was setting the network back up, I cannot access the Tablo from my Roku Premiere Plus (4630X). The Roku finds it, but after that all I get is “Loading…” I have let it do this for an hour, so its not connecting properly. Both the Roku and Tablo are on the same wired network.

I have an Android phone and the app connects OK. I can even watch TV on it. I can ping it OK on my network via a laptop, so I know it is present.

I suspect it is a heat issue. The bottom of it is really hot. Steps I have taken:
1 Reconnect the Ethernet cable and do a short press on the reset button so it would connect via wire. Roku finds it and the above “loading” loop takes place. Can access OK via Android.
2. Disconnect Ethernet and power back on for wireless connection. Roku on same network cannot find it. Android can find it but cannot connect.
3. Performed factory reset. No difference, repeated steps 1 & 2. No difference.
4. Pulled power cord and let it sit for 30 minutes to cool down. No difference.
5. Rebooted Roku, tried wired connection. Roku found it, then went into the loading loop again.
6. Rebooted router. Roku finds Tablo and remains stuck in loading loop.

The Android interface continues to work- it synced OK after step 6. I was able to rename the device to a more fitting name, and it showed up that way after the Roku found it.

This has thermal problem written all over it. Tiny stuff is great, but tiny unreliable stuff is not great. Why not make it an inch taller and put a hefty heat sink or even just a fan on it?

I would try disconnecting the Tablo from the Roku app and re-add, or uninstall the Tablo Roku app and reinstall.

Hey @User_0423, sorry to hear that you’ve been having some issues. I see that you’ve touched base with our support team already. They’ll work with you directly to get this fixed up.

Thanks. Tim’s advice of

  1. Unplugging the router, Tablo, and Roku,
  2. Letting them sit, then
  3. Plugging router back in and waiting 5 minutes, then plugging in the Tablo and finally the Roku worked.

I am planning to add a heatsink and fan once my warranty expires.