Tablo Ripper - Automatically download new recordings

Has anyone had any issues lately? It shows a progress bar like it’s working then it just fails with no error. It’s always just worked before. I haven’t changed any settings. I’m on the latest version of Tablo Ripper. My Tablo is a 4 tuner on 2.2.38.

As always, enable logging, try a rip, disable logging and look for an error at the bottom of the log file.

If the problem isn’t obvious, let me know what the log says.

Thanks, I’m not sure what the issues was but it’s working now. I’ll make sure to turn logging on if it starts again. Thank for the terrific work by the way. I’ve been using this software for a long time. The Plex naming convention makes it very convenient.

1 Like

Hey all. Running TabloRipper 2.4.3 with my DUAL Lite (2.4.38). Most recent firmware.

This is the first time I’ve had an issue with the software… it won’t talk to my Tablo. Says “initializing” but won’t load the recordings list. Anyone else?

It looks like TabloRipper is able to retrieve your registered local IP addresses from the Tablo cloud, but then can’t use them to connect to your Tablos.

If you haven’t already, I’d suggest you try assigning static IP addresses to your devices (using your router) and then connect TabloRipper using one of those instead of using the cloud data.

Or, is it possible that the PC running TabloRipper is on a different subnet that can’t “see” those registered addresses ( &

Please let me know what you find out.

1 Like

Really appreciate the reply. Thanks! I’ll try giving it a static IP and plug that into TabloRipper instead.

Otherwise, perhaps I should mention that this is a replacement Tablo I’ve not used with the app before (the reason why there’s 2 Tablos listed: the old one and the one I’m trying the replace it with). Only the new one is connected. I’ve tried connecting using both of the Tablos the app seems to see/remember, but no dice.

I’ll report back. Thanks again!

Your new Tablo doesn’t happen to be one of the HDMI models, does it?

Not a huge deal but you may want to edit your posts and remove your public IP address.


No it doesn’t. I’ve actually never owned one of those. This one is a Dual Lite.

Ah… thank you. :slight_smile: Will do!

Thanks @CycleJ for the help: I assigned a static IP address to the Tablo and TabloRipper saw it immediately. :slight_smile: All set. Very thankful for this app! Cheers.

1 Like

I am having trouble after installing window 11. It doesn’t bring up the gui. Can you help?

I don’t have windows 11 installed, so you’re a pioneer (they’re the ones with arrows in their back).

Sorry. But maybe someone else has given it a try with better results?

I hope so. I thought it was just off screen some where but I can’t bring it back if it was.

It does store it’s last reported position on the screen. Try removing the TabloRipper folder you’ll find under “c:/program data” (that folder is hidden by default).

Ok thank you. I figured it out. Gui was off screen.

1 Like

I recently upgraded to Windows 11 and Tablo Ripper is working just like it did under Windows 10. I’m opening Tablo Ripper using Chrome, so if @Mark_Sloat is using a different browser, that may be the problem.

Thank you but I figured it out. It was just off screen and I had to bring it back.

Hey @CycleJ!

I can’t believe I’ve had my Tablo for over a year and never noticed this thread. Yesterday I was looking around the forum for tips on how to upgrade to a larger hard drive and that’s when I found mention of your utility. This thread is pretty long, but I’ve managed to read through about the first 1/3 of it so far. :smile:

Anyhow just wanted to let you know that your utility is the BOMB. GREAT JOB MY FRIEND! A few months ago I had setup a Raspberry Pi with a 2TB SATA SSD and configured it with Open Media Vault to act as a NAS along with Plex (Network Chuck has a great video on this on youtube). I was using this to host a bunch of movies I had ripped for my daughter previously. Now with your utility, I am able to offload some of my favorite TV shows (like MASH) I have recorded and I can serve them up on my little plex server as well.


Thanks for the kind words!