Tablo Ripper - Automatically download new recordings

One problem is that the windows service for TabloRipper isn’t “you”. You can change that if you change the default user to be your login for that service.

Not ideal but possible “work-a-round”, as a last resort. Export locally, run post-processing script which will - mount network share, copy/move files, disconnect shared drive.

Or may just move files using \network\path with credentials directly and not actually mounting a “drive” (if this is possible in Windows)

1 Like

Thanks for the suggestions. I haven’t even tried the service yet. Just running exports manually.

1 Like

@toddk63 you can use the solution that @djk44883 suggests or there are other solutions that also get you there.

The easiest is to just create a network location (which will prompt for user/password when you create it) then it’ll use those credentials when you access that location. This will require the TabloRipper service to run as “you”.

Running 2.4.3. Starts to populate the files from my Tablo to the Tablo Recordings box and then get a message that says Exception: Object Reference not set to an instance of an object. Any thoughts or ideas oh great ones?

As always, enable logging, try a rip, disable logging and look for an error at the bottom of the log file.

If the problem isn’t obvious, let me know what the log says.

Whoa. Way above my head. For some strange reason it is ripping now. Scratching my noggin, but not complaining. Thx man.

I have successfully got the export to go to a network location manually. I want to make the service work now. By default the service runs as “Local System”. It seems to do nothing. Am I not waiting long enough? What is the cycle time for the service to check for new programs? I believe you are hinting that the service has to run as “me”. Is “me” the login credentials I use to access the Windows computer that the service is running on? I have tried that and get "Error 1069: The service did not start due to logon failure?. What am i doing wrong?


Update. No more Error 1069. Service is logged on as user, but still do not see anything happening with new programs.

You might also check the Configuration Guide for “start/stop service”, “service starts after” and “ends before”

This is as close as I have got to get the background service to work. I can export manually to the remote linux PC, but had to first create a new user (other than the Windows user) on both the linux and windows PC to map the SAMBA share to Z: drive on windows. The service works fine as long as the output folder is physically on the windows PC and not the mapped Z: drive. When I run the service as either the Windows user or the new created user, I get the error below “Exception: Could not find a part of the path ‘Z:\tmp’.” I have also tried running service as Network Service and Local Service. It doesn’t even respond as these two. Yes I verified permissions in linux for owner, group and other. All are read/write.

11/5/2022 4:30:14 PM recList.Length=272
11/5/2022 4:30:14 PM newCompletedList.recIdList.Length=271
11/5/2022 4:30:14 PM InvokeApi
11/5/2022 4:30:14 PM JSON: {“server_id”:“SID_5087B8201686”,“name”:“Tablo”,“timezone”:"",“version”:“2.2.40”,“local_address”:“”,“setup_completed”:true,“build_number”:2202115,“model”:{“wifi”:true,“tuners”:2,“type”:“gii”,“name”:“Tablo DUAL LITE”,“device”:“gen2”},“availability”:“ready”,“cache_key”:“6b747bce-bc4f-4c4d-aa51-c2e70d260efc”,“product”:“tablo”}
11/5/2022 4:30:14 PM RemuxRecording
11/5/2022 4:30:14 PM FFMPEG : C:\Program Files\TabloRipper\ffmpeg.exe
11/5/2022 4:30:14 PM TempOutput: Z:\tmp\Background_rip.mp4
11/5/2022 4:30:14 PM Output : Z:\Have Gun — Will Travel\Season 01\Have Gun — Will Travel - s01e33 - The Silver Queen.mp4
11/5/2022 4:30:14 PM Exception: Could not find a part of the path ‘Z:\tmp’.
11/5/2022 4:30:14 PM All done.

I remember trying to use the “map” command (net use) back in the old days, but that doesn’t persist when the service logs in to run. Thus the error message you’re getting. What might work is using a network location instead.

Thanks , i will try that again. Had trouble with it too, but maybe doing something different now.

“The user name or password is incorrect.”

I cannot figure out what user name or password is wrong. The service is logged on as the Windows user using that password. The Windows user has access to the SAMBA share on the Linux PC and I can see the Tablo output files and manually write to them. The SAMBA password IS different from the Windows logon password. This is by design. If the two passwords are the same, the Windows user can access the SAMBA shares without a password, which I do not want.

This is really a great program and manually syncing the new programs is not really that much of a bother. I just want the service to work if it is supposed to. I am wondering if it is something simple I am overlooking. If anything, I have been learning all things file permissions and services this week. I have been off from work this week, but sadly return tomorrow, so won’t have the same kind of free time to fuss with it.

Here is the log:

11/6/2022 3:00:43 PM RemuxRecording
11/6/2022 3:00:43 PM FFMPEG : C:\Program Files\TabloRipper\ffmpeg.exe
11/6/2022 3:00:43 PM TempOutput: \\Tivo-2TB\Tablo\tmp\Background_rip.mp4
11/6/2022 3:00:43 PM Output : \\Tivo-2TB\Tablo\Have Gun — Will Travel\Season 01\Have Gun — Will Travel - s01e33 - The Silver Queen.mp4
11/6/2022 3:00:43 PM Exception: The user name or password is incorrect.

11/6/2022 3:00:44 PM All done.

This was the problem. I changed the dummy Windows user password to the same as the SAMBA password. Even when logged in as the main Windows user, I can use the credentials of the dummy user for both access to the network Tablo output directory AND the Tablo Ripper service. Then it works. Since the dummy user only has access to the Tablo directories on the network, the other network shares still require a password to access.

I’m glad you figured it out😁

Got it downloaded, thanks. I can’t seem to locate my Tablo on Wi-Fi. I have a hdmi connected quad unit, will that work with Tablo ripper?

1 Like

It may not find your HDMI Tablo automatically, but you can try to input your Tablo’s IP address manually. See below:

Tablo Ripper Screenshot


Got it thanks!

@CycleJ - thanks for the excellent app, I’ve been using it for awhile and it works great! I recently noticed that ripped TV shows displayed the show title where the episode title would be expected. After extensive troubleshooting of Plex and filenames, I found that the ripper places the show title as the title in the file metadata and after manually changing that, Plex displays episode titles properly.
In your next release, would you please update so that episode title populates the metadata title so I don’t have to manually update each file.
Thanks in advance!