Tablo Ripper - Automatically download new recordings

I’m not sure what the new Dual HDMI has to do with remote access, but I can answer your question about remote access not working with Tablo Ripper. Tablo Ripper requests a connection to your Tablo that’s refused unless both devices are on the same LAN.

I’m sure some enterprising individuals have tried implementing a VPN for remote access. Perhaps that’s what you should pursue? It wasn’t a problem for me since my use case was exporting shows to Plex (which you can watch anywhere on any device).

Good luck.

The Dual HDMI Tablo doesn’t seem to allow remote access. You can’t use the web app and they do state it was not made to be a remote device. Yet it must have some way of being accessed remotely. My Roku has access to it using the Tablo app. All this is being said I’m talking only about my local home network.
My old Tablo Dual Lite had no issues and I could access from remote places and of course my home network. The Dual HDMI is not the same animal.

When you say remote access I think most of us equate that with this functionality…

Out-Of-Home Streaming | Over The Air (OTA) DVR | Tablo (

But are you just talking about a playback device on the same local network (i.e. a Roku on another TV besides the one the Dual HDMI Tablo is physically connected to)?

If the Dual HDMI is on the same local network as the PC running Tablo Ripper, there isn’t any reason it shouldn’t be able to connect to it is there @CycleJ?

Yep just a in home network access doesn’t work with it. So my ripper can’t access or see it. Not sure why. Even the Tablo Web app doesn’t work in my house on my PC I can not gain access and they say the Web app won’t work with it.

Have you tried using the Tablo local IP address to connect within TabloRipper? If that doesn’t work, I’m clueless. Sorry.

“as expected” would negate “remote access”


Yeah I did try that , it timed out on me. I’m thinking I have missed something here. My Dual Lite Tablo had no issues with the Ripper. With the Dual HDMI there may have a way , but I have not figured it out yet if it does.

OK it works now. I have no idea why , but I went back and tried 2 times to input the IP only to watch it fail. I rebooted my PC ( for other issues ) and went back to try again. Third time was the charm. It works just fine and the Ripper is back on line. Why it didn’t work the first few tries I have no idea. It does however work now. It can’t search and find it , but IP input does work. Being stubborn does pay off sometimes. Thank you all for the replies and help.

Now that the issues is resolved… I’m thinking almost everyone? A screen shot from the setting tab
That’s kind’a what it is - Tablo Connect = Remote Access / Remote Access = Tablo Connect

I may come across as a dudu :poop: head pointing out things which are other wise semantics, particularly with tech – words really do matter.

Glad you got things working. Fingers crossed it stays that way :wink:

Thanks CycleJ

Now if only I can get the Tablo tools to work. :grinning:

Continuing the discussion from Windows 10 Exception Error:

@CycleJ some of the confusion may be:

Version 2.4.1 64-bit 32-bit

  • Final/Stable

Although there is a newer version… there’s no dates. There may be some misunderstanding the next higher may be testing or beta version. A user would want the stable version… final build. Not knowing there was anything needing fixed.

Yes, conventional logic would take the highest version, but “final/stable” could be misleading for some.

Sorry for the confusion. At the time I wanted to be really clear that there’s no new development. But then I took an educated guess at fixing a TLS connection problem created by a Tablo upgrade, and voila, a new “final” version was born. This time it’s really done.

Actually I quoted the wrong post… moving it to your Tablo Ripper thread -

It appeared they got the “wrong” version. I wondered why, then looked at the page… I would have gotten the highest version - but the one does say “Final/Stable” and some users may figure that’s what they want.

Sorry for the misunderstanding.

Good suggestion. I edited the download notes to hopefully make things clearer.

I put in the static IP but it still shows no Tablo Recordings after initializing. I have tried both WiFi and LAN connections. Installation work fine. The Tablo does not appear on the dropdown list. It appears the Tablo Dual HDMI is piece of junk.

Your Tablo does not work with your TV?

Do you have a Guide Subscription?

Just widely speculation, you need a subscription to stream from an HDMI tablo (even within your house on your local network).

Although it’s been confirmed Tablo Ripper does work, it’s not clear if you need a subscription to get the device to even “stream”.

If you do have the subscription, then, there’s other trouble shooting options before concluding “piece of junk” at this point I hope.

Using a static ip address bypasses the tablo “list”, so it’s normal for that to remain empty.

Does TabloRipper “connect” to your tablo? You might want you enable logging, restart TabloRipper, then look at the log file for errors.

I finally spent the afternoon redoing my entire entertainment center and the MVidia Shield works fine over LAN. It is much faster then using the Tablo Dual itself.

The problem is not LAN. The are doing something to disable any device that does not use their app. I doubt ota2go work either.