Tablo Remote Connect


I setup RC per the Chapter 6 guidelines and received no errors during my tablo or router setups. I then downloaded and installed the TabloTV app from the play store on my Note 5 and while at home opened it and watched a few minutes of a couple of different recorded shows.

I then took my Note 5 to my office and the first time I started the app it worked but I was unable to playing anything. It would kick back with “unable to play live stream” or “unable to continue video”.

I restarted my phone and now when I start the Tablo App it goes to “retrieving tablos” then to “connecting” and just hangs there.

Any idea what this is about?

Go home, re-pair the Tablo app over WiFi. Then try connecting to the Tablo just over your 3G or LTE network.

Some work networks block ports needed by the Tablo app.

I am the Network Admin at work!

Anyway the problem was simple to diagnose but troubling…the Tablo locked up.

More worrying is that the blue button wouldn’t reset / restart it. I had to yank the power cable.

Once it was power cycled though it worked fine, even on my Note 5 via 4G LTE.

I hope that this isn’t a constant problem. A good chunk of the reason I bought this, instead of a doing a roll my own solution with Kodi or WMC, was to have an appliance I didn’t need to fiddle with all the time.

What firmware are you running? 2.28 or a beta?

2.2.8 and it just locked up again while my wife was trying to RC from her laptop.


Open a Support Ticket - they can look at your logs.

This may be a heat issue. I was aware this could be a problem so I put it up high, didn’t stack anything on it, and actually put the Tablo itself on top of the box that it came in.

What I discovered after my 2nd or 3rd reset of the night was that while the top of the box was cool to the touch the BOTTOM was very hot.

To add some air gap between the bottom of the Tablo and surface it sits on I put two bic pens under it, one on each side, which made a nice 1/4 to 3/8" gap. I then went hours last night without a lockup even with me using a tuner locally and my wife pulling recorded content via RC. In fact RC is still working fine as of now some 18 hours later.

If everything continues working for another day or two I’ll get some thumb tacks and push them into the rubber feet to create a more permanent stand off.

You could also try turning your Tablo vertically on its side. That’s how I run mine.

1 Like

@MrCliffyG Send us a ticket - we’ll get logged in and see what’s going on.

I ordered the DEEPCOOL WIND PAL MINI Laptop Cooling Pad 15.6" Slim Design 140mm Silent Fan Blue LED from Newegg US for 9.99 with free shipping. I set my Tablo and 2TB Seagate usb portable drive on top of it and plugged it in. It makes NO noise and very little breeze …but my Table is now just barely warm to the touch and before it was HOT - 90++. And my HD seems to be just fine up there…so far

Now I know that they say that 90+ is normal for the unit, but I have always found that cooler electronics seem to last longer.