Tablo remote connect works intermittently with Xfinity / Cisco DPC3941T

Hello all - I am a fairly new Tablo user. My ISP is Comcast/Xfinity and I’m working with a combined modem/router made by Cisco [model: DPC3941T]

Inside my house, all devices (Roku, tablets, phones, etc.) are able to access my Tablo just fine.

Going through the setup process, when I check the option for remote access, the settings screen processes for a bit and then comes back saying ‘Your Tablo is ready for remote access’ From then and maybe a day or two, I can reach Tablo remotely (with my phone) from an offsite location like my office. Everything works great.

Some random amount of time after that, I’ll try it remotely and it will not work.

Getting home, I go to the Tablo settings and find a notice saying that my router requires manual configuration blah blah.

Usually, I can uncheck the remote access check box and re-check it – and, I’m good to go again. (for at least some random amount of time)

I assumed that the issue might be related to my router changing the Tablo’s IP address so I set a reserved IP for the Tablo – now known as However, even after doing that I’m still experieincing the intermittent drops.

From one other post on here, I know that the router model I have doesn’t support port forwarding entries in a more traditional way — but if that were the limiting factor here, I believe the remote connect would just never work. In my case, it works and then doesn’t.

Any ideas what might be contributing to my challenge? Does anyone on here have the same model equipment that I have and have overcome the issue?

You should be able to Disable UPnP on your router/modem combo. Then manually configure the port forwarding for the Tablo.

I tried searching for a manual for your modem but the documentation isn’t complete with the Advanced features / screen. Maybe you can post some screenshots and we can help you through it.

More Google’ing revealed many people have issues with port forwarding with that modem you have. Supposedly instead of using the Local Gateway Admin Tool (this is what you get through the 10.0.01 website), you can use the Xfinity web portal to also setup port forwarding. See link below. Link to the web portal is on the page below.

Thanks theuser86. We have had Xfinity for a few years and I never realized I could do on-line configuration of my network vs. going through the gateway device.

I accessed the Xfi portal and ‘named’ my Tablo (found MAC address and confirmed that IP was what I reserved it as) So…IP is now known as Tablo.

My remote connect worked for a period of time today and then went into error state with the requires manual configuration message.

It says I need to map public 21101 to private 8887 and public 21100 to private 80.

Using the Xfi portal, I can access the port forwarding area, locate my Tablo and then enter the area for manual configuration.

However, the entry form UI is totally confusing (a very poorly designed UI). It doesn’t seem to have the notion of public-to-private – only fields for port #. I tried entering 21101 in the first field called Port Number. Then, clicking on the Add Port Number link, I got another port number field where I added 8887. I repeated this process with 21100 and 80. The result just looked like it was going to forward all 4 of those ports to my Tablo. After doing that, I tried to ‘retest the mapping’ in Tablo settings but no dice.

I tried searching for help but all it really says is to enter your ports. Something tells me that I could open 21101 and 21100 and direct that toward Tablo. However, I don’t know how to get that to resolve to 8887 and 80, respectively.

I saw your other suggestion about disabling UPnP but I don’t know what that really means.

Hi — I am having this same issue with the XFi app. If you come up with a solution please post here!

I wound up switching to Verizon Fios where I started experiencing the same issue: Would enable remote connect, have it work properly for a few hours and then it would stop working. When revisiting the Tablo settings, I would see the same message: Your router requires manual configuration.

Well, I finally found a work-around.

I opened my Fios Router admin and went to the port forwarding section. Watching that, I clicked the option to remote connect the Tablo. After that, I could see the 2 port forwarding rules inserted by the Tablo via UPNP. When I went to look at the UPNP settings of the router, there are two checkboxes. Enable/disable UPNP and Clean-up old/unused UPNP connections.

I found that by unchecking the clean-up option, the port forwards added by Tablo were allowed to persist. My theory is that if the router didn’t see traffic on those ports over a certain period of time, the router was just removing the rules.

Down the road, I plan on working with Verizon to figure out how to manually enter the same rules added by the Tablo so I am not dependent on UPNP and from there, I will re-enable the clean-up because I’m not sure what the implications of having the clean-up unchecked might be long-term.

Hope this helps.

If you set up the port forwarding manually, I recommend you Disable UPNP on your modem rather than re-enable the clean up option.

I might do that too because other than using the Tablo, there are really no other needs for me to do port forwarding on my network.

However, I do see that Verizon has added a ton of forwards for enabling some of their things (home phone, TV, etc.) so I might just leave well enough alone.