Tablo Quad - No Tuners Available

I’ve opened up a case with Tablo support, but unfortunately they seemed to have disappeared, so I’ll pose this issue with the community:

I have an original Tablo Quad (circa 2015), and lately (and perhaps coincidentally with the 2.2.36 firmware update), all four tuners are reported “in use” and unavailable. A power-cycle or single-button-push reset clears the problem for a little while (perhaps a day or two), and again all four tuners are reported in use.

The consequences of this problem is 100% failure of scheduled recordings.

I have my Tablo sitting on a cooling fan and the disk drive was replaced in early May 2021. It was running fine with the replacement drive until 2.2.36 firmware.

Has my Tablo finally bit the dust, or is there maybe something else going on?

Hi there @KapnKrunch - It looks like your ticket was moved to the back of the line because you followed up before we could get to your ticket. I’ve let the team know and they’ll be in touch very shortly.

1 Like

@TabloTV given how much this seems to happen (person tries to provide more info and gets pushed to the back of the queue), could your help ticketing system be modified to be straight FIFO on ticket creation date/time?

2 Likes

Thanks. I got a direct response, and I’ll be working directly with your support team.

Wow. That’s kind of a weird system. Perhaps some sort of caveat message in the first automated response would be a good idea. I would have held off knowing I was shooting myself in the foot.

1 Like

Maybe there is a reason the help ticket system works the way it does.

The way it works has been mentioned a number of times in the forum.

Maybe it prevents people from gaming the system. Or maybe it prevents “the squeaky wheel gets the grease”. Many people may think that the more they pester support the faster their issue will be resolved.

…and maybe your support hours could be more realistic across multiple coast-to-coast time zones, been something brought up often. How about a few weekend hours when user have time to toss at trouble shooting tablo issues. Seems to happen be an often encounter.

Oh, you’ll look into it. ok, cool, thanks.

I’ve live in PDT for over 50 years and have owned multiple tablo units for over 6 1/2 years. In the early years there were a lot more problems then today and users seemed to survived with the current support hours.

There are any number of large companies with CDT service hours. Of course for for those who want either immediate respnse and/or after hours support there are business models for support as a service.

but why do you suppose their tuners are all used up when… they aren’t really “in use”?

“In the early day” I suppose the user base was much smaller, generally more tech savvy as all this stuff was less common.

Number of large companies… have large profits. Increased tech support takes resource$ for training $ for infrastructure which equates to less net profit :frowning: It’s a business model for profitability. can’t really be upset about it, but there’s always room for commenting.

It use to be possible to have real out-of-tuners and phantom out-of-tuners. Often you could use the Live TV menu to verify the tuners in use by the blinking red highlight.

Then there is high resolution where a four tuner could could only use 3 tuners. Then there tuners used for remote connect transcode.

But there could always be phantom tuner inuse. Tablo app use to have 2 basic engines. The HTML and the Restful API. And the tablo firmware use to have the evil spinning wheel of death for reconnecting. Depending on what you or the tablo unit was doing a tuner may have been marked in firmware as in-use. And since reconnection had a high failure rate it might stay in use until the unit was rebooted. And since I have multiple 2-tuners I could see the problem once a week.

Of course we could talk about what use to happen during a channel scan if the app thinks it needs to reconnect as the scan output is happening.

I primarily use Roku, 720p, no remote connect and a solid LAN. I haven’t seen this problem recently. Maybe reconnect either doesn’t happen anymore, or happens in the background with failed reconnect timers.

I had a similar issue years ago, which turned out to be tuners not releasing weak signal stations after Live TV viewing, or recording.
Technical Support was perplexed.

First, I just removed the trouble channels, however, I missed viewing them.
After getting a much better antenna, mounting it on my roof, and aiming it to get the best signal from all stations I cared about, never had that issue again.

Interesting. However my situation is a bit different. I already have an outdoor antenna with amplification, and all of the stations that I record are solid and strong.

Tech-support said they accessed my hard drive which apparently had a damaged file structure. That sounds a little weird to me. I don’t really understand how a damaged file structure on an external disk can knock all tuners off line.

Perhaps technical support can weigh in, but maybe file status is reported back to the Tablo and “releases” the tuner for subsequent use.

UPDATE (8/4/21): Turns out that my Western Digital Elements 5TB HDD was actually defective. When I reformatted the disk on a Windows 10 system, reading and writing worked under Windows, however doing a basic scan for errors hung the system. I had to reboot my PC to recover. After that, as long as that drive was plugged into my PC, overall system responsiveness ground to a halt.

Unfortunately, this WD Elements disk does support SMART (which I think is a major shortcoming), and if it did I’d have a good picture what was wrong. Fortunately, it’s still under warranty (being only 2 months old), so a replacement is underway.

Bottom line, I’d recommend against any HDD that doesn’t support SMART, because I believe Tablo will eventually catch up the the times and implement it in a future update.

UPDATE: I received a spanking-new Western Digital Elements 5TB HDD, and wouldn’t you know it, the “no tuners available” problem is back. So, I did a complete factory reset on the Tablo, and recordings worked fine for about two days, then, again the problem returned.

My conclusion is that the Tablo itself has failed. I’m thinking perhaps the on-board RAM has a bad region. The “persistent” scheduling and recordings information in this RAM begins to fill up, and eventually hits the bad region, and the failures begin.

I’ve ordered a new Tablo Quad, and I’m confident this problem will finally be resolved.

Was it “spanking-new” or do they replace with a factory reconditioned drive? The same our you recommend not to get?

You have the exact same problem with a bad drive, but this time…

So it would have otherwise worked with the bad drive if it weren’t for the suspected RAM? Or did the bad RAM cause the drive problems?

Ok, I’m just trying to follow your logic? Just like that - you suspect it’s RAM? based on? Replacing a bad drive?


I do believe you will be satisfied with your new Quad!! and you did get a reasonable run from your 4-Tuner :grinning_face_with_smiling_eyes:

I used the process of elimination. I first replaced the drive with brand-new one. Not reconditioned. My “not recommended” comment was based upon the lack of SMART support, and personal opinion. However, the drive IS recommended by Tablo as a compatible device. Same problem occurred.

I’m speculating that the Tablo’s native NVRAM (which holds schedule and recent recording metadata), after factory-reset, begins to populate starting from a specific memory location, and gradually captures more information as time goes on and recordings happen. If there were a defective NVRAM region, failures would start to occur once that region was accessed.

Again, this is speculation on my part, based upon my observation that after each factory reset, the problem would re-occur after a couple days of successful recordings. Then all subsequent recordings would fail. I don’t have any inside knowledge of the Tablo’s theory of operation, but basing this upon my personal experience with computers.

I installed my new Quad today, and will continue to observe and report my findings.

1 Like

Update: It’s been two days and my new Tablo Quad is working perfectly. No reports of “unavailable tuners” or any other mishap. The new Quad also appears to be somewhat snappier in performance compared to my old original Quad.

Conclusion: My sever-year-old Quad finally bit the dust. “No Tuners Available” was the only symptom. I’d be happy to have the Tablo team take it off my hands for a post-mortem (if they pay shipping, that is). Otherwise, it’s going into the electronics recycling bin.

1 Like

I had a similar issue with my Tablo 4-tuner (original one).
Tablo Max Recording Quality set to HD 1080 - 10Mbps, 720@60fps would occassionally trigger the ‘No Tuners Available’ error message.
Dropping Max Recording Quality down 1 level worked around the issue, and haven’t seen that error message for years, since the settings change.

Interesting. In my case, I had all quality settings at “normal” (recommended) values.