Tablo NOT detected by Roku 3

I have both a Roku 3 (in the Livingroom) and a Roku LT (in the bedroom),  The router is in the living room, and so is the Tablo.  I was watching the Roku LT and exited and went to the living room.  The Roku 3 did not detect Tablo.  Since it was detected by the Roku LT and the Android apps, I figured reboot the Roku 3.  I did that, and it did NOT solve the problem.  I then rebooted the Tablo, and now it is detected.  all devices are connected wireless using Linksys EA3500 router.

I’m having the same issue. I noticed it yesterday. I have rebooted Tablo and my network. I can access Tablo via the PC and my cell phone. So it’s connected to the network. But on all my Roku’s 2 & 3’s I get the not detected message. The Tablo is hardwired and I can see it on the 1 Roku that I have wired as well. It appears to be a wireless issue with Rokus? I have deleted the app and rebooted the Rokus. Still no luck

Have you set up DHCP reservation for the Tablo on your router?


@beastman @PlanesPilot We actually ran into some similar behaviour while building the brand new Roku app. 

There are some interesting (and undocumented) rules on the platform, so a few of them threw us for a bit of a loop. You can expect some significant improvements in the new channel.

When will we see this improvement? It’s getting to be frustating having to reboot the whole network in the house. Like tonight. I was watching TV in my living room. Turned it off and went to my bedroom to finish viewing. Now I get the cannot find error. My problem is both kids are watching other shows on Plex and Netflix. So I’m going to have to kick them off so I can try to get this working!!

I don't know which of the following fixed it, but since I put the Roku 3 and the Tablo on the 5 ghz network and since I started running the beta I have not seen the error.  The Roku LT is still on the 2.4 ghz network.  Maybe the Roku assumes only one Roku per WiFi network.  @TabloSupport can you test that theory and see if it is true there as well?

My Tablo is wired and my Rokus are wireless. My bedroom is a Roku 3 and it’s on the 5ghz network. The others are not. When this occurs, I get the same Not connected on all Roku devices in the house. PC’s and phones are fine, so I know Tablo is connected to the network?

Do you have DHCP Reservations set up for all the Rokus that are wireless?


  1. What is the brand and model of your router?
  2. Can you set up DHCP reservation for the Tablo so the router assigns the same IP to the Tablo? Essentially a static IP for the Tablo.

Netgear AC1750. Yes I have it set to a static IP. It’s something with the Roku’s that is the problem. I can still access Tablo with my phone and PC so i know it’s connected to the network. I even have one Roku hard wired on the same switch as the Tablo box and it will not work.

Does the problem happen after a period of time?  Like maybe when the DHCP lease expires?  Can you try making all your Rokus hard wired or at least turning off the ones that are not hard wired and see if the problem goes away.  It might be the ip renewal process in the Roku software is broken.

When the Tablo stops working are you still able to watch other channels on the Roku?

Yes it happens about every week since the last upgrade. Not sure why you are asking to hard wire the Rokus. That sure why you are asking to hard wire them? It doesn’t work either way? To get the system back up and running I do the follow. Unplug router, switch and Tablo. Turn on router, then switch and then Tablo. Reboot the Roku and I’m up and running. This makes it hard on nights that everyone is sitting in their room watching TV. Most of the time the kids are on Netflix or my Plex system watching through the Roku’s. Me and the wife use Tablo most often. I get the ugly looks when I tell them they are going to loose connection for a little while!!

Maybe @TabliSupport will address what was changed in the last software updatr in regards to networking.

I have two ROKU 3’s hard wired to my router, a Netgear Nighthawk 8000, a Tablo quad running the latest update, 2.1.28 also hardwired with an assigned IP address.  I recently added MLB TV to my streaming applications.  In order to get around black outs I use the unlocator DNS service.  After I began using unlocator, I noticed that the Tablo Roku preview channel would find my Tablo quad just fine, but would not connect to it.  It showed a message on the TV to go to    and make sure my Tablo was up to date.  The current production Tablo app and ALL other Roku applications that I use work just fine.  I confirmed by updating the router to use my ISP DNS and poof!! the Tablo preview channel worked as expected.  I switched back to unlocator DNS, rebooted the Roku and Tablo preview failed.  Great product guys, but Tablo shouldn’t give a darn about what DNS server is in use.  Here’s hoping for a quick fix.

@RJPingrey meet @midnightjim

Looks like you two are having the same problem by using alternative DNS servers.


Yes, this is the problem. I Confirmed with my roommate that he is using the unlocator service and using an alternative DNS. I had him switch back to normal ISP DNS and the new tablo channel worked fine. He turned back on unlocator service DNS and tablo preview can’t find the tablo. Normal tablo channel works fine With alternate DNS, as do the web tablo and iPad app. My roommate doesn’t want to remove his unlocator service since he pays for it. @midnightjim, you are correct, tablo shouldn’t be affected by alternate DNS, especially since old tablo channel isn’t affected. @tablosupport, what’s different about the way the two tablo channels discover the tablo on the network? Is there a fix in the works?


The use of alternate DNS servers is not a “normal” use by any means. I am sure they will fix it, but I wouldn’t expect it to be a priority.

Not to mention the use of alternate DNS servers to get around geographical blackouts is against the Terms of Service of those providers such as Netflix, Hulu, MLB, etc.

I don’t use ISP dns servers and do not have any problems. I have my router configured to use Opendns and have the Roku use and everything just works. Connected wireless using DHCP