Tablo never appears as uPnP server in Windows VLC

New Tablo user. I am trying to watch Tablo programs via VLC in Windows. Mainly so I can have better control of slow-motion and frame-by-frame for sports. Right now I have little interest in moving programs off of the Tablo drive via Tablo-Exporter, etc.

People seemed to chat about watching from VLC a lot around 2015 but not lately. The link to the Tablo-VLC Media Player by the mysterious user kwaa is long dead plus some of the last entries in that thread mentioned that it no longer worked. (Would love to know if it still works for anyone and if I could get a copy of the code).

My problem seem to be getting Tablo to identify itself as a DLNA or uPnP server. Tablo doesn’t show up in the Playlist page when I select “Local Network-Universal Plug’n’Play in the left tool bar in VLC. That is what I believe is the central problem. My MyCloud shows up but no Tablo.

Additionally I never see Tablo as a device in my Windows Explorer network. The Rokus show up automatically. I have enabled SMB, network media sharing, and Windows Subsystem for Linux. Additionally I have installed 2 small apps that allow browsing Linux directories. None of these ever find Tablo on the network.

The viewer works fine in Firefox in Windows, so I believe that this should be fixable in some way since my Windows system is somehow running the files from the Tablo device.

I can enter the IP address for a TV program into Firefox and pull up the directories and see all the files.

With some trickery, I can even get Notepad to open any given TV program’s .3m8u playlist. If I try to navigate to the directory, I get a ““You can’t open this location using this program. Please try a different location.” message. But if I enter the full path/filename in the filename field, it opens the file.

VLC player system is Thinkpad T430 running Windows 10-64 bit.
Tablo Quad running 2.2.26 with a 500GB internal SSD drive
I have tried VLC 3.0.8, 3.0.7 plus about a 2 year old version of VLC.

I think that I am missing something simple.
Any insights would be greatly appreciated!!

Tablo streams media via HTTP, so you have to get the “streaming URL” or playlist URL and I’m sure VLC will work. I regularly use smplayer to do the same thing.

It’s not a here’s how to do it type of answer. I could suggest a 3rd party app APL Tablo. From the Recorded window, it will give Copy Streaming URL. If you want to bad enough. This is really a straight forward method and extremely easy.

To make it super simple - launch VLC, from the Media menu choose “Open Location from clipboard” then click Play. (yes, I just confirmed it works that easy).

There are other PITA ways, or more interactive methods, but this is about as painless as it is for what you want I believe.


djk, thanks so much! I got it to stream from the VLC Media menu. as you suggested. Now, I need to figure out a method to tell me which shows belong to which URLs.
I will try to play with the APL Tablo app over the next few days.

1 Like

Well, that’s why I suggested the 3rd party app. APL Tablo seem to be the most user friendly, that I’ve used - it uses a GUI.

Not that that’s the only one to get the information… or the only way to dig it out. Just thought it’s be quick and easy for you, but if you want to hunt and peck, that kind of works too.

If you search through the forums and/or some of the scripts for old apps you can dig things out, but it’s still easier to use work someone else polished up. Considering you don’t even want to off load any media.

If you have any questions, post them in the topic and the developer will (generally) respond directly to your issues! But it’s not a game :poop:

All the information is there…it’s getting it into a ‘usable’ format that’s the hard part :slight_smile:

Thanks guys. I am playing around with getting APL Tablo setup.
I have passed several newbie hurdles so at least the Java environment seems to be working now. I am getting a page full of errors now and nothing else. I will PM LJ with what I am seeing.

fyi: where ever you installed APL Tablo you should have APLTablo.log which will aid in debugging if you didn’t copy the “page full” of errors.

If you post in the topic instead of PM, it may help someone else in the future with the same problem.