Tablo Lite: No ability to continue setup when zip code is entered--endless loop

I’m using the Google Play Tablo app on Tivo Stream. The app recognized my connected Tablo Lite (ethernet connection) and asked to continue. Next screen offers just “Enter Zip” and “Continue” options. (There was not any “use current location” option as shown in some guides) Of the two existing options given, Continue does nothing and does not work. “Enter zip” takes me to the next screen. I enter my 4 digit zip and it just sits there and nothing happens. There is no Enter button on the remote to tell it I’m done and to continue and no “OK” or other prompt to ask it to accept the zip and it does not accept it automatically when the last digit is entered. The only option then is to back out to previous screen and from there it is an endless loop, “Continue” does not continue and “Enter zip” goes back to the now empty box for entering zip.

I’ve tried power off/on reboot and the resent button for 30 seconds. Nothing works.

Use another device to setup your Tablo, maybe an iPad or a computer using the Chrome browser.

1 Like

What @theuser86 said, try another device - maybe a PC (

Can you use ethernet for this?

I don’t see why not! :slightly_smiling_face:

If your Tablo is directly connected to your router via an Ethernet cable, then the setup device such as your computer can be connected to your router via either an Ethernet cable or WiFi.

thought zip code was 5 digits. Maybe that’s the problem.


Excellent catch… but tablo is compatible with Canadian broadcasting…

Postal codes in Canada

A Canadian postal code is a six-character string that forms part of a postal address in Canada.

As for

I wonder if they’d enter that one or two more digit if that would end the loop.

I am going to bet that is just a typo lol And the OP meant 5 digit zip code, but who knows

I stayed far away from this post.

I found it strange that the post would include or need to include the size of the input - 4-digit. Especially since the 4-digit size is smaller then the minimum size of a U.S. zip code or the Canadian postal code of 2 sets of 3 alpha number characters.

Friends, thanks for your comments. The zip was 92011 (5 digit and it would not work). I had to use the web interface on a computer where Tablo could be updated and then all worked. Just out of the box, the Tablo setup would not function.


Hi James - You can use Roku or Apple TV to set up your Tablo but not Android TV quite yet.