Tablo keeps disconnecting from Roku boxes

A few days ago, the Tablo app on my Roku 3 started to do this thing where it disconnects immediately after we try to start it. It also disconnects from my Roku 4.

It sort of blinks once and then goes back to the Roku channel menu.

My Tablo is a 2 tuner version which I’ve had for a couple of years. Same with my Roku 3.

I was wondering if anyone else is having this issue.

I’ve tried rebooting the Roku 3, rebooting the internet router, rebooting the Tablo itself. None of these has worked. I also checked the app on my iPhone where I’m getting an error message that it couldn’t connect to the Tablo.

I checked the unit and the blue light on the front of the unit is steady blue. It blinks when I reboot it.

It looks like it works, but it’s as if the unit itself isn’t there.

The issue with my iPhone seems to have been solved. I found the solution here:

Still haven’t been able to figure out why I’m being disconnected from the Roku units.



I have the same problem on my ROKU 3s and ROKU 4

It happens when watching recorded shows, not when starting to watch, but while watching the show in progress.

When it does happen it will happen a couple times in a row after tablo reconnects and I resume watching…

However it doesn’t happen enough for me to pin it down.


I had the same problem. It turned out that the HD was drawing too much power from the power supply during playback and causing the voltage to drop and Tablo to crash and restart which led to a lost connection and then a reconnect. I inserted a powered USB hub between the Tablo and the HD to enable the HD to be powered from the USB hub and not the Tablo and the problem immediately disappeared. I think Tablo has fixed this in later hardware by including the same power supply as the 4 tuner model but mine had the older 1A (?not sure) power supply.

I have the same problem using a Roku Ultra. We watch a live show it stops and displays the prior popup after about 20 minutes. 2.2.22 with latest tablo roku client.