Tablo Gen4 Registration Processing

I received my new Tablo Gen 4 this weekend and was setting it up using the app on Android. It connected to WiFi with no issues and updated the firmware. At that point I get to a screen stating “Registration Processing” and “40 Percent Complete” and then it stops. After 30 minutes or so it says there was an error and “Try Again”, but it goes straight back to the same screen.

I tried uninstalling and reinstalling the app, using a different (Still Android) device, factory reset of the Tablo and unplugging / plugging it in a few times.

Has anyone else seen this?

Paul, Maine

Yes, happen to me also, ended up unplugging tablo and restarted it and it solved my problem.

I am having this trouble right now as well. I power cycled the device – still no luck. OP: did power cycling work for you?

I have power cycled many times, did multiple resets and factory resets and still have the problem. Just for kicks I tried setting it up yesterday by Ethernet, but as soon as the firmware downloads, I get the same thing. Just stuck registering the device when it reaches 40 %.

After I unplugged and restarted my Tablo Gen 4, it started working. At this point, I would call support and have them troubleshoot it. Good luck.

I have had a ticket open with support since the problem appeared, but wanted to poll the community to see if there were any other ideas.

I called the support line, and it was a bunch of ads (?!) and I was never able to get a live person. I tried installing with my wife’s iPhone and that didn’t work either. Super frustrating.

Update: I was able to get a live person on support. They recommended the same procedure of power cycling and everything, which did not work. However, as we were hanging up they suggested trying a different zip code – and that did the trick! (I switched from my suburb zip 02459 → nearby major city zip 02215). I did this in conjunction with a fresh restart, but not sure if that was necessary or not. Anyway, I suggest you try the same, and hopefully it works for you too (and any other frustrated customers who find this thread!)

That worked! Thank you! I switched to the zip code for the closest large town (I live out in the middle of the woods) and it completed the set up.

Yep zipcode change worked for me too - initially it suggested a neighboring zip code - I changed it to my actual zip code - it then got stuck at registration. As soon as hit back and accepted the suggested zip it moved to next screen