Tablo does not recognize hard drive

I just got a 4 tuner Tablo last week and really like it. Trying to add a hard drive so I can record programs. I attached a WD Elements hard drive to the Tablo box. When I go to the TABLO page of the Roku app it shows “no hard drive connected”. I had previously tried a WD My Passport hard drive with the same results. What do I need to do so the Tablo will recognize that a hard drive is connected? I would appreciate any suggestions.


  1. Power off your Tablo by unplugging the power cord.
  2. Connect the USB HDD.
  3. Power on the Tablo.
  4. Connect to your Tablo using the Tablo app on a smartphone or tablet (iPhone or iPad for example), then see if it asks you to format the HDD. Do not use the Roku.
1 Like

That worked!!! Thanks

1 Like

No problem.

Which drive did you use?

The WD Elements of WD My Passport?

The WD Elements. 2TB of storage.

That’s the drive I’v been using for a long time now. Coming up on 3 years next spring. Plenty of storage for my needs, and still working great.

I’ve recorded a few programs using the WD Elements hard drive and have noticed during playback that the video is breaking up. Is there a setting that can be changed to eliminate this?

What you are describing is likely pixelation of the video. This is generally caused by weak / poor OTA signal. You’ll need a preamp at the OTA antenna or a bigger antenna.

If you are seeing this issue on ALL channels then it could be do to the hard drive. I’d replace the hard drive then.