Tablo crashes all the time it is very unreliable

I have 2 Roku ultra on different TVs and 1 Roku streaming stick on a third TV, consistently on each TV shortly after I start streaming the screen will go blank (black) with a “Loading” and a full blue progress bar, shortly after that the app will crash and I will get the welcome screen (first connection) “Discover live TV and DVR…” and I will have to search for the Tablo device again, other times in the middle of the show or any streaming I will get a blue screen “Reconnecting to Tablo…”. I have the latest OS in Roku 8.1.0, and I have the Tablo Dual Lite just purchased yesterday at Best Buy connected via Ethernet cable to the router. This is gettng very annoying because I will loose the beginning of the shows I am watching, there seems to be so many issues and reliability is poor, please could you advice what to do, thanks

NOTE: similar unreliable behavior with my iPhone 8 Plus, iPad Pro 12.9, the issues are across all devices

UPDATE: In 30min streaming I got the Loading issue, Search Again isssue, Reconnecting to Tablo issue and now it went to the Live View home screen, in summary 4 crashes in 30min

While I don’t have a Roku problem that bad, I got the update on June 27th on my Roku 3 -4200.

While I’m using an old tablo unit that is wired I have seen the Roku app blow all the way back too the main Roku menu.

Sometimes reentering the tablo app will spin will connecting (the tablo unit is not rebooting) and sometimes the discover menu appears It’s seems pretty obvious that when an immediate retry discovery fails immediately the Roku OS is probably not feeling well - for whatever reason.

So now I just reboot the Roku and life seems to go on for another day.

Open a support ticket and have them look at the logs.

Thanks I just created a. Support ticket

Same problem. Had my Tablo Dual Lite for less than a week, already a member of this “crash club”. I get the same errorr “Check Internet Connection”, etc. First time I requested help through Support Ticket (separate issue), took two or three days to get a response. This has happened several times since I bought it (FIVE times today), so if it takes that long for a response again, I’ll have returned it by then. So much going for it and so many great reviews on Amazon, I’m very disappointed.

If you’re getting that message when using a Roku, it’s a Roku message, not a Tablo message, and literally means there’s something wrong with your internet connection to your Roku.

Wrong. I’m using an Amazon Fire TV. Having the same problem on both platforms, both Amazon Fire and Roku, whether wired or wifi. This is not something you can blame on a Roku, the problem is in / with the Tablo.
Plus which, I don’t believe a Roku (or any other device) can force a Tablo to crash, blink constantly and then go out … which is what my (new Tablo) does. Once I’ve reset the Tablo, goes back to normal for awhile but not for long.

Wasn’t trying to blame the Roku.
You said…

I’ve seen this error on my Roku… when my internet connection was down.

Yes, I’m experiencing this on both platforms (Roku and Amazon Fire TV). The Roku error makes it look as though I either don’t have a Tablo, or that a Tablo has never been connected to begin with. The Amazon error just asks me to connect. In both cases, once I’ve clicked-to-connect, same result after (they both) time out.

Simple fix, I’ve been either resetting (reset button on back) or rebooting / power cycling. After it goes through its boot up conniptions, light stops blinking and all is well … for a few hours.

It sounds like there’s something chronic going on; you shouldn’t have to reboot routinely. Are you still chatting with our team? We should be able to take a closer look at the setup and see what’s going on.

Same here. I thought I had my Tablo problems behind me after I rigged up a mega heat sink & fan (posted a how-to in another thread here). Worked great for a couple of weeks and then yesterday when Mrs. User tried to watch TV she got the “Connect to Tablo” screen. It never connected and when I got home I rebooted the Tablo. It eventually (10-15 minutes) showed up and we were eventually (5-10 more minutes before “Live TV” was available) able to watch TV. I thought maybe this was just a one-time occurrence, as my Tablo now runs really cool.


Came home again today and same thing has happened. I guess I’m headed for a support ticket also.

As I mentioned in my other thread, I will gladly accept a unit the size of a DVD player if it is reliable. The current device is not reliable.

I ended up switching the Tablo Lite with a Tablo Duo, I’ve been using it for the last 4 days without a any problem, not a single crash or reboot.

You mean the OG Tablo 2 tuner?

The “newer” models are Tablo DUAL 64GB, and Tablo DUAL Lite.

Sorry, the Tablo Dual 64GB replaced the Tablo Dual Lite, no more issues.

Hey there - I can see that you touched base with our support team. We sent you a note today. I’m confident the team will get you up and running :slight_smile:

Is your Tablo connected to your network wirelessly using wireless-n @ 2.4GHz?
My Tablo would disappear from my network at least once per day, sometimes more.
Only a powercycle would bring it back online.

Your “team” took FOUR DAYS to reply to my Ticket. No thanks.