Tablo Connect with Dlink DIR-632 router

I am trying to get my new Tablo to see my Dlink DIR632 router. The router supports UPnP, as Slingbox was able to connect that way. I’ve done port forwarding before in order to enable Plex. My Tablo though, is different.

First, only two ports show up as needing to be changed in my Tablo control panel. I enter these into the Port Forwarding section on the router, and reboot the router, and test the ports. I receive back the “Hello world” and Tablo server messages. Can I assume this means that the forward is working? Where is the info for private port 443 (the one that is missing?) If Tablo has created this one, shouldn’t it show up on the router side? I have reserved a specific IP addr for the Tablo, so that it always comes up as 192,168,15,100 on the private side of my network. This has worked over many reboots and a complete power failure.

If anyone has any experience with the DLINK DIR 600 family and Tablo Connect, and is willing to give a noobie some direction, I would surely appreciate it.

Jim Zix
Fort George G Meade, MD
Home of Armed Forces Network (AFN)

PS: We love the Tablo. We are located between Washington DC and Baltimore and receive 49 channels (with “green” signal strength) using only a non-amplified Amazon flat antenna taped to the inside of a second story window. We lived outside of the US for the past 11 years and are amazed at how much good (old) stuff is now available on the secondary channels, and how great the HD picture looks.

  1. What is the make and model of your modem? Not the router.
  2. Is your modem in bridge mode? Bridge mode disables the router function of the modem, which most new modems come with these days.
  3. What is the WAN IP of the D-Link router? You can find this under the status page. If the WAN IP is an Internal IP say then your modem is not in bridge mode. This means you are engaging in “Double NAT”, which is a router behind a router. This would explain why Tablo Connect does not work even after forwarding the correct ports.
  4. Tablo Connect only requires you forward two ports for it to work, 8887 and 80. It no longer requires port 443.

for jumping in. I really appreciate your help. My cable modem is a TP
Link TC 7610, a dedicated modem NOT leased from the cable company. I can
access it thru my network, but the only settings that I can change are
the user name and password. The other tabs are all status tabs.

WAN address reported by the DLINK DIR-632 is, which maps
to Comcast, my ISP. Below are the screen shots from the virtual server
and port forward screens on the router.

Any help you can provide will be really appreciated!
Jim Zix

  1. Update your router to the latest firmware v1.03, see link below.
  2. Have you set up DHCP Reservation for your Tablo? See Page 29 of the PDF manual, link is below. If not, please do so.
  3. You only need to configure the 2 ports on the Virtual Server page. Do NOT enter anything in the Port Forwarding page. You only want to use the Virtual Server page to forward the External port to a different Internal port.
  4. Please ensure you are using the correct internal IP of the Tablo as this can change when you reboot your router, specifically if you have not set up DHCP Reservation in Step 3.
  5. Can you please post a screenshot of the Status page of the router showing the WAN connection? See page 68 of the PDF manual. You can blank out the last 2 sets of numbers if you’re worried about security. I just want to make sure your TP-Link modem is not assigning an internal IP to your router. I looked up the modem manual too and it does in fact have a built-in DHCP server too.

Let us know how it goes.

Thanks for this information. I will make the changes tonight after work! The Tablo does have a DHCP reservation set in the DLink router – we’ve had a couple of power failures on Post over the weekend and it served to confirm that the Tablo is correctly being assigned to the same address each time.

The DLink router is also “hard assigned” to it’s IP address, and does not pick one up from the cable modem. I will send the screen shot along once I get home.

Thanks again for the help.


So the WAN IP on the D-Link router is a Static IP? As in you physically entered all the information into the D-Link router?

That is correct. My local IP address ( was selected by me and coded into the DLink router.


The is the manually selected subnet of the router. The IP of the router then becomes The is an internal IP set.

This is very different than the WAN IP of the router. The WAN IP is the External IP assigned to the router by the ISP.

Yes, my WAN changes whenever I move (I am in the State Dept). I manually set the local, internal IP address for my network so that it (and the resulting IP addresses for all the connected devices) remains the same when I transfer from Post to Post. I’ve not had any problems with this setup for the past 7 years.

Am I doing something wrong? My subnet mask is Is this setup forcing a double NAT situation?


The fact that you can access the TP-Link modem through you router makes me think the modem is assigning a local IP to your D-Link router. What IP do you use to access the modem? This is the default IP of the modem based on the manual linked below.

Which is why I want to see the screenshot of the D-Link router Status page.

I see what you mean now. I will need to check when I get home. When we were at our last posting in Korea, we used ADSL for service (50 mbs) and the TP-Link modem was something I picked up when I returned to the US.


Sounds good - the screenshot of the Status page from the router will tell a lot.

The IP of the modem is, and the IP of the router is The fact when you are connected to the router you can access the modem means it is possible the WAN IP of the router is - which would mean you have a router behind a router (aka Double NAT).

The 73.39.xx.xx IP you reported above, did you find in that in the D-Link router interface or the TP-Link modem interface?

This is the screenshot I am referring to - I have boxed the WAN IP in red, you will notice how it is different than the IP Address listed under LAN.

Here’s the router page showing the WAN info for the modem. It appears to show the correct address for the modem. When I want to access the modem, I enter the WAN IP address.

GOOD NEWS! I cleared the Port Forward info for Tablo and made sure the info was checked on the virtual server page. (I had not checked off the settings previously). IT WORKS!

Thanks for the help! On the DLink, the user must check off the left hand check mark to enable that particular forwarding rule. It’s not made really clear in the online help, but is buried in the manual.


1 Like

Glad to hear it.

Your modem is in fact in bridge mode. The WAN IP of your router is an External IP, which is why it works when the correct ports are forwarded.