Tablo Connect port mapping

I have been working with the Tablo Connect on my new Tablo. When I first got it and turned it on UPnP on my router worked fine. However, after a few hours port 21100 ->80 and port 21101->443 would show up as errors. The tablo page would say my router required a manual configuration. 

I turned off UPnP and manually configured the ports and it worked…for a few hours. It would fail again with the same two ports, and the same message. 

Turning off the Tablo Connect for half a day would magically fix the problem. I would be able to turn on Tablo Connect with UPnP or manually configured for a few hours. Tablo support had a good suggestion and they believed that if there was a change in my DHCP reservation it could possibly play havoc with the ports which made sense. 

The next step was to assign an IP addy to the Tablo and manually configure the ports. I was able to access the Tablo using my iPhone using 4G. I went to bed and the next morning the Tablo was still on the address I had assigned it but the same two ports were bad.

I have used two separate routers, the latest is a Netgear WNDR3400v2, used manual port config and UPnP on both, and the same two ports are always failing.

The fix is unplugging the Tablo, letting it sit, and making sure the Tablo Connect is unchecked. Once it powers back on I can select Tablo Connect again and get a few hours of remote playback. Obviously this is not a solution especially if I am away from home. I can’t hire somebody to stay home and power off the Tablo every few hours when it has an issue and remote playback was the primary reason I purchased this DVR.

Any suggestions besides “Buy another router” would be appreciated.


The need to use two separate routers due to asymmetric port forwarding is a real pain IMHO, a completely avoidable design flaw.

My apologies…poorly worded on my part. I have tried two different routers. I don’t have two separate routers on my network now…but if that is a suggestion I’ll try anything :wink:

@gradman2k3 - Have you placed at ticket w/ @TabloSupport? If not, please do. They’ll be happy to help you work this out.

Have you tried updating the firmware in the newest router as well as factory resetting it and configuring it from the beginning?

I have the latest firmware and it was an extra router somebody had purchased. It was new out of the box and I spent an hour configuring it.

@TabloTV I do have a ticket open and am waiting for further suggestions. I am willing to open up the remote setting on the router if Tablo tech support needs access.


Further info…I am using Comcast in Denver. Anybody else from this area having an issue? Tablo support is saying something is changing on the network. Odd that I can reboot the modem and router and nothing changes but if I reboot the Tablo it works for a few hours.

It has been working for a week without issue. Nothing has changed …except me crossing my fingers reallllllllllllly hard :slight_smile:

@gradman2k3 - Well let’s hope it sticks. 

My fingers? or the settings :wink:

The settings! Sticky fingers are only good if you’re eating candy. 

Does anyone here have issues with Tablo Connect 2100X port mappings? When I bought the device in September it worked perfectly with old 3188X port mappings. Then I saw the new port map 2100X message in the settings page and decided to update the ports in my router, which is when all hell broke loose!

Now I can’t get my Tablo Connect to work in neither the new 3188X ports nor the old 2100X ports. I opened a trouble ticket (2555) and worked with David. He was very helpful, he even logged in remotely to check my router and said everything looked good but couldn’t get it to work. I have AT&T U-verse 2WIRE gateway.

I’m hoping for a firmware fix or a new set of ports to fix this issue. I sure would like to view my Tablo remotely. Please help!

I was able to solve this port mapping issue! I didn’t know you could change the ports to any number you want from the tablet app, until I installed the Amazon version in my Kindle. So I changed the 2100X ports back to 3188X ports and that updated the Tablo. After that I changed my router ports from 2100X to 3188X and tested it. Tablo Connect was setup for remote access!

So my AT&T U-verse 2WIRE gateway/router didn’t like the 2100X ports. Hope this helps others with similar issue.

Tablo guys, please provide this option to change port numbers in the web interface.

@rameshts - Tx for the suggestion! We’ll see if we can get that working. 

@rameshts Interesting - the ports can always be changed, but it’s uncommon that the ones we recommend are in use - or that they cause a problem. That being said, it sounds like a disclaimer here would have saved you some time. I’ll bring it up with the team.

Thank you. Also, I remember asking David if I could go back to 3188X ports during the remote session to which he said it wasn’t possible on his end. Maybe I misunderstood him.

Anyway, I’m so glad it’s working now :slight_smile:

I have the same issue. I’ve been asking support how to change the external ports being used for weeks with no result. Now I find this thread that says that changing the external ports will solve my remote connect problem… Yet, still no one says how to do it. Please provide a step by step procedure to change the external port numbers. Note: I do not have a kindle. My clients devices are iPhone, iPad, or Windows laptop. Thanks

Well, I just discovered how to change the external ports on my iPad. I also just updated to the latest Tablo software version so perhaps this is a new feature? Simply click on the external port number, edit the number, and retest. Through my research I discovered that my AT&T uverse modem did not like the odd number port between the two even numbered ones. If I changed the odd port number to a new even number then, using a port forwarding checker, all ports worked. This took a bit of work to figure out. Tablo support told me it was an AT&T problem so I spent a few hours with them to no solution. I knew if I could just change the one odd external port all would work. Sure would have been nice if someone at Tablo knew how to do it… Anyway, all’s well that ends well. Happy Tanksgiving!

@jeffdomo Just saw your post and I'm glad you figured it out. I agree with you. If Tablo support had told us how to change the ports (even if we don't have an iPad, Android tablet or a Kindle) it would have helped. We could have borrowed a friend's device just to change the ports. It would have saved me a lot of headache and some 5+ hours of troubleshooting my router! I can only think of 2 reasons: either the support team didn't know this port configuration feature existed only in the tablet app or they didn't know the 2100X ports was causing the issue with AT&T routers.

I just checked the tablet app in a Google Play Android tablet (not Kindle) to see if the port text inputs are editable. Yes, you can edit it in the Android tablet app as well, although getting the keyboard to popup in the editable text inputs is tricky!

So to summarize: only the Tablo tablet app from Apple, Amazon and Google Play provides the option to configure the port numbers inside the Tablo DVR. The port configuration page is accessible from the settings page.

This support page (Chapter 6) talks about this feature but doesn't tell you it's only available in the tablet app:

This port configuration feature is not available in the Tablo Web app for phones available in Google Play:

Also, if you disable remote access in the settings page and re-enable it then you'll have to change ports again from 2100X to 3188X or the ones that work in your router. In other words Tablo DVR defaults to 2100X when disabling and enabling the remote access.

Hope this helps others save some headache!

p.s: I wanted to include some screenshots of the tablet app but there's no option to attach images directly in this forum. 

@jeffdomo @rameshts Sorry for all the confusion, folks. We’ll be updating our documentation with a separate article to reflect these changes. 

We recently discovered that some ISP’s are reserving the standard SSL port, which caused some problems and required some changes on our end to allow for the use of an alternate SSL port. 

However - this wasn’t directly related to the ability to change/alter the external ports the Tablo can use for the port mapping process. We’ll be publishing some updated documentation on that as well.