Tablo connect port forwarding Uverse

I would like to confirm I correctly mapped my port in Uverse router and if so, any suggestions of what else I can try to get Tablo Connect configured.

  1. at my uverse router, I opened “pinhole”. To do this, I had to map a port to host port. Is the private port the host port? (I actually tried it both ways but neither worked).
    For Uverse, I had to create an application with port, and a map to host port. I entered 21131 for port (Public port on Tablo connect) and 8887 for map to host port (Private port on Tablo connect). Is this correct or do I have them reversed?

  2. I gave my Tablo a static IP and I unchecked Stealth mode which was a suggestion in other posts.

  3. When I look at my router log, I see a message that Session Matches User Pinhole, Packet Passed.

  4. When I look at diagnostics I see that 21130 and 21131 are listed for both the tablo and the outside gateway.

  5. I do have a Dlink router that is acting in bridge mode only and the Table is connected to it via ethernet. While I do not think that is an issue, I did try bypassing the Dlink and it did not help.

Any suggestions of what I can try next? Thanks

Tablo needs two ports forwarded. Did you do both? It uses 8887 and 80. So you’ll have one pinhole for each, with two different public (outside) ports. In your case 21130 and 21131. One gets forwarded to 8887, the other to 80.

These are the port mappings shown in my router:

External port 21030 gets mapped to Internal port 80, protocol is TCP
External port 21031 gets mapped to Internal port 8887, protocol TCP

I can’t be certain, but I think the external ports may have changed at some point, but the ones I’ve shown above are the ones that are currently in my router, and I know that they work.

Yes I did both ports. Can you confirm the ports I forward to are “host ports” (so I know I did not do it backwards). I’m not real techie

Assuming I did them correctly any other ideas?

The ones I used are the ones that came up on my iPad app. I did read that some people used something else and I tried it. I will try yours …
Can you confirm that I need to have 80 and 8887 as host port?


Can you post a screen shot of that config page? Unfortunately, not everyone uses the same terminology. It’s usually called Public port and Private port. I’m not 100% sure what they mean by host port.

Here are some shots of the manual. I really appreciate the help!

They are referred to as External and Internal ports on my router… your router may be a little different in that the External ports are referred to as Global Ports or Global Port Range and the internal ports are referred to as Base Host Ports, or possibly Host ports. Not knowing your specif router make/model, I can’t say for sure, but this should get you there.

In Step 2, you’re going to put in the IP address of the Tablo.

You’re going to need to add two profiles, one for each IP address the Tablo wants.

The Port (or Range) entry will be 21130 mapping to host port 80 and 21131 mapping to host port 8887.

Rats. That is what I did and it does not work. Another user suggested I use different ports (different from 21130 and 21131)…

Check this out from Tablo support… the ports are different yet! This posting was fairly new.

The Tablo recommends that you use relatively high (and uncommon) external port numbers. This won’t be the same for all Tablos, though. Note: you can change the port numbers you want to direct the rules to in the Settings screen at

Thanks. I have tried the one that started off in my app, as well as two others recommended. I’ve used 21131, 21130; 31881,31882; and 21031, 21030. None worked. my next step is to call in since I tried email support and this forum.

So I just signed up for AT&T 1Gb Uverse service and worked on the same problem until 1:30am with no joy. So though my Tablo shows it has a 192.x.x.x IP Address and I selected it in the Step 1 portion, in the Port Forwarding status, the ports for 8887 & 80 are shown to be pointed at a 172.x.x.x IP address. I’m thoroughly confused?

If it’s 172.16.x.x it’s a class B address subnet mask

Versus the typical class C address 192.168.x.x subnet mask 255.255.255.x.

Assuming you only have one DHCP server and depending on router model you should be able to log onto the router and go to the “settings” menu. There should be a LAN menu which contains the DHCP information and another menu for address allocation.

When I signed up for AT&T 1GB service and got a new router, what I had done previously started working. I will mention highlights - if this is all foreign let me know and I will provide more detail.

You need to go to Applications, Pinholes, and DMZ under firewall.
Add 2 user defined applications. One to forward to 8887, and one to forward to 80
Then select the tablo and add the defined applications to it.

So I thought I did just that, but as I read some of the other comments above, I think I’m doing this wrong please advise…

For example, I’m putting from port 8887 to 8887, leaving Map Port blank or putting 8887, and labeling it Tablo. Tablo2 is from 80 to 80, Map Port 80.

As I read the comments above, am I for Tablo to put from 21130 to 21130 Mapping to Port 80, and for Tablo2 from port 21131 to 21131, Mapping to Port 8887? Maybe that’s where I’m getting crossed up?

Your last paragraph is what you need to do.

Tablo to put from 21130 to 21130 Mapping to Port 80, and for Tablo2 from port 21131 to 21131, Mapping to Port 8887

And don’t forget to associate the Tablo and Tablo2 with the actual Tablo device (chosen in select computer, but it shows up as unknown)

1 Like

Now I understand, sorry about that. Couldn’t see the forest because of the trees. :blush:

1 Like

That worked. thanks guys