Tablo connect issues port forwarding

So I had posted that I had an issue getting my tablo connect even though it was working for a year+. I finally got it working again but it will only stay working for about 24 hours. I currently don’t have to port forward to get it to work, but when it fails it tells me to port forward. I turn the connect function off then on and it will work for another 24 hours. So I figure I will just port forward. Except I am using xfinity xfi modem and router and when I goto port forward it only gives me an option to put one port in. I can’t say forward 80 to port 27006. I can put one of those numbers in only. Has anyone successfully forwarded using the xfinity xfi router? If so how did you enter then ports to forward? Thanks!

1 Like

Do you have UPnP turned on? If so then turning remote access off then on again in Tablo should setup the proper ports in your router. It’s been a long time since I messed with this but if you turn remote access off then on again several times does it setup new ports each time in your router? If so you may have to do some cleanup to get rid of any unused forwards. I believe an old Belkin router did this to me and could make a mess of things that I’d have to clean up.

Sorry not that router, but mine will stop sometimes too with a D-Link Wifi 6 one. All I do is reenable Tablo Connect and it sets all the ports itself. Sometimes I have to turn the setting off and on a few times to get it to work or it will tell me to configure the ports myself.

I have almost no experience with that router but a quick Google search gave me this.

"Log into your modem, and go to the advanced options. You should see "Port triggering" as something you can set. In there you can configure an external port to forward to a different internal port."

Port triggering is a bit different then regular port forwarding so I’m not sure if will work.

If I remember correctly you can’t replace your router. I would ask Xfinity if I could replace it with a more configurable model. Others have told me they simply added a second router to their network that connects to the Infinity router. That would give you th functionality you want.

Thanks I was thinking of setting up a second router that is more configurable. As it is I have it working but every half to full week I have to go in and disable connect and upnp and then enable everything back up. Since I set the tablo on a static ip in the router it works without reconfiguring the devices I have outside the house. Also, I can remote into my plex server computer and use that to reset the router when I am away from home if I have to. I’m on the verge of giving up and switching to the airtv. If it wasn’t for the commercial skip feature I would have already. If I ever lose that I will switch I think.