Tablo channel on Plex stopped working / can't reinstall

My Tablo is working fine. My Plex server (running on a Mac Mini with Yosemite OS) is working fine and I can get every channel EXCEPT Tablo. The Tablo channel was working yesterday but today it was just hanging. Eventually, I decided to uninstall the Tablo plugin and then reinstall it. However, when I tried doing it, the installer would just hang. Occasionally, I would check the directory and would see a checkmark on the Tablo plugin, but it would not be listed on my list of channels.

Has anyone experienced this problem? Any ideas as to how to get Tablo working again as a Plex channel/plugin? I have a suspicion that I may have to delete certain files from my Plex server to get a “clean” install, but I’m not sure how to do that on my Mac.


It is a bug and is being fixed ASAP… Might take some time for Plex to push it though

Wow! That was quick. Thanks!

@horizonjob, thank @Davidvr for fixing fast :wink:

It’s weird, though. Working great before today. Nada today. I installed and uninstalled other channels, restarted my Plex server, etc., but no joy. The checkmarks showing that the channel had been reinstalled when it was just hanging up was a cruel tease. I love my Tablo, having cut the cord (or in my case, the line from the satellite dish) around Thanksgiving. I can still watch on the native iOS app, but I recently got a Smart TV and I enjoy watching on the big screen.

Of course, a native app on my Samsung Smart Hub would be even better. I don’t suppose that’s coming down the pike anytime soon. :wink:

@Davidvr  My situation is similar – but different.  This morning I found the Tablo Channel missing from my PLEX channel list.  When I went to reinstall it, I found that it was still “Installed”.  I have tried uninstalling and reinstalling to no avail.  The little thingy just spins and spins.  This has happened in the past and I have followed board suggestions to manually uninstall bits and pieces that remain after a formal UNINSTALL.  That worked in the past but no-go today.  Obviously,  I need some more help!  Thanks in advance.

@JohnT it is the same issue… The bug is causing it

I just checked the Plex github, Davidvr’s pull request has not been done yet so you will have to wait until they do it.

So I have the same problem I restarted my Plex server and the Tablo app is no longer there, will it return to my channels automatically after the update is fixed? or do I need to do something different?

I think we’ll just have to wait and see. I did several attempts to reinstall. It’s uninstalled now, and I will wait until I hear that the fix has been implemented before trying another install.

Not to sound like a broken record, but wouldn’t a native smart tv Tablo app be nice?

@mb190e yes it should

@jestep thanks, I also noticed a couple other channels are not working properly ABC and CBS lets you can navigate all the way to the show, but when you click play gives you an error.

@mb190e I tried ABC right now and I did not see an error, but when I click play it comes right back. Looking at the log for ABC I saw this on one show… But others played ok.:

302 is URL redirection and apparently it is not working.

2014-12-12 10:27:44,539 (11424a000) :  DEBUG (runtime:106) - Sending packed state data (104 bytes)
2014-12-12 10:27:44,539 (11424a000) :  DEBUG (runtime:918) - Response: [302] Redirect, 0 bytes
2014-12-12 10:27:44,542 (113a44000) :  DEBUG (runtime:106) - Sending packed state data (104 bytes)
2014-12-12 10:27:44,542 (113a44000) :  DEBUG (runtime:918) - Response: [302] Redirect, 0 bytes
2014-12-12 10:27:44,570 (113e47000) :  DEBUG (runtime:106) - Sending packed state data (104 bytes)
2014-12-12 10:27:44,571 (113e47000) :  DEBUG (runtime:918) - Response: [302] Redirect, 0 bytes
2014-12-12 10:27:44,610 (114a50000) :  DEBUG (runtime:106) - Sending packed state data (104 bytes)
2014-12-12 10:27:44,611 (114a50000) :  DEBUG (runtime:918) - Response: [302] Redirect, 0 bytes

Might want to check the logs

@jestep yeah I tried a couple other shows and it seems to be working

@horizonjob Native apps would be really cool, and i’m sure they are on the radar. I very thankful the web app works great on my new LG, so much so I haven’t even hooked back up my roku :slight_smile:

No completed pull request yet, looks like we’re f’d for the weekend.

I was wrong - the pull request was committed 2 hours ago - it works well folks.

Thanks to Davidvr and Plex!