Tablo app does not and never has worked

It’s as simple as this. We’ve had our Tablo since Christmas and really like it with one excetion. While the Tablo works great with our Roku TVs and our LG TV, It flat out will not work on our Android devices. We’ve tried everything that the comunity has suggested but without any success. Please don’t ask the obvious questions. Yes I’m sure we’re on the same network. Yes, we have tried resetting a)the network, b) the modem, c) the tablo device itself, and d) the android debices. We have two Samsung Galaxy S10+ phones, and two Samsung Tab A devices. What am I missing?

Instead of listing what you’ve tried, you tell people who might be inclined to help not to ask obvious questions. What are you missing? Manners.

When I get a chance (after work), I will try my Samsung Tab A to see if I can duplicate your results. I hardly ever use the tablet or my android phone for Tablo viewing.

Sorry, must ask obvious questions.
What Android OS versions?
What does it flat out will not work mean?
The Tablo app won’t open at all?
The Tablo app opens, but crashes before connecting to Tablo?
The Tablo app, opens and connects to Tablo, but there’s no Live TV grid?

Unfortunately, then you’ve come to the wrong place.
We are masters of obvious questions.

The fact that we ignore requests to not ask obvious questions. :slight_smile:

1 Like

Every day I use the Android Tablo app (and preview version) on a Nvidia Shield.
The Android App also works on a Chromebook, a Moto G6 phone, a really old Samsung tablet, and an old Moto G4 phone.

So specifics on what issues you are having might help.

“Not work” can mean multiple things on the Tablo.

  1. The app doesn’t launch at all (highly unlikely, but if so, delete the app and reinstall).

  2. The app doesn’t see any Tablos on your network. If that is happening, we would need more info on your network setup.

  3. The app sees your Tablo but never successfully connects.

  4. The app connects to your Tablo but can’t do one of more features (live tv, play back recordings, Tablo connect, etc).

  5. Everything works but there is no sound. You would need to turn surround sound off, since it isn’t supported on Android phones.

3 and 4 likely would need a support ticket.

Just finished checking my Samsung Tab A. I was able to connect, sync, watch live TV and recordings.
The only trouble I had was with my wifi 5GHz channel. I chalk this up to the wireless channel and my distance/obstacles to the router or the tablet’s wifi chip. Once I switched to the 2.4GHz channel on my tablet, everything worked.

1 Like

Today I connected to my 3 y.o., 4-tuner Tablo REMOTELY using my new Google Pixel 3a XL (Pie) and an older Samsung Galaxy Tab S2 8.0 (Nougat). I’ve previously connected to my Tablo at home and while travelling on other, older Android devices including Samsung and Motorola phones. I hope you resolve the issue that is preventing you from enjoying your Tablo on your Android devices.

Android app runs fine on a old RCA quad-core (1.2 ghz) 32 gb tablet running Android 5.0. Also ran fine on an older Samsung S5 mini, with similar horsepower.

Please be more specific with your setup, so that perhaps someone here may offer some positive suggestions.

Point us to where you got “everything the community suggested”.

I’ve experienced no problems with Android app on these platforms:

  1. Air TV box (first generation, first version with periodic updates)
  2. Stream+ DVR from Channel Master
  3. Xiaomi Mibox
  4. Matricom Gbox Q3
  5. Nvidia Shield

I’m one of the least technically-inclined members of these forums, each of these platforms was up and working within twenty minutes of unpacking. All instances listed here have been plug-and-play, all connected through wifi.

Three days ago this guy joins - looks at 2 topics reads 5 posts, creates a topic claiming something never worked suggesting he already tried the obvious things so don’t bother. He’s too smart to overlook anything…

Never been back, since he already knows but doesn’t want to admit, yet 3 days later, everyone still wants to prove him wrong? If we’ve surpassed the threshold of three days and indication of wanting any actual assistance…

You have not missed anything. It’s obvious the Tablo app does not and never has worked, it’s a conspiracy to think it has or will.

Shut up man! I’ve put a lot of time into making this thing appear to work!!! My wife is still convinced I do 90% of my TV viewing on my Android tablet and Android phone. If she’s finds out I’ve been faking… well I don’t know what will happen. I hope noone finds out about the underwear gnomes. PS. I hate autocorrect!

Works fine for me on my Amazon FireHD devices and my cheapo Walmart “ONN” 10.1 tablet … I didn’t do anything special other than install it … I am going to chuck this one up to what we refer to as “user failure”…

1 Like

I bet he sorted out what it was he did and it was really embarrassingly dumb and is really ashamed and horrified to come back and post what it actually was … (user failure/operator error)


User incompetence is a more accurate term, however is not very politically correct.

You’ll notice there’s a lot of post regarding the new commercial skip in particular where users are absolutely certain their setup was properly configured and didn’t work - often the reply included a RTFM type excerpt – read… it doesn’t work with the application you’re using or it doesn’t work on the news!

don’t use hands to stop blades | don’t use knife to dislodge toast | don’t use [ointment] on sensitive areas

Owh dude. You could try “at least I’m not as bad as…” excuse. You know, it could always be worse, so this isn’t so bad, now is it?